Amps indicator light on dash is on - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 01-10-2002, 09:23 PM Thread Starter
Matt Graham
Registered User
 
Matt Graham's Avatar
2001 TJ Wrangler 
 
Join Date: Aug 2001
Location: LaGrange
Posts: 1,533
Post Amps indicator light on dash is on

My brother has a 74 CJ-5 with a 304. He says he was driving in town and at a red light it started idling funny and then the amps light on the dash came on and the jeep went dead. He couldn't get it to crank. I think it may be the alternator (or does it have a generator), and if it's a generator what do they cost and where do you get them?

Thanks for the help,


Instagram: @mattgraham79 - http://instagram.com/mattgraham79
Youtube: http://goo.gl/ar21Wp
Matt Graham is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-11-2002, 02:38 AM
JIM79CJ7
Registered User
 
JIM79CJ7's Avatar
 
Join Date: Nov 2001
Posts: 309
Post

It's an alternator and you should be able to get it at any local parts store
GOOD LUCK,

JIM

originally posted by Mikeythefireman :
Mr. Bill, you're a Jacka$$! or should I say 'drack you're a Jacka$$ I was looking for a straight answer there.

Custom Stuff--- JC Fab & Design
ORANGE JEEP CLUB
MEMBER # 1

1979 CJ7 / 304 /T 150 /HUGGER ORANGE PAINT JOB/ Lots of cool stuff
2003 Inca Gold Rubicon , <------ Sissy jeep :)
JIM79CJ7 is offline  
post #3 of 4 Old 01-11-2002, 08:09 AM
CJeep
Alpha dog
 
CJeep's Avatar
1982 CJ8 
 
Join Date: Apr 2001
Location: Near Fairfield, CT
Posts: 1,216
Cool

Based on what happened, I'd check all of the wiring connections first; from the battery on down. Something may have wiggled lose.

'82 Scrambler - NV4500/4.5" lift/33" Toyo MTs/4.0/twin stick, and my windshield washers work! Full 1/2 cab Cage

2004 Grand Limited 4.7 HO - OH Boy!

2010 Grand Laredo 5.7 Hemi - SICK - work vehicle -gone - replaced by an 08 Tahoe - nice ride.

"Both my Doberman and my Jeep can accurately be described as 'black and rust.'"

"I got a fever . . . and the only prescription is more cowbell"
CJeep is offline  
post #4 of 4 Old 01-11-2002, 10:15 AM
Guy Hollister
Registered User
 
Join Date: Sep 2001
Location: Auckland, New Zealand
Posts: 283
Post

Mine had same.... a wire had come off the back of the Alt... very obvious and instant fix. Just go for a run in the Jip after you jump it as you'll need to charge up the battry.

g

1984 RHD CJ7
1979 LHD CJ5
Guy Hollister is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
CJ7 Dash Indicator Lights Woolys_CJ7 Jeep CJ Forum 6 06-09-2009 06:39 AM
'74 CJ5 Amps Light flickering?? Scuter83 Jeep CJ Forum 2 08-28-2008 08:48 AM
Dash indicator lights not working onesourcemike Jeep CJ Forum 4 08-11-2008 07:58 AM
need help - dash indicator order TexasGuns Jeep CJ Forum 3 12-02-2007 09:09 PM
AMPS Light STRATAS 83 CJ-7 Jeep CJ Forum 2 07-06-2002 12:11 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome