Alternator noise and slight engine miss, related? -

LinkBack Thread Tools
post #1 of 1 Old 04-25-2013, 01:08 PM Thread Starter
Registered User
1980 CJ7 
Join Date: Mar 2011
Location: chandler
Posts: 339
Alternator noise and slight engine miss, related?

I'm noticing the alternator doing a faint hum/purr noise on and off. Mixed in with that, the engine is doing a faint miss also.

I test the battery to see the voltage and it's holding at 14.4. Is AMPS a bigger factor in this(measuring output from alt) to determine if the 2 are related?

Also, what are some common issues that attribute to a miss on the 4.2 with fuel injection? I might be chasing something else besides the alt.


offroadz is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome