Accelerator pump just stopped working -

LinkBack Thread Tools
post #1 of 3 Old 05-28-2009, 02:02 PM Thread Starter
Registered User
1983 CJ7 
Join Date: May 2009
Location: Texas Hill Country
Posts: 6,494
Accelerator pump just stopped working

I was driving back from the parts store all proud of myself for how much better it was running when, out of nowhere, I got a stumble on acceleration. After checking it I saw that there's no squirt, nowhere nohow.

It also decides at it's leasure to increase the idle sometimes, which makes going into first gear sound like an old school bus.

Why do I always end up with a "California Emissions" vehicle. I've never even lived there!

Any ideas!

tuning Holley carburetors

swatson454 is offline  
Sponsored Links
post #2 of 3 Old 05-28-2009, 04:00 PM
BESRK's Avatar
1980 CJ5 
Join Date: Nov 2002
Location: Newport News, VA
Posts: 12,285
Debris (rust or dirt) in the float bowl finding its way into the pump circuit?

'80 CJ5 w/AMC360, T176, D44 w/Detroit 4.56, RE 4" YJ lift and 35s..

Lower 2


Down Schoolbus

Slickrock Tellico



More Crozet
BESRK is offline  
post #3 of 3 Old 05-28-2009, 04:23 PM Thread Starter
Registered User
1983 CJ7 
Join Date: May 2009
Location: Texas Hill Country
Posts: 6,494
Not sure exactly what caused it but the diaghram was stuck at the bottom of the well.

This thing definitely has intermittent idle/running issues so I'm off to get wire for the Nutter Bypass. I had an 86 Blazer with all of this crap on it failing one little part at a time so I'm not playing this game again!

So what controls the dizzy now that the cpu is bypassed? Can't just be vacuum.

tuning weber carburetors
swatson454 is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Carter BBD problems--accelerator pump? jjdtaylor Jeep CJ Forum 15 11-22-2010 03:00 AM
Wipers Stopped Working... poppatello Jeep CJ Forum 4 02-08-2010 04:29 PM
Need new accelerator pump - Leather or Rubber? mjfitz99 Jeep CJ Forum 0 08-07-2009 07:03 AM
Carter BBD accelerator pump adjustment? obscurotron Jeep CJ Forum 0 10-08-2007 03:41 PM
accelerator pump daytoncj Jeep CJ Forum 3 05-28-2003 11:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome