Accelerator Cable Problems - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 09-26-2011, 04:38 PM Thread Starter
Noplainsdrifter
Registered User
1974 CJ5 
 
Join Date: Jul 2011
Location: Hillsboro
Posts: 513
Accelerator Cable Problems

I have a 74 CJ5 with a AMC 360 and Edelbrock carb. I have always had trouble with my linkage. I have used everything from a coat hangar to what I think was a OEM cable and nothing seems to last or work very well. I was wondering what everyone else is using. Part numbers and or pics would be great!


It's a Jeep Thing, Chrysler Doesn't Understand!
Noplainsdrifter is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Accelerator cable dawgs30814 Jeep CJ Forum 4 02-18-2010 03:37 PM
1979 Accelerator Cable manderson2228 Jeep CJ Forum 1 12-19-2009 10:24 PM
Accelerator Cable pscj5 Jeep CJ Forum 10 02-17-2009 06:35 AM
Accelerator cable help Quentin Jeep CJ Forum 4 01-14-2008 04:23 PM
Why doesn't this accelerator cable fit? (pics) RLBJeep Jeep CJ Forum 11 03-10-2007 01:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome