83 cj 7 - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 08-26-2013, 12:01 PM Thread Starter
Rick66002
Registered User
1983 CJ7 
 
Join Date: Aug 2013
Location: Atchison
Posts: 4
83 cj 7

ok bought this thing 6 years ago, drive it for allmost 2 years and parked it. so just put new tank, sending unit all fuel lines and pump, dist,cap rotor,plugs and wires, and had the carb rebuilt. in town runs great put it in 4 gear and it falls on its nose I have to baby it to get up to 60 mph but it will go. Any xtra gas pedel and she spits and sputters

Rick66002 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 08-26-2013, 03:52 PM
LumpyGrits
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: The Mojave Desert - Palmdale, Ca. U.S.A.
Posts: 6,465
Change the fuel filter.
Does it 'flood' out or run out of fuel in 4th?
Run prem. gas.
Ck your fuel pump for psi.
Get a REAL factory shop manual!
LG

Have'n you along, is like loose'n 2 good men
LumpyGrits is offline  
post #3 of 9 Old 08-26-2013, 04:57 PM Thread Starter
Rick66002
Registered User
1983 CJ7 
 
Join Date: Aug 2013
Location: Atchison
Posts: 4
has new fuel filter and pump, but i have access to a pressure tester
Rick66002 is offline  
post #4 of 9 Old 08-26-2013, 05:00 PM
LumpyGrits
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: The Mojave Desert - Palmdale, Ca. U.S.A.
Posts: 6,465
Pull carb and rebuild it.
Bet bowl is a mess.....
LG

Have'n you along, is like loose'n 2 good men
LumpyGrits is offline  
post #5 of 9 Old 08-26-2013, 05:02 PM
kovic
Registered User
1983 CJ5 
 
Join Date: Apr 2012
Location: Grand Rapids
Posts: 748
He said he had it rebuilt. But if you have to baby it to get it up to speed its probably running way to rich. I would pull the carb and rebuild again.

kov
kovic is offline  
post #6 of 9 Old 08-26-2013, 05:09 PM
LumpyGrits
Registered User
1985 CJ7 
 
Join Date: Jul 2010
Location: The Mojave Desert - Palmdale, Ca. U.S.A.
Posts: 6,465
Quote:
Originally Posted by kovic View Post
He said he had it rebuilt. But if you have to baby it to get it up to speed its probably running way to rich. I would pull the carb and rebuild again.

kov
Yes he did, and I missed that.
OP-How did it run before the carb rebuild??
LG

Have'n you along, is like loose'n 2 good men
LumpyGrits is offline  
post #7 of 9 Old 08-27-2013, 02:00 AM
BagusJeep
Registered User
1981 CJ7 
 
Join Date: Jul 2009
Location: Bali
Posts: 5,492
HAve you checked the timing and the advance mechanisms? Is the engine well grounded? It may be an ignition related issue, remote but possible.

BagusJeep lives in Bali.

1981 CJ7 258ci - Bagusjeep
1984 CJ7 258ci - Puthijeep
1981 J20 258ci - Gladys
1951 Willys CJ3A/MB/M38 - Little Willy
1995 Cherokee 4.0 - CHEROKEE
BagusJeep is offline  
post #8 of 9 Old 08-27-2013, 09:32 AM Thread Starter
Rick66002
Registered User
1983 CJ7 
 
Join Date: Aug 2013
Location: Atchison
Posts: 4
LG it wouldn't even run in 4 th had to drop it down to 3 rd and ran good
Rick66002 is offline  
post #9 of 9 Old 08-27-2013, 09:36 AM Thread Starter
Rick66002
Registered User
1983 CJ7 
 
Join Date: Aug 2013
Location: Atchison
Posts: 4
the only thing we have not been replaced is the ignition module
Rick66002 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome