4x4 problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > 4x4 problems

Bill Baird Motorsports DIY parts - NalinMFG.comFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 09-08-2002, 10:20 PM   #1
onesojourner
Registered User
 
Join Date: Jul 2002
Posts: 101
4x4 problems

well i finally got the elctrical bugs out of my 79 cj 7 with 304 and a 3spd and i took it out yesterday and did some off roading then i started hearing this clicking sound. and it just got worse. so i unlocked the hubs when i got back on the road and it went away so what do you guys think it is? transfer case maybe?


Last edited by onesojourner; 09-09-2002 at 02:55 PM..
onesojourner is offline   Reply With Quote
Unread 09-09-2002, 04:54 PM   #2
onesojourner
Registered User
 
Join Date: Jul 2002
Posts: 101
oh and it wasnt just diong it in 4 wheel drive. it did it in 2 wheel also. but it goes away when i unlock the hubs.
onesojourner is offline   Reply With Quote
Unread 09-09-2002, 06:03 PM   #3
jeepdaddy2000
Web Wheeler
 
jeepdaddy2000's Avatar
1971 CJ5 
 
Join Date: Jan 2002
Location: Eagle Point Oregon
Posts: 6,116
Rusty or improperly assembled hubs, bad spindle bearings, bad axle U joints, or bad front driveline U joints. I think that should cover the simpler causes.
jeepdaddy2000 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.