4.2L will crank but won't turn - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 08-14-2009, 04:59 PM Thread Starter
gmchx4
Registered User
1983 CJ7 
 
Join Date: Aug 2009
Location: Lake of the Ozarks
Posts: 4
4.2L will crank but won't turn

I have dreaded asking this question all week but I have exhausted all known options to myself. Last weekend it started just fine, no problems. This week, I have removed the dash and unplugged the guages to check the connectors, then plugged everything back in according to wiring diagram (NO guages were actually replaced). Also, I replaced the ignition key lock cylinder. The last two small things that I have worked on since the last time it started was I replaced the windshield washer fluid motor, and worked on the wiring harness for my headlights to get both lights to work on both settings (high and low beams). After those few things, I went today and can not get it to turn over. It just cranks and cranks and cranks but no fire. I beleive the coil has good power because I got a spark when disconnecting and reconnecting the two wires that go to it. It's the 4.2L with an MC2100 carb, other than that I can only assume the other parts are oem or oem replacements (I have only had the CJ for about two weeks now, and it ran fine as of last weekend). It's unknown to me why, in a week's time, it won't start after all i have done s mess with electrical systems, but nothing in th engine bay on the major components. Any help here would be much appreciated.

THANKS

gmchx4 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-15-2009, 05:29 AM
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant
Posts: 18,089
Quote:
Originally Posted by gmchx4 View Post
IIt's unknown to me why, in a week's time, it won't start after all i have done s mess with electrical systems
Chuckle....

I don't know where to start....

Off the top, there is one connection under the dash on the later ones that controls the tach. This is a large red wire off the ignition switch plug and it also controls the power to the ignition module. If you unplugged a stock tach, the engine won't start.

Then there should be two small wires off the fender soleniod in the engine bay on the side of it, maybe one got knocked off?

You need a multimeter and a helper so you can see if the coil is getting power when the engine is cranking over as well as when the key is in run. These are two separate circuits.

Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is offline  
post #3 of 3 Old 08-16-2009, 12:14 PM Thread Starter
gmchx4
Registered User
1983 CJ7 
 
Join Date: Aug 2009
Location: Lake of the Ozarks
Posts: 4
got it to start this morning! i feel dumb after fixing it but at least i can get back to driving her lol. it turned out to be a bad ground wire coming off the white, ceramic regulator on the passenger fender, the wire was going to the coil. anyway, the wire was shorting out and after replacing it and the connector, it fired right up, better than when i first bought it haha

thanks for the help, great info for when i go to add my tach this winter ...
gmchx4 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
4.2 will crank but won't turn, went for a bad swim. apfroggy0408 Jeep CJ Forum 15 10-13-2009 09:59 AM
85 CJ7 will crank but wont turn over? HRW85CJ7 Jeep CJ Forum 18 09-29-2009 03:42 PM
4.2L I6 will crank but not turn over rcawrse Jeep CJ Forum 16 07-28-2009 10:34 AM
74 cj5 401 will crank but wont turn over sherman401 Jeep CJ Forum 6 06-03-2009 04:47 PM
4.2L 73 cj5 will crank but wont turn.??? 73CJ-5 Jeep CJ Forum 16 06-27-2008 07:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome