JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   Jeep CJ Forum (http://www.jeepforum.com/forum/f8/)
-   -   304 will not turn off when key turned off and removed (http://www.jeepforum.com/forum/f8/304-will-not-turn-off-when-key-turned-off-removed-1545743/)

Tweeter00801 07-06-2013 05:00 PM

304 will not turn off when key turned off and removed
 
I could use some help.

The 304 runs beautifully, but today for some reason, when I turned off the key, the engine did not quit while at the gas station. I accidentally turned it too far in the 'on' position, which gave power to the started, then returned the key to the 'off' position and only then did it turn off.

I returned the Jeep to my garage and turned the key to the 'off' position, and the engine would not turn off when I turned the key to the 'off' position. I could even removed the key. Nothing changed. I activated the starter by turning the key all the way 'on', and again, the engine would turn off. I don't want to do that again if possible.

Both instances, the engine ran exactly the same with the key in the 'on' position, and when the key is removed. In both instances, with the engine on, when I turned the key as if I was going to start it, the starter squelched, and the engine died when I turned the key to the 'off' position.

The Battery and Selenoid are new within the last 6 months. It runs great. The only thing I have done recently was change the engine oil, changed the transmission oil, and changed the headlights to KC-Hi-lites. I don't think I've done anything that would cause an electrical issue.

Any thoughts?

draperjojo 07-06-2013 05:30 PM

You may want to double check the ignition switch down on the steering column if it's like my jeep. There is a little bit of adjustment..... do a search on it here.

LumpyGrits 07-06-2013 05:56 PM

Bad ign. switch contacts.
LG

jeep_boy02 07-07-2013 12:11 PM

x2 on double checking the switch and x2 on getting a new one... Have put three in mine and just feel like the system isn't a good design/ weak or cheaply made.

Elkaholic 07-07-2013 02:04 PM

Same thing happened to me.. it was the switch at the bottom of the steering column.

LumpyGrits 07-07-2013 03:03 PM

Quote:

Originally Posted by jeep_boy02 (Post 15650356)
x2 on double checking the switch and x2 on getting a new one... Have put three in mine and just feel like the system isn't a good design/ weak or cheaply made.

It's a GM column :thumbsup:
Ain't nut'n wrong with it.....Look at all the dirt we get into :thumbsup:
LG


The time now is 07:19 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.