304 dies when put in gear - JeepForum.com
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > 304 dies when put in gear

6th annual beat your wife to the credit cards sale!!Get ready!! CyberMonday deals are coming!!!Last few hours of great savings JeepHut.com

Unread 01-18-2010, 01:18 PM   #1
Registered User
1999 TJ Wrangler 
Join Date: Dec 2007
Location: Arizona
Posts: 201
304 dies when put in gear

Hey, I just did a 4bbl uprade on my 304. I put a Holley 4180 on it (600cfm). I have everthing adjusted and hooked up but whenever i put it into gear it kills the motor? What do i need to adjust? Also i have an automatic transmission.

1999 TJ Custom 3 Link, 2.5" FOA Coilovers, 4.88 gears, Trussed D30, Locrite lockers, 35" MTR's

85' CJ7 Project "Bentsome"
In Progress

Last edited by locked-up-XJ; 01-18-2010 at 03:37 PM..
locked-up-XJ is offline   Reply With Quote Quick reply to this message

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Suggested Threads

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.