2000 Jeep Wrangler dies at idle frequently - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep CJ Forum > 2000 Jeep Wrangler dies at idle frequently

6th Annual, Beat Your Wife to the Credit Card Sale!50 in light bar /A pillar mount less than 500 at JeepHut.cFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome Effect

Reply
Unread 11-26-2014, 05:28 PM   #1
mustangjeep
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2014
Location: Delaware, OH
Posts: 2
2000 Jeep Wrangler dies at idle frequently

I have a 2000 Jeep Wrangler 4.0L with 5spd. My Jeep will miss occasionally. It will die at idle frequently. Usually, it will start right back up. It will sometimes give P0340 code.

I have replaced my cam position sensor. I have replaced my crank position sensor. I have replaced my alternator. I replaced the IAC. I cleaned the throttle body. I sent my ECM off to SIA electronics to have it checked. I replaced the throttle position sensor.

The fuel pressure was checked.

I'm scratching my head what else that it could be.

mustangjeep is offline   Reply With Quote Quick reply to this message
Unread 11-26-2014, 05:47 PM   #2
numbersix
Registered User
1979 CJ5 
 
Join Date: May 2013
Location: Newberg, Oregon
Posts: 32
Still throwing the p0340 code after a new cam & crank sensor? Could be wiring or failing ECM.
__________________
1979 CJ-5, mostly stock.
2001 XJ, DD / offroad.
numbersix is offline   Reply With Quote Quick reply to this message
Unread 11-26-2014, 07:09 PM   #3
mustangjeep
Registered User
2000 TJ Wrangler 
 
Join Date: Nov 2014
Location: Delaware, OH
Posts: 2
SIA electronics tested my ECM and it passed their testing.
mustangjeep is offline   Reply With Quote Quick reply to this message
Unread 11-26-2014, 08:35 PM   #4
Ken4444
Corripe Cervisiam
 
Ken4444's Avatar
1985 CJ7 
 
Join Date: Oct 2005
Location: Houston, Texas
Posts: 4,545
I almost thought I was reading the wrong forum
__________________
"I give you a republic, if you can keep it." - Benjamin Franklin
Ken4444 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.