1984 CJ 7 Lighting Issues - JeepForum.com

LinkBack Thread Tools
post #1 of 2 Old 11-15-2012, 05:00 PM Thread Starter
Registered User
1984 CJ7 
Join Date: Oct 2012
Location: Orange County
Posts: 10
1984 CJ 7 Lighting Issues

I'm working on dialing in all of my lights, the following lights work,both headlights, the dimmer switch, both taillights, both reverse lights, passenger rear signal, passenger front side signal, passenger front signal, both front parking lights. The following lights do not work, both brake lights, both rear side marker lights, driver side rear signal, the driver side signal stays on but very dim and doesn't blink, driver front signal. I ran a dedicated ground wire to the driver taillight, cleaned all of the grounding contacts inside of both taillights, opened the rear wire loom fixed any little nicks that I found, I also found a orange and a black wire that I can not find listed on any diagram?? I tested the brake switch through the cruise control pug and it was showing hot when the pedal was depressed. I also check the fuses. Sorry for the long winded write up I just wanted to list where I am at.
Thanks in advance

P00hs84Cj7 is offline  
Sponsored Links
post #2 of 2 Old 11-15-2012, 05:16 PM
Registered User
1984 CJ7 
Join Date: Sep 2008
Location: Logan
Posts: 748
Ha! Wireing can be a nightmare for sure... head around to each light and one at a time pull a buld and use a testlight to see if the socket is getting power. Check for any corrosion in the sockets to while you have the bulbs out look inside them make sure the little coils are not broken. If one of the lights does not have power to the socket reach in behind the light and unplug it, again with the testlight touch each prong see if you have juice. If still no juice open the drivers door and reach under the bottom door jam and unclip the wiring harness and carefully poke each wire you haven't found power in yet. (if the testlight prong slips it will draw blood...)

If you need help I'm up in Logan and might be able to help you out saturday. Send me a Private Message if you do.

row684 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome