1979 CJ Rebuild - JeepForum.com
 
LinkBack Thread Tools
post #1 of 12 Old 09-20-2017, 08:38 AM Thread Starter
babyblue79
Registered User
1979 CJ7 
 
Join Date: Feb 2011
Location: madison
Posts: 38
1979 CJ7 Renegade LEVI Rebuild

Jeep is a 1979 CJ7 Renegade Levi Edition. It was purchased new in 1979 by my dad and I rode home from the hospital when I was born in '81. I have driven it around town for the last 7 years or so but the 304 had gotten weak as a 40 year old motor with 90K miles should. It is basically all original with only a 3 in RC lift and 33 12.5s.

I took it to one of dads buddys that has rebuilt a few 304s and the body is going to paint today. The motor is still in limbo as to exactly what I am going to do with it. UPgraded cam is happening but unsure if I am going to change the intake and go to a 4 barrel instead of the 2. Still have not make my mind up on stock manifold exhaust vs headers. Not looking for mountain climbing power.

Anyway Ill try to keep the thread updated and will probably ask for some advice. I am not doing the work but dad is at the shop and taking pics as it goes.

babyblue79 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 09-20-2017, 08:41 AM Thread Starter
babyblue79
Registered User
1979 CJ7 
 
Join Date: Feb 2011
Location: madison
Posts: 38
SO the motor is out and taken apart. Here are some of the pics I have of getting the motor out and taking the head off. Actually in pretty good shape for a 40 year old motor that has sat up some in its life.















































babyblue79 is offline  
post #3 of 12 Old 09-20-2017, 08:41 AM Thread Starter
babyblue79
Registered User
1979 CJ7 
 
Join Date: Feb 2011
Location: madison
Posts: 38
double post
babyblue79 is offline  
 
post #4 of 12 Old 09-20-2017, 09:06 AM Thread Starter
babyblue79
Registered User
1979 CJ7 
 
Join Date: Feb 2011
Location: madison
Posts: 38
ill figure out the pics shortly
babyblue79 is offline  
post #5 of 12 Old 09-20-2017, 01:19 PM
ADDZ71
Registered User
1979 CJ7 
 
Join Date: Jul 2011
Location: Fort Mill
Posts: 212
I have nearly the same Jeep. Just recently realized that the Wedgewood Blue color was only offered in 1979.
Attached Thumbnails
image.jpg  
ADDZ71 is offline  
post #6 of 12 Old 09-20-2017, 02:57 PM Thread Starter
babyblue79
Registered User
1979 CJ7 
 
Join Date: Feb 2011
Location: madison
Posts: 38
Yep... Did you get a single stage paint of clear coat?
babyblue79 is offline  
post #7 of 12 Old 09-21-2017, 07:01 AM
bob4703
Registered User
1974 CJ5 
 
Join Date: Feb 2015
Location: Easley
Posts: 1,400
Did you notice the loss of power after going to 33s? You could have gearing problem. Go here and do the math http://www.grimmjeeper.com/gears.html

-----

Paved roads are prime examples of government over spending!
bob4703 is offline  
post #8 of 12 Old 09-21-2017, 12:44 PM Thread Starter
babyblue79
Registered User
1979 CJ7 
 
Join Date: Feb 2011
Location: madison
Posts: 38
The loss of power was noticeable before the change but it was more pronounced after the tire swap. It had plenty of power once it got rolling but no torque.


304
T150
D20
3.54 Gears
babyblue79 is offline  
post #9 of 12 Old 09-21-2017, 02:38 PM
ADDZ71
Registered User
1979 CJ7 
 
Join Date: Jul 2011
Location: Fort Mill
Posts: 212
Wanted to add that I shifted from Headers and Side pipes to stock manifolds and dual out the corners this past spring. Much happier with the stock manifolds. Torque and Power I would say is about equal but smell in cab and noise is more reasonable with the top off. I run a hardtop and and hard doors through the winter (Nov-Apr) and it would not matter.
ADDZ71 is offline  
post #10 of 12 Old 09-21-2017, 07:59 PM Thread Starter
babyblue79
Registered User
1979 CJ7 
 
Join Date: Feb 2011
Location: madison
Posts: 38
So I made the decision to make it a frame off today. Wasn't going to but I also don't want to do this again... it's just money right.
babyblue79 is offline  
post #11 of 12 Old 10-03-2017, 08:50 PM Thread Starter
babyblue79
Registered User
1979 CJ7 
 
Join Date: Feb 2011
Location: madison
Posts: 38
















babyblue79 is offline  
post #12 of 12 Old 10-03-2017, 08:54 PM Thread Starter
babyblue79
Registered User
1979 CJ7 
 
Join Date: Feb 2011
Location: madison
Posts: 38
Obviously timing change worn bad. All bearing surfaces worn but the rear one was bad. Body off to body shop in the morning,
babyblue79 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome