Please help identify my Alternator -

LinkBack Thread Tools
post #1 of 1 Old 08-27-2013, 07:22 PM Thread Starter
Registered User
YJames90's Avatar
2012 JK Wrangler 
Join Date: Jul 2007
Location: Dutchess County, NY
Posts: 6,980
Please help identify my Alternator

quick back ground. Running a 1988 4.3 out of an S10 4wd pick up in the jeep with an E fan for the radiator and another e fan for the trans cooler.

At times the radiator e fan acts like its not getting enough juice and turns on and off even though its wired to always be on
The volt meter shows just above or at 12 when running.
I researched what alternator to upgrade to and got one out of a 99 Escalade.
Thought i had to change the plug to the alt but it fits the new alt.
Also read that the pully would be bigger but it may be bay a hair
So the question what original Alt do i have and did i buy an upgrade or waste my money?

Originally Posted by Poke View Post
Spring Over is not for you.... yet

My 2.5 to 4.3 swap thread
YJames90 is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome