Bought this today, just my speed! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 14 Old 04-06-2013, 05:20 PM Thread Starter
tomthbomb
CJ7 1/2 Top Club mem. #1
 
tomthbomb's Avatar
1978 CJ7 
 
Join Date: Sep 2004
Location: Deep East Texas
Posts: 787
Bought this today, just my speed!

Perfect for Caddo Lake. Maybe not so good for Lake Meade.

It will work perfectly with a 14' Jon boat. Will post some photos after the next fishing trip.


http://www.explorecaddolake.com/index.html










1978 CJ-7 original owner; AMC 401 V-8 (w/some goodies);NP4500;D300 (w/Curry 4:1); D44 front;AMC20 (Warn one piece axles) rear
tomthbomb is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 04-06-2013, 06:55 PM
Bean333
Registered User
2003 TJ Wrangler 
 
Join Date: Feb 2013
Location: Boston
Posts: 19
Nice!.. What year is it?
Bean333 is offline  
post #3 of 14 Old 04-06-2013, 07:39 PM Thread Starter
tomthbomb
CJ7 1/2 Top Club mem. #1
 
tomthbomb's Avatar
1978 CJ7 
 
Join Date: Sep 2004
Location: Deep East Texas
Posts: 787
1967

1978 CJ-7 original owner; AMC 401 V-8 (w/some goodies);NP4500;D300 (w/Curry 4:1); D44 front;AMC20 (Warn one piece axles) rear
tomthbomb is offline  
post #4 of 14 Old 04-06-2013, 09:47 PM
Bean333
Registered User
2003 TJ Wrangler 
 
Join Date: Feb 2013
Location: Boston
Posts: 19
Very nice!.. I'm impressed it still has the case!
I run a 3.3 mariner on my 12' mirror craft.... Doesn't compare
To your classic!
Bean333 is offline  
post #5 of 14 Old 04-07-2013, 08:18 AM Thread Starter
tomthbomb
CJ7 1/2 Top Club mem. #1
 
tomthbomb's Avatar
1978 CJ7 
 
Join Date: Sep 2004
Location: Deep East Texas
Posts: 787
I was surprised when I pulled the cover and found two cylinders although it clearly says " YACHTWIN".

1978 CJ-7 original owner; AMC 401 V-8 (w/some goodies);NP4500;D300 (w/Curry 4:1); D44 front;AMC20 (Warn one piece axles) rear
tomthbomb is offline  
post #6 of 14 Old 04-07-2013, 02:27 PM
lespaul_custom
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2008
Location: NWGA
Posts: 282
man that's a nice motor! I have a 1985 evinrude 2hp I use to get around the lakes that allow it. sure makes the trolling battery last longer. Id like to see a video of it running!

Quote:
originally posted by urb4ntroll
Quote:
The weird thing is that I thought I hear a minor bang, almost like a fart sound coming out of my Jeep, but I'm not sure what it was. It has never happened before the glue incident.
www.coosa.org white jeep club #1993 looking to buy complete rear seat belts
lespaul_custom is offline  
post #7 of 14 Old 04-07-2013, 05:07 PM Thread Starter
tomthbomb
CJ7 1/2 Top Club mem. #1
 
tomthbomb's Avatar
1978 CJ7 
 
Join Date: Sep 2004
Location: Deep East Texas
Posts: 787
Quote:
Originally Posted by lespaul_custom View Post
man that's a nice motor! I have a 1985 evinrude 2hp I use to get around the lakes that allow it. sure makes the trolling battery last longer. Id like to see a video of it running!
Will do. It will be a few weeks.

Here are a couple of videos of the same motor I found on YouTube:



1978 CJ-7 original owner; AMC 401 V-8 (w/some goodies);NP4500;D300 (w/Curry 4:1); D44 front;AMC20 (Warn one piece axles) rear
tomthbomb is offline  
post #8 of 14 Old 04-16-2013, 04:46 PM
fillerup
Registered User
2004 TJ Wrangler 
 
Join Date: Jan 2009
Location: Somewhere in Minnesota
Posts: 311
I thought I was the only one who had one of those. Had it for years and I don't use it much any more, I have a 5 hp I use now.
fillerup is offline  
post #9 of 14 Old 04-16-2013, 05:32 PM Thread Starter
tomthbomb
CJ7 1/2 Top Club mem. #1
 
tomthbomb's Avatar
1978 CJ7 
 
Join Date: Sep 2004
Location: Deep East Texas
Posts: 787
Quote:
Originally Posted by fillerup View Post
I thought I was the only one who had one of those. Had it for years and I don't use it much any more, I have a 5 hp I use now.
5 hp! You can run circles around me!!

1978 CJ-7 original owner; AMC 401 V-8 (w/some goodies);NP4500;D300 (w/Curry 4:1); D44 front;AMC20 (Warn one piece axles) rear
tomthbomb is offline  
post #10 of 14 Old 05-08-2013, 08:20 PM
lespaul_custom
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2008
Location: NWGA
Posts: 282
so you had it out on the water yet? how she do

Quote:
originally posted by urb4ntroll
Quote:
The weird thing is that I thought I hear a minor bang, almost like a fart sound coming out of my Jeep, but I'm not sure what it was. It has never happened before the glue incident.
www.coosa.org white jeep club #1993 looking to buy complete rear seat belts
lespaul_custom is offline  
post #11 of 14 Old 05-09-2013, 06:37 AM Thread Starter
tomthbomb
CJ7 1/2 Top Club mem. #1
 
tomthbomb's Avatar
1978 CJ7 
 
Join Date: Sep 2004
Location: Deep East Texas
Posts: 787
Quote:
Originally Posted by lespaul_custom View Post
so you had it out on the water yet? how she do
I am not happy with the amount of water coming out of the pump. The motor has very few hours on it but rubber water pump impellers dry out over that number of years. I am in the process of running one down.

1978 CJ-7 original owner; AMC 401 V-8 (w/some goodies);NP4500;D300 (w/Curry 4:1); D44 front;AMC20 (Warn one piece axles) rear
tomthbomb is offline  
post #12 of 14 Old 05-09-2013, 06:26 PM
lespaul_custom
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2008
Location: NWGA
Posts: 282
i dont blame ya, i would prob service everything i could! does it have a true weep hole? or just sputters out the exhaust? my 2hp just spudders some out the exhaust a Lil bit and I was thinking of changing the impeller till I seen/read that 98% of the water went on out the exhaust by the propeller under water and what little I see blowing out the exhaust vent was alright. have you found a source for parts yet?

Quote:
originally posted by urb4ntroll
Quote:
The weird thing is that I thought I hear a minor bang, almost like a fart sound coming out of my Jeep, but I'm not sure what it was. It has never happened before the glue incident.
www.coosa.org white jeep club #1993 looking to buy complete rear seat belts
lespaul_custom is offline  
post #13 of 14 Old 05-13-2013, 04:30 PM Thread Starter
tomthbomb
CJ7 1/2 Top Club mem. #1
 
tomthbomb's Avatar
1978 CJ7 
 
Join Date: Sep 2004
Location: Deep East Texas
Posts: 787
Quote:
Originally Posted by lespaul_custom
i dont blame ya, i would prob service everything i could! does it have a true weep hole? or just sputters out the exhaust? my 2hp just spudders some out the exhaust a Lil bit and I was thinking of changing the impeller till I seen/read that 98% of the water went on out the exhaust by the propeller under water and what little I see blowing out the exhaust vent was alright. have you found a source for parts yet?
There are six weep holes. The guy I bought it from said there is a thermostat and the water doesn't start to flow until the motor reaches operating temperature. Everything is on the internet. When I researched it I found that Evinrude didn't use a thermostat on this model until 1968. Mine is a 1967.

1978 CJ-7 original owner; AMC 401 V-8 (w/some goodies);NP4500;D300 (w/Curry 4:1); D44 front;AMC20 (Warn one piece axles) rear
tomthbomb is offline  
post #14 of 14 Old 05-13-2013, 08:24 PM
phitmein
Web Wheeler
 
phitmein's Avatar
1995 ZJ 
 
Join Date: Feb 2009
Location: Columbia
Posts: 2,906
Tom, that motor is so sweet .
phitmein is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome