WK squeak during gear change - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > WK squeak during gear change

Great prices on seating!--Oconee Off-RoadBestop underseat lock boxes @ oconee off road 706 534 9955Yukon Ultimate 35 axle kit for c/clip axles with Yukon Zip

Reply
Unread 02-26-2013, 12:01 AM   #1
KunningSTUNT
Registered User
2005 WK 
 
Join Date: Sep 2012
Location: Melbourne, Australia
Posts: 64
WK squeak during gear change

Hi guys,

lately while driving my wk 4.7l I have been experiencing a squeak whilst my car is changing gear, usually I have my foot to the floor (or close to) when it happens, i cant tell if its coming from the engine or transmission.
Does this sound common to anyone??

Thanks

__________________
05' WK Grand Cherokee Laredo 4.7L QTII
- modified OME HD
- custom snorkel / air intake
- lukey exhaust
- superchips
KunningSTUNT is offline   Reply With Quote Quick reply to this message
Unread 02-26-2013, 05:57 AM   #2
caulk04
Registered User
2008 WK 
 
Join Date: Jan 2013
Location: Greenville, Pennsylvania
Posts: 894
I think the noise is the serp belt squeaking from the abrupt change in engine speed.

I've noticed this in the past with my Dakota 4.7, it seemed related to the torque management that cuts engine power momentarily during full throttle shifts to keep things smooth. Once I disabled that, it stopped.
caulk04 is offline   Reply With Quote Quick reply to this message
Unread 02-26-2013, 12:14 PM   #3
IndyBlueWK
Registered User
2005 WK 
 
Join Date: Feb 2012
Location: Carmel, indiana
Posts: 1,142
belt .... New one will fix it..
IndyBlueWK is offline   Reply With Quote Quick reply to this message
Unread 02-27-2013, 03:04 AM   #4
KunningSTUNT
Registered User
2005 WK 
 
Join Date: Sep 2012
Location: Melbourne, Australia
Posts: 64
Apparently according to my mechanic who is also my brother in law my belt looks fine, so i guess that only really leaves the auto tensioner, are they a common problem? my car has done 150,00km (93000 miles)
__________________
05' WK Grand Cherokee Laredo 4.7L QTII
- modified OME HD
- custom snorkel / air intake
- lukey exhaust
- superchips
KunningSTUNT is offline   Reply With Quote Quick reply to this message
Unread 02-27-2013, 12:38 PM   #5
marioct
Registered User
2007 WK 
 
Join Date: Aug 2006
Location: Southern CT
Posts: 155
I have the same issue. It seems to be under the car and not in the engine bay. When I put it in gear when there is a high idle at start up, it makes the noise too. it sounds like slipping of rubber on rubber
marioct is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.