WK Heater/AC Blower Not Working - JeepForum.com
 
LinkBack Thread Tools
post #1 of 2 Old 05-20-2013, 05:37 PM Thread Starter
Tonycoco
Registered User
2005 WK 
 
Join Date: Sep 2010
Location: Los Angeles
Posts: 11
WK Heater/AC Blower Not Working

Hello everyone,

I have an 05 WK and just recently all of a sudden the Heater/AC completely stop working. I have no fan on any speeds or settings.

I have checked all fuses and relays and also replaced the blower resistor.

Any thoughts on what it may be?

Your input is very much appreciated.

Best

Tonycoco is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-21-2013, 12:59 AM
Jaashua
Registered User
2005 WK 
 
Join Date: Feb 2013
Posts: 1,144
Jaashua is offline  
Reply

Tags
ac , blower , hvac , resistor , wk

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome