Whining upon startup Commander - JeepForum.com
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Whining upon startup Commander

Yeti Paracord Handles are in at JeepHut.comFS: Jeep Fog Light LED Bulbs! Several Brightness Options! 6th annual beat your wife to the credit cards sale!!

Unread 08-11-2013, 09:21 PM   #1
Registered User
2006 XK Commander 
Join Date: Jul 2010
Location: Phoenix
Posts: 4
Whining upon startup Commander

I have 2 issues that may be related. When I try to start my Commander, it takes several turns to actually start. Battery is less than 2 years old and I don't hear a clicking noise. Its just dead silence when I turn it over. Eventually after 4-5 times at starting it turns over, then I hear a whining noise even before its put into gear.

I had the power steering fluid checked, didn't seem to be the issue.

Any suggestions?

djbadder is offline   Reply With Quote Quick reply to this message

commander , whining noise , xk

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.