Wheel balancing problems. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Wheel balancing problems.

Jeep Wrangler Bushwacker Flat Fender Flare Sale at BaselinANOTHER Rockridge4wd Creation!! Spare Tire Carrier Delete The Original 3/8" Ruffstuff Diff Cover!

Reply
Unread 11-08-2006, 04:15 PM   #1
madjack
Registered User
 
Join Date: Oct 2006
Location: Illinois
Posts: 11
Wheel balancing problems.

I have an 2005 GC Limited with 35,000 miles and decided to upgrade the tires to a set of Michelin M/S, one size over. Ever since doing this I cannot seem to get rid of the steering wheel vibration between 68 and 75 mph. I've had them balanced and rotated three times and nothing changes.
I'm at a loss as to what would cause this other then a balancing issue. I have the Chrome Clad wheels which I heard about problems with so I purchased a set of after market wheels and nothing has changed.

Help!


Last edited by madjack; 11-09-2006 at 05:06 AM..
madjack is offline   Reply With Quote Quick reply to this message
Unread 11-08-2006, 04:20 PM   #2
GCJake
Registered User
2011 KK Liberty 
 
Join Date: Nov 2006
Location: Dallas
Posts: 10
I have the same issue.
I have a 05 Grand with 12k miles and it shakes the steering Wheel around 65 mph +
I have 20" wheels with Alcoa rims
GCJake is offline   Reply With Quote Quick reply to this message
Unread 11-09-2006, 05:08 AM   #3
madjack
Registered User
 
Join Date: Oct 2006
Location: Illinois
Posts: 11
GC Jake,
Have you taken it in for service or talked to anyone about the problem?

Thanks.
madjack is offline   Reply With Quote Quick reply to this message
Unread 11-09-2006, 08:03 AM   #4
GCJake
Registered User
2011 KK Liberty 
 
Join Date: Nov 2006
Location: Dallas
Posts: 10
They have not serviced it yet, but they tell me it must be a wheel balance problem...
I would think that it would happen at any speed if it was a balancing problem, so I am not sure what the issues are
GCJake is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.