What did you do to your WK/XK today? - Page 850 - JeepForum.com

 313Likes
 
LinkBack Thread Tools
post #12736 of 16291 Old 08-24-2014, 10:05 PM
fafafofi
Registered User
2006 WK 
 
Join Date: Jun 2008
Location: Glenwood Springs
Posts: 216
Added a shorty antenna then dropped off the WK to get ball joints/UCAs replaced. Went with RRO after dealing with the dreaded squeak for almost a year

fafafofi is offline  
Sponsored Links
Advertisement
 
post #12737 of 16291 Old 08-25-2014, 09:32 AM
mrjaydeeone
Registered User
2007 WK 
 
Join Date: Jan 2010
Location: Woodbridge, NJ/Staten Island, NY
Posts: 220
In regards to tpms sensors. After about 60 miles miles my left rear was showing on display. ANd then turned back to -- and the annoying chime is back. I've heard maybe could be a receiver. And there are 3. What do they look like? Where are they located? Is it something I can replace myself? If I can does anything need to be reprogrammed?

Current 2007 WK Graystone Pearl V8 4.7 limited fully loaded. Current mods Escort 9500 IX tapped into rearview mirror and mounted under mirror with bicycle reflector bracket. 6K HIDs in Lows and 3K HIDs in Fogs
mrjaydeeone is offline  
post #12738 of 16291 Old 08-25-2014, 11:08 AM
rulother
Registered User
2008 WK 
 
Join Date: May 2014
Location: Alpharetta
Posts: 100
Went on a small road trip up to Helen, GA and drank some German beer!

2008 WK 3.7L V6 Dark Khaki Club Member #75 "Grizzly"
2001 WJ 4.7 V8 (Sold)
1998 ZJ 5.2L V8 (Dead @ 300,000 Miles)
rulother is offline  
post #12739 of 16291 Old 08-26-2014, 10:00 AM
lavern23
Registered User
2005 LJ Wrangler 
 
Join Date: Apr 2011
Location: Louisville
Posts: 95
Thursday I broke a valve spring, dropped a valve and poked a hole in number 6 piston. Time for another new motor.
lavern23 is offline  
post #12740 of 16291 Old 08-26-2014, 10:04 AM
boykinjw
Registered User
1999 XJ Cherokee 
 
Join Date: May 2010
Location: VA
Posts: 302
Quote:
Originally Posted by lavern23 View Post
Thursday I broke a valve spring, dropped a valve and poked a hole in number 6 piston. Time for another new motor.
How many miles and what motor do you have? Were you hard on the skinny pedal when it happened?

2005 WK Hemi QDII
1999 XJ OME MD, 245/75/16 ST MAXX, ARB Bull Bar, Aussie Locker F&R
boykinjw is offline  
post #12741 of 16291 Old 08-26-2014, 11:33 PM
punisher65
Member
 
punisher65's Avatar
2006 WK 
 
Join Date: Jun 2011
Location: Kirkland
Posts: 334
Just got my flush mount Rigids and the brackets from Jonathan at Steel Armadillo for the brush guard. Didn't get a chance tonight to wire anything up, but they are mounted and ready to go...and it looks fantastic IMO! Just waiting for my grill inserts from Crawl Offroad, then the front of the Jeep will be complete (although I might have to replace the factory fogs with some Rigids too after I find out how much light these things put out!)

Sorry about the picture quality, but at least I have a picture!
Attached Thumbnails
Rigid.jpg  

2006 5.7 WK
OME HD, 265/70-17 Duratracs on Level 8 Strike 5, Aspen Creek Shackle Mounts,
Airaid CAI, Superchips Flashpaq, Gibson 3" catback, Steel Armadillo Engine Skid Plate
BT Catch Can, TB ground, Cree LED Reverse Lights, Interior LED upgrade


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


1993 4.0 ZJ
BB and 31" Bighorns SOLD :(
punisher65 is offline  
post #12742 of 16291 Old 08-27-2014, 07:48 PM
lavern23
Registered User
2005 LJ Wrangler 
 
Join Date: Apr 2011
Location: Louisville
Posts: 95
Quote:
Originally Posted by boykinjw View Post
How many miles and what motor do you have? Were you hard on the skinny pedal when it happened?
130,000 on the Chrysler reman motor that was put in at 48,000. I had been on the highway for 2.5 hours which is where it spends it's time mostly and turned it off for 10 minutes at a customer and wouldn't start again. When it did it was knocking and smoking. I have the 5.7 QDII Limited.

I'm religious on my maintenance too.
lavern23 is offline  
post #12743 of 16291 Old 08-29-2014, 01:22 PM
631GCLaredo
Registered User
2007 WK 
 
Join Date: May 2014
Location: Commack
Posts: 12
Lube, oil, filter @ Jiffy lube.

2007 Jeep Grand Cherokee Laredo X, Mineral Gray metallic, gray leather, Quad Trac 1.
631GCLaredo is offline  
post #12744 of 16291 Old 08-29-2014, 04:32 PM
05WKinPA
Registered User
2005 WK 
 
Join Date: Apr 2008
Location: Philadelphia
Posts: 421
Quote:
Originally Posted by 631GCLaredo View Post
@ Jiffy lube.
And it still runs???

Rocky Road & OME MD hybrid lift / AEV Pintlers / 32" BFG Mud Terrains / Four X Doctor rear diff guard / JBA UCA's / 4XGuard Belly Skid / Stillen cross drilled rotors
05WKinPA is offline  
post #12745 of 16291 Old 08-29-2014, 04:38 PM
121ak
Registered User
1998 XJ Cherokee 
 
Join Date: May 2014
Location: Mountain Home
Posts: 99
It got detailed. Looks fantastic!

121ak is offline  
post #12746 of 16291 Old 08-29-2014, 04:42 PM
Bogie
Registered User
2005 WK 
 
Join Date: Jun 2008
Location: Franklin Square ,NY
Posts: 106
Got a few of my lights installed (click for video)




05 WK 5.7 Limited Stone White Dead Stock
84 Dodge W350 Crew Cab 9'+ Lift 37" SSR's
66 Dodge Dart 273 4-Speed Radio/Heat Delete
Previous Jeeps - 78 SJ,91 YJ,94 ZJ,98 XJ,06 LJ Rubi
Bogie is offline  
post #12747 of 16291 Old 08-29-2014, 08:03 PM
TheFaz
Registered User
2007 WK 
 
Join Date: Jul 2011
Location: Stamford
Posts: 65
Quote:
Originally Posted by 121ak
It got detailed. Looks fantastic!
Good looking rig man, what size tires are you running? And is that an OME?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TheFaz is offline  
post #12748 of 16291 Old 08-29-2014, 10:05 PM
121ak
Registered User
1998 XJ Cherokee 
 
Join Date: May 2014
Location: Mountain Home
Posts: 99
Quote:
Originally Posted by TheFaz View Post
Good looking rig man, what size tires are you running? And is that an OME?
265 General Grabber AT2s. And it's a rough country 2" lift.
121ak is offline  
post #12749 of 16291 Old 08-30-2014, 08:20 PM
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore
Posts: 4,688
Swapped back in my Philips bulbs and ditched the HIDs.. Would have thrown my 3000k HIDs in my fogs but they sent the wrong bulbs!

2007.5 WK Laredo 4.7
OEM+
paroxysym is offline  
post #12750 of 16291 Old 08-31-2014, 05:06 AM
james_2k
Registered User
2003 WJ 
 
Join Date: Feb 2013
Location: Aberfoyle
Posts: 876
new rear discs and pads all around. waxed the roof, which i couldnt be bothered doing when i did the last wash.

cleaned out the compressor/intercooler/radiator as much as i could with washing liquid and a hose.
james_2k is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 3 (2 members and 1 guests)
Jcompres , kryton
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Almost ran out of gas today SYCOHEMI WK Grand Cherokee & XK Commander Forum 44 10-28-2016 08:24 AM
Got a 95 GC today colby72olds ZJ Grand Cherokee Forum 2 06-20-2010 07:34 PM
got my 94 ZJ today, and did my first mod Saleen4971 ZJ Grand Cherokee Forum 10 09-22-2009 01:52 AM
sad day, today cyberbrain ZJ Grand Cherokee Forum 21 02-06-2008 10:32 PM
Hey, Today is 5.9 day! CAHotRodBoy ZJ Grand Cherokee Forum 5 05-09-2005 10:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome