What did you do to your WK/XK today? - Page 693 - JeepForum.com

 212Likes
 
LinkBack Thread Tools
post #10381 of 15971 Old 09-09-2013, 10:25 PM
Wilbready
Registered User
2005 WK 
 
Join Date: Feb 2013
Location: Casa Grande
Posts: 256
Quote:
Originally Posted by JeepN4KC

The place in that pic...................

Mine?

Pulled this home:



and ordered one of these:
I bought and installed the same brake controller! It is awesome and very useful, since I routinely tow a 7200 lb trailer.


"Roads? Where we're going, you don't need, roads.)
Wilbready is offline  
Sponsored Links
Advertisement
 
post #10382 of 15971 Old 09-10-2013, 04:51 AM
Snow4Lif3
Registered User
2005 WK 
 
Join Date: May 2010
Location: Manseau, Qc, Can
Posts: 206
Quote:
Originally Posted by DRCracker View Post
Don't have Bora, but I use 90ft.lbs. on the metric 10.5 grade studs.

Does that photo show both spacers stacked on the hub?

TC
Yes, both spacers stacked on the hub to show the thikcness. My concern is not the stud, but the spacer itself but i'll do like you and torque them to 90 lbs !

2005 WK 5.7L Limited QDII | Superlift | 1" Bora wheel spacers | Moab wheels | BFG A/T 285/70R17E | MDS light | SuperChips FlashPaq | Taylor Shorties wires | BT catch can | Volant CAI | Gibson Catback | S4xC Front Shackles | Anodized blue painted calipers | Stillen Rotors & Pads | 25W Cree LED Backup Reverse | Nokya Hyper Yellow Fog | ....
Snow4Lif3 is offline  
post #10383 of 15971 Old 09-10-2013, 06:18 AM
BennyOC
Registered User
2006 WK 
 
Join Date: Mar 2013
Posts: 10
Just started noticing this loud tapping sound coming from my rear wheels somewhere around the rotor. It only happens when I brake and go over a bump at the same time. I read up on it and it says that WK's have been know for the parking break glue or something to wear, and so it's just just hanging there clanking? Who knows, wonderin if anyone knows more or any quick fixes!
BennyOC is offline  
post #10384 of 15971 Old 09-10-2013, 01:23 PM
DRCracker
Registered User
2006 WK 
 
Join Date: Apr 2012
Location: Somerset
Posts: 380
Quote:
Originally Posted by BennyOC View Post
Just started noticing this loud tapping sound coming from my rear wheels somewhere around the rotor. It only happens when I brake and go over a bump at the same time. I read up on it and it says that WK's have been know for the parking break glue or something to wear, and so it's just just hanging there clanking? Who knows, wonderin if anyone knows more or any quick fixes!
Shortly after purchasing my 2006 in 2012, the park brake components grenaded inside the rear rotor. Wouldn't reverse without locking up the rear wheel. Check that out, seems common with our WK's.

TC

MOLON LABE: 2006 WK Limited, Dark Khaki Pearl, 5.7 HEMI, QDII,
Console XDs-45acp, Billet Catch Can, Airaid CAI Tube,
1" Spacers, Steel Armadillo Sliders, Dark Khaki 4xGuard Front Skid,
Dark Khaki 2011 #9104 Wheels, Firestone Destination A/T 265/70/17's.
OME HD lift. Dark Khaki Matrix Brush Guard, Dark Khaki Painted Headlight Bezels.
Hemi Club #65 // Khaki WK Club #40
DRCracker is offline  
post #10385 of 15971 Old 09-10-2013, 01:43 PM
BennyOC
Registered User
2006 WK 
 
Join Date: Mar 2013
Posts: 10
Quote:
Originally Posted by DRCracker

Shortly after purchasing my 2006 in 2012, the park brake components grenaded inside the rear rotor. Wouldn't reverse without locking up the rear wheel. Check that out, seems common with our WK's.

TC
Yeah that's what I'm afraid of happening, ill prolly end up just takin it into a shop and swapping everything out so I don't have to worry about it anymore
BennyOC is offline  
post #10386 of 15971 Old 09-10-2013, 02:58 PM
jaysix
Registered User
2006 XK Commander 
 
Join Date: Jul 2013
Location: Portage
Posts: 33
Changed the sparkplugs in my Hemi XK hoping to possibly improve the gas mileage. Didn't happen even though the plugs that I took out were gapped to .060 instead of the .045 they are supposed to be. 77k miles, New plugs, k&n cai, diablosport tuner and I cant get better than 15.3 on the highway, 14 combined.
jaysix is offline  
post #10387 of 15971 Old 09-10-2013, 03:39 PM
ajxj9197
Registered User
2009 WK 
 
Join Date: Jul 2008
Location: Bloomington, Illinois
Posts: 1,346
Quote:
Originally Posted by jaysix
Changed the sparkplugs in my Hemi XK hoping to possibly improve the gas mileage. Didn't happen even though the plugs that I took out were gapped to .060 instead of the .045 they are supposed to be. 77k miles, New plugs, k&n cai, diablosport tuner and I cant get better than 15.3 on the highway, 14 combined.
Weird. Mine is stock with old spark plugs and I manage 14 purely city and get 16 or more on the highway.
It is a wk though.
ajxj9197 is offline  
post #10388 of 15971 Old 09-10-2013, 03:41 PM
B_Baity10
Registered User
 
Join Date: Jun 2013
Posts: 196
Put new wheels on the WK today!!

Next step, lift kit!
Attached Images
 
B_Baity10 is offline  
post #10389 of 15971 Old 09-10-2013, 03:43 PM
jaysix
Registered User
2006 XK Commander 
 
Join Date: Jul 2013
Location: Portage
Posts: 33
Quote:
Originally Posted by ajxj9197

Weird. Mine is stock with old spark plugs and I manage 14 purely city and get 16 or more on the highway.
It is a wk though.
Yeah, I have no idea what is going on with it. Had it for a month now and am about to get rid of it if I cant figure it out.
jaysix is offline  
post #10390 of 15971 Old 09-10-2013, 03:50 PM
JeepN4KC
Keep on Jeepin on........
 
JeepN4KC's Avatar
 
Join Date: Jul 2011
Location: Blue Springs
Posts: 6,942
Quote:
Originally Posted by jaysix View Post
Changed the sparkplugs in my Hemi XK hoping to possibly improve the gas mileage. Didn't happen even though the plugs that I took out were gapped to .060 instead of the .045 they are supposed to be. 77k miles, New plugs, k&n cai, diablosport tuner and I cant get better than 15.3 on the highway, 14 combined.
What kind of rpm's do you typically run with your driving style?

~Mike~

Build Thread WK
Other Build Thread XJ
Sept '13/Jan '15/Jun '16 COTM
JeepN4KC is offline  
post #10391 of 15971 Old 09-10-2013, 03:52 PM
jaysix
Registered User
2006 XK Commander 
 
Join Date: Jul 2013
Location: Portage
Posts: 33
Quote:
Originally Posted by JeepN4KC

What kind of rpm's do you typically run with your driving style?
Usually 1500-2500. On the highway, i set my cruise at 65 and just sit back.
jaysix is offline  
post #10392 of 15971 Old 09-10-2013, 03:57 PM
JeepN4KC
Keep on Jeepin on........
 
JeepN4KC's Avatar
 
Join Date: Jul 2011
Location: Blue Springs
Posts: 6,942
Quote:
Originally Posted by jaysix View Post

Usually 1500-2500
Yeah I dunno, that's pretty much on the conservative side of driving style. I drive the same way. My 4.7 WK gets around 16 +/- combined. Heavy on the around town miles and lesser so highway. My straight highway mpgs are typically 18-19+

Not sure what the 5.7 XK is "supposed" to get but yours seems low.

~Mike~

Build Thread WK
Other Build Thread XJ
Sept '13/Jan '15/Jun '16 COTM
JeepN4KC is offline  
post #10393 of 15971 Old 09-11-2013, 04:02 AM
LilOmelet
Registered User
2005 WK 
 
Join Date: May 2012
Location: Spokane
Posts: 256
Quote:
Originally Posted by jaysix
Changed the sparkplugs in my Hemi XK hoping to possibly improve the gas mileage. Didn't happen even though the plugs that I took out were gapped to .060 instead of the .045 they are supposed to be. 77k miles, New plugs, k&n cai, diablosport tuner and I cant get better than 15.3 on the highway, 14 combined.
I have pretty much the same setup in my WK and I get about the same MPG's... However I do have a little 2 inch lift with 265/70/17's.

The Punisher - 05 WK 5.7L HEMI Limited QDII - Volant CAI - 2" Rough Country - Bilstein Struts - 265/70/17 Nitto Trail Grapplers - ASFIR Suspension, front diff. Skid - Mopar Fuel Tank, T-case Skid - Mopar (Borla) Exhaust
LilOmelet is offline  
post #10394 of 15971 Old 09-11-2013, 06:41 AM
IndyBlueWK
Registered User
2005 WK 
 
Join Date: Feb 2012
Location: Carmel
Posts: 1,155
Drove it to work today. Goes to the dealership tonight to go under the knife tomorrow.
IndyBlueWK is offline  
post #10395 of 15971 Old 09-11-2013, 07:14 AM
bhawks28
Registered User
2014 JK Wrangler 
 
Join Date: Jun 2012
Location: chicago
Posts: 799
ordered a Cobra CB radio. This weekend should be pretty busy. I plan on swapping out my CURT hitch for the factory hitch and installing the CB and antenna.

2014 JKU Rubicon
bhawks28 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Almost ran out of gas today SYCOHEMI WK Grand Cherokee & XK Commander Forum 40 08-12-2016 07:36 AM
Got a 95 GC today colby72olds ZJ Grand Cherokee Forum 2 06-20-2010 06:34 PM
got my 94 ZJ today, and did my first mod Saleen4971 ZJ Grand Cherokee Forum 10 09-22-2009 12:52 AM
sad day, today cyberbrain ZJ Grand Cherokee Forum 21 02-06-2008 09:32 PM
Hey, Today is 5.9 day! CAHotRodBoy ZJ Grand Cherokee Forum 5 05-09-2005 09:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome