What did you do to your WK/XK today? - Page 447 - JeepForum.com
 117Likes
 
LinkBack Thread Tools
post #6691 of 15769 Old 11-11-2012, 04:17 PM
Walt
Registered User
2008 WK 
 
Join Date: Oct 2009
Location: Midland
Posts: 1,559
Changed oil & filter. Cleaned throttle body. Emptied oil catch can. Tires rotated last weekend.

Still need to change engine coolant, but oil change caught me by surprise and took precedence.
Anybody remember, does the cheap plastic drain valve open clockwise or counter-clockwise?

Gotta start serious battery shopping before it fails in the Winter weather. Probably end up at Sears for a DieHard Gold. Over 45 years of DieHard batteries and never had a problem. Did some looking at the Energizer website and found out that the one at Sam's Club is the bottom of the Energizer line. Disappointed. Think I'd rather pay the extra few $$ and not have to return and fight for a warranty replacement if a cheap one dies early.


HEMI CLUB MEMBER #45; SILVER WK CLUB MEMBER #13
'08 WK GC Limited. 5.7L HEMI. Quadra-Trac II. Bright Silver Metallic. Class IV hitch.
Michelin LTX M/S tires. Fumoto oil drain valve. Billet Technology oil catch can.
Walt is offline  
Sponsored Links
Advertisement
 
post #6692 of 15769 Old 11-11-2012, 05:43 PM
mpgumby
Registered User
2004 WJ 
 
Join Date: Jan 2009
Location: Redmond
Posts: 255
Just ordered up Monroe LLs 58643. That should even the Jeep out. Now to talk to Kolak about the front end...

05 WK Limited with 2" RC, 1.5" wheel spacers, 265/70/17 Duratracs, K&N drop in, expanded grille mod painted black, tail light guards, tinted tail lights, Superchips Flashpaq, and a 5.7 HEMI!!!
87 J10 w/ AMC 360 and headers /// 84 J10 with SOA, 33" BFG MTs, and AMC 360
Sold: 93 ZJ Limited 4.0 lifted with some goodies
GO DUCKS!!!
mpgumby is offline  
post #6693 of 15769 Old 11-11-2012, 05:51 PM
JeepN4KC
Keep on Jeepin on........
 
JeepN4KC's Avatar
 
Join Date: Jul 2011
Location: Blue Springs
Posts: 6,786
Quote:
Originally Posted by Walt
Changed oil & filter. Cleaned throttle body. Emptied oil catch can. Tires rotated last weekend.

Still need to change engine coolant, but oil change caught me by surprise and took precedence.
Anybody remember, does the cheap plastic drain valve open clockwise or counter-clockwise?

Gotta start serious battery shopping before it fails in the Winter weather. Probably end up at Sears for a DieHard Gold. Over 45 years of DieHard batteries and never had a problem. Did some looking at the Energizer website and found out that the one at Sam's Club is the bottom of the Energizer line. Disappointed. Think I'd rather pay the extra few $$ and not have to return and fight for a warranty replacement if a cheap one dies early.
DieHard batteries have been tried, tested, and proven. Sears always has sales on them - I'd go that route in a hearbeat.

~Mike~

Build Thread WK
Other Build Thread XJ
September 2013/January 2015 COTM
JeepN4KC is offline  
post #6694 of 15769 Old 11-11-2012, 05:52 PM
JeepN4KC
Keep on Jeepin on........
 
JeepN4KC's Avatar
 
Join Date: Jul 2011
Location: Blue Springs
Posts: 6,786
Quote:
Originally Posted by mpgumby
Just ordered up Monroe LLs 58643. That should even the Jeep out. Now to talk to Kolak about the front end...
What do you have up front currently?

~Mike~

Build Thread WK
Other Build Thread XJ
September 2013/January 2015 COTM
JeepN4KC is offline  
post #6695 of 15769 Old 11-11-2012, 06:08 PM
Walt
Registered User
2008 WK 
 
Join Date: Oct 2009
Location: Midland
Posts: 1,559
Quote:
Originally Posted by JeepN4KC View Post
DieHard batteries have been tried, tested, and proven. Sears always has sales on them - I'd go that route in a hearbeat.
Sold.

After I read your positive recommendation, I realized that EVERY automotive replacement battery I've had since 1969 has been a Sears DieHard. That would be ~17 cars.

Maybe I should do a commercial for Sears........maybe a testimonial for a free battery!

Anyway, thank again.

HEMI CLUB MEMBER #45; SILVER WK CLUB MEMBER #13
'08 WK GC Limited. 5.7L HEMI. Quadra-Trac II. Bright Silver Metallic. Class IV hitch.
Michelin LTX M/S tires. Fumoto oil drain valve. Billet Technology oil catch can.
Walt is offline  
post #6696 of 15769 Old 11-11-2012, 06:56 PM
RTLT05WK
Registered User
2005 WK 
 
Join Date: Oct 2012
Location: FRESNO
Posts: 44
.

Ryan

2005 WK Hemi "Badger"

Last edited by RTLT05WK; 11-11-2012 at 07:00 PM. Reason: mispost
RTLT05WK is offline  
post #6697 of 15769 Old 11-11-2012, 06:59 PM
RTLT05WK
Registered User
2005 WK 
 
Join Date: Oct 2012
Location: FRESNO
Posts: 44
Quote:
Originally Posted by Anthony92x View Post
Drove it even though sensor is still messed up. Extremely bummed that I couldn't take it to pigeon forge with me. Wanted to take some pictures. Revs do have a <2500 limit, 45mph limit, and seems to be stuck in 3rd gear. Part is only $16 anyone know how to figure out which sensor is bad?

Attachment 498264

Sent from the Death Star
Had the same issue and not clue whats causing it. Happens randomly and just pull over and turn her off and it goes back to normal.

Ryan

2005 WK Hemi "Badger"
RTLT05WK is offline  
post #6698 of 15769 Old 11-11-2012, 07:39 PM
Anthony92x
Registered User
2007 WK 
 
Join Date: Apr 2012
Location: Huntington
Posts: 381
Quote:
Originally Posted by RTLT05WK

Had the same issue and not clue whats causing it. Happens randomly and just pull over and turn her off and it goes back to normal.
Does yours go back to normal or sometimes does. Here recently I've had to pull over to the side after every red light to restart and retry. My only problem is speed sensor so might get those checked. Just don't go to a dealer to have it checked. Try a local mechanic first that saved me $200 right there. Also for you it could be the transmission sensor. But that's just a $30 part as well and it's easy to change.

Sent from the Death Star

07 WK 3.7, Cree 7w reverse lights, tinted tails, kicker audio, K&N filter,ported TB, RC 1.25in spacers, Bilstein HDS, 4 prong plugs, aux lights, Bedliner'd grill, rear step and rear latch cover.
Anthony92x is offline  
post #6699 of 15769 Old 11-11-2012, 08:25 PM
BobG97
Registered User
2005 WK 
 
Join Date: Dec 2010
Location: Piedmont
Posts: 496
Quote:
Originally Posted by RTLT05WK

Had the same issue and not clue whats causing it. Happens randomly and just pull over and turn her off and it goes back to normal.
Just my guess but it sounds like your jeep is going into "Limp Mode" (turning off the jeep usually resets the ECU). Does it throw a check engine light? It could be storing DTC codes that could help figure out the issue. Speaking from experience, transmission failure is not always easy to diagnose in a WK. if you don't have a code reader there is a trick to display the DTC codes on your jeep, below is the link to the exact steps.

http://www.ehow.com/how_7447860_chec...angler-jk.html
BobG97 is offline  
post #6700 of 15769 Old 11-11-2012, 08:50 PM
bigdo26
Registered User
2007 WK 
 
Join Date: Sep 2012
Location: Vernon
Posts: 13
Today (OK yesterday, but close enough) picked up my 'new to me' 2007 WK.

Traded in my 1994 Grand Cherokee Laredo 4.0 with ~178,000 miles for the slightly upgraded WK with the 4.7 V8. So far I love it!

2007 Grand Cherokee Laredo 4.7 - daily driver / tow car
2002 Audi S4 - weekend / track toy
2009 Smart Car - wife's semi-car ;)
bigdo26 is offline  
post #6701 of 15769 Old 11-12-2012, 07:05 AM
jeremyc653
Registered User
2005 WK 
 
Join Date: Jun 2009
Location: St pete
Posts: 652
Quote:
Originally Posted by bigdo26
Today (OK yesterday, but close enough) picked up my 'new to me' 2007 WK.

Traded in my 1994 Grand Cherokee Laredo 4.0 with ~178,000 miles for the slightly upgraded WK with the 4.7 V8. So far I love it!
Welcome to your new family!

Build Thread: http://www.jeepforum.com/forum/f67/jeremyc653-build-thread-1423295/#post14245927
jeremyc653 is offline  
post #6702 of 15769 Old 11-12-2012, 02:16 PM
BobG97
Registered User
2005 WK 
 
Join Date: Dec 2010
Location: Piedmont
Posts: 496
I picked up my new wheels and tires today. 285/70/17 Toyo OpenCountry AT II and Torque 17x9 wheels. I'd be lying if I said I'm not excited!
Now I just have to find time to put the SL on and I'll be set!
Attached Thumbnails
image-626042636.jpg   image-1199248140.jpg   image-2334930392.jpg   image-3799150108.jpg   image-2542632873.jpg  

BobG97 is offline  
post #6703 of 15769 Old 11-12-2012, 04:03 PM
JordanD07
Registered User
2007 WK 
 
Join Date: Jan 2011
Location: Atlanta
Posts: 332
Modified my hitch so hopefully I can fit a new 255/75/17 under there! Tole me an hour to get it done with a dremel

'07 3.7 4x4 QT1 ll Red WK Club #27 ll OME ll Monroe LL ll Rusty's ll ProComp ll BFG ll 4xGuard ll S4XC ll VLEDS ll Infinity ll Thrush ll Riddler ll 6K HID
JordanD07 is offline  
post #6704 of 15769 Old 11-12-2012, 05:07 PM
Robb286
Registered User
2006 WK 
 
Join Date: Feb 2011
Location: Pocono Mts
Posts: 575
I washed and waxed her after work tonight.
Attached Thumbnails
image-501598377.jpg   image-3775790613.jpg   image-210229120.jpg  
Robb286 is offline  
post #6705 of 15769 Old 11-12-2012, 08:15 PM
Marna89
Registered User
 
Join Date: Sep 2012
Location: Florence
Posts: 51
Hit a deer on my way home from work last night. Ripped off the front bumper and busted my radiator.

image-2816836523.jpg

What a bummer.
Marna89 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 5 (4 members and 1 guests)
angryrooster , Bogie , chance_p , ma3x
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Almost ran out of gas today SYCOHEMI WK Grand Cherokee & XK Commander Forum 37 04-29-2016 10:36 PM
Got a 95 GC today colby72olds ZJ Grand Cherokee Forum 2 06-20-2010 06:34 PM
got my 94 ZJ today, and did my first mod Saleen4971 ZJ Grand Cherokee Forum 10 09-22-2009 12:52 AM
sad day, today cyberbrain ZJ Grand Cherokee Forum 21 02-06-2008 09:32 PM
Hey, Today is 5.9 day! CAHotRodBoy ZJ Grand Cherokee Forum 5 05-09-2005 09:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome