What did you do to your WK/XK today? - Page 237 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > What did you do to your WK/XK today?

ENGO QUADLUX 6" to 54" LED AMBER AND WHITE MULTIEngo winches available at www.rockridge4wd.com! Free shippSmittybilt Hard Tops @ Oconee Off-Road! 706-534-9955

Reply
Unread 03-20-2012, 01:32 PM   #3541
jager00
Registered User
2005 WK 
 
Join Date: Apr 2009
Location: salisbury, maryland
Posts: 3,840
Finally made it over this pipe the other day! I used to get high centered on it until i got the 37's on
http://m.facebook.com/profile.php?id...5077a04e9f9ddb

__________________
2007 JK Sahara- trying to figure this one out


2005 WK 9" lift on 37's with all the goodies- regretfully sold :(
jager00 is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 01:53 PM   #3542
corswandtm
Registered User
2007 WK 
 
Join Date: Oct 2010
Location: Richmond, Virginia
Posts: 361
Quote:
Originally Posted by RIDER6
Yes jrlt deffinately keep us updated it seems like a simple cheap bolt on, but only worth it if there is good gains out of it!
Total cost = about $5....I will be doing this tonight.
__________________
2007 WK Red Rock Limited - 5.7 HEMI w/QD-II - Stainless 22" Magnaflow muffler - AFE Stage 2 CAI - Bilstein HD shocks/struts - JBA Strut Spacers - 245-70/17 Firestone Destination AT
corswandtm is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 02:27 PM   #3543
BobG97
Registered User
2005 WK 
 
Join Date: Dec 2010
Location: Piedmont, MO
Posts: 496
Fixed a leaky transmission pan (due to removing and reinstalling it about 4 times over the past 2 weeks) now I have to track down my front diff issue, service 4wd message is on and the stealership said its a "low voltage detected to the front 4wd solenoid" and it appears to be fully engaged at all speeds and is KILLING my mpg! Any thoughts?
BobG97 is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 02:43 PM   #3544
Muddy4DSM
Registered User
 
Join Date: Nov 2011
Location: Aurora, IL
Posts: 373
I just secured a deal for 5 Moabs with only 13k miles for a buck fifty.
__________________
OO|||||||OO
Muddy4DSM is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 02:53 PM   #3545
WKBoston
Registered User
2006 WK 
 
Join Date: Apr 2010
Location: Massachusetts
Posts: 101
Final got a chance for the grill mod, sprayed my tailgate step with bed liner and changed the spark plugs.
__________________
Black WK Club Member #26
WKBoston is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 02:54 PM   #3546
vada9
Registered User
2007 WK 
 
Join Date: Dec 2011
Location: Yorktown, VA
Posts: 84
Today the front porch had a Magnaflow 22" large case muffler, AFE Pro dry intake..and 2 OME n190 shocks. So the garage is now full of parts. All I am waiting on is the Front OME struts..and the work will hopefully begin this weekend...fingers crossed.
vada9 is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 03:16 PM   #3547
ecollins7
Registered User
2006 WK 
 
Join Date: Sep 2011
Location: baltimore, Maryland
Posts: 435
image-4018192714.jpg

Got 3 of the wheels painted but gotta finish the other 2 tomorrow
ecollins7 is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 04:19 PM   #3548
TXWK131
Registered User
2009 JK Wrangler 
 
Join Date: Jul 2010
Location: Dallas, TX
Posts: 125
From the Brown Truck today! Should be puttin them on tomorrow.

forumrunner_20120320_171706.jpg
__________________
[CENTER]2009 [COLOR="SlateGray"]SILVER[/COLOR] JK Sahara
RC 3.5-315.70.17 on Stock RUBI's
PE Front and Rear Bumper
DIY DECK LID
[/CENTER]

2006 Navy WK HEMI ~RK 3.5 lift - 17" Moabs - Toyo 265.70.17 AT - Bedliner Paint Job - [COLOR="Red"][B]SOLD[/B][/COLOR]

'85 XJ... Still tryin to figure out what the heck I have in this piece of Junk! But you gotta start somewhere
TXWK131 is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 05:57 PM   #3549
Budasac
Registered User
2005 WK 
 
Join Date: Nov 2010
Location: Woodbridge, NJ
Posts: 3,159
Quote:
Originally Posted by TXWK131 View Post
From the Brown Truck today! Should be puttin them on tomorrow.

Attachment 367189
Before you install I suggest you dis-assemble them and glue those rubber sleeves in place. It'll save you the headache of having to pull 'em off and do it later.
Budasac is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 06:44 PM   #3550
AJeepZJ
Registered User
2006 WK 
 
Join Date: Aug 2010
Location: Ft Bragg, MO
Posts: 3,575
It makes me wonder if they changed something in the manufacturing of these, because mine have not slipped down at all.
__________________
All Gear, No Skill.
AJeepZJ is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 07:01 PM   #3551
TurboDiesel
Registered User
2008 WK 
 
Join Date: Apr 2011
Location: langley, BC
Posts: 1,956
are those the load levelers?
__________________
[B]-]All Blacked Out[-[/B]
2008 Jeep Grand Cherokee 3.0 CRD
2" RC lift
255/75R17 BFG KM1's
17" ion alloy rims
15" kicker solo baric L7 w/ Alpine m1000 amp
aftermarket headlights w/5000k HIDs
Red interior LEDs and Red license plate LED
Tinted tails
5% tint over the rear windows
more to come....
TurboDiesel is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 07:07 PM   #3552
Budasac
Registered User
2005 WK 
 
Join Date: Nov 2010
Location: Woodbridge, NJ
Posts: 3,159
Quote:
Originally Posted by AJeepZJ View Post
It makes me wonder if they changed something in the manufacturing of these, because mine have not slipped down at all.
You're lucky. I had to pull mine off and repaint them and glue the sleeves. One had a small rip in it already. Now it's gnarled and the spring is rubbing a little. rolleyes: I'll have to pull it off again and do something about I guess.
Budasac is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 07:35 PM   #3553
fireman922
Registered User
2008 XK Commander 
 
Join Date: Aug 2010
Location: Indiana
Posts: 35
Installed a 12 VDC power plug in the back of the center console, above the inverter plug.

I know, not much of a mod...
fireman922 is offline   Reply With Quote Quick reply to this message
Unread 03-20-2012, 07:40 PM   #3554
JRLT
Registered User
2010 WK 
 
Join Date: Aug 2011
Location: Lower Brule, South Dakota
Posts: 1,376
Put on over 200 miles tonight, bought a torque wrench but that's another story. A 70 mile stretch is about the flattest land in South Dakota plus it's interstate and my AVG MPG went from 18.5 to 18.8 but I couldn't remember the last time I reset it so I filled up on 87 octane (Ethanol is 89 here, 5 cents cheaper)and reset the EVIC. Got on the interstate and set the cruise at 75MPH. I watched as it climbed from 19.0 AVG MPG all the way to 20.9 AVG MPG before I hit hills, then it bounced around between 20.2 & 20.4. It's at 20.5 when I parked it.
__________________
2010 3.7L, 4XGuard Matrix, Fastman TB, TB Ground Mod, Injen CAI, 255/60/18 Nitto Terra Grapplers, Bilstein Shocks & Struts, Cruiser Alloy Wheels - Switchblade, Stillen Brakes, Cargo Light Strip Mod, Electric Ashtray Mod, Jet-powered, Monkey Navigated...
JRLT is online now   Reply With Quote Quick reply to this message
Unread 03-20-2012, 07:44 PM   #3555
mattydipps
Registered User
2006 WK 
 
Join Date: Sep 2011
Location: west babylon, new york
Posts: 1,512
Quote:
Originally Posted by JRLT View Post
Put on over 200 miles tonight, bought a torque wrench but that's another story. A 70 mile stretch is about the flattest land in South Dakota plus it's interstate and my AVG MPG went from 18.5 to 18.8 but I couldn't remember the last time I reset it so I filled up on 87 octane (Ethanol is 89 here, 5 cents cheaper)and reset the EVIC. Got on the interstate and set the cruise at 75MPH. I watched as it climbed from 19.0 AVG MPG all the way to 20.9 AVG MPG before I hit hills, then it bounced around between 20.2 & 20.4. It's at 20.5 when I parked it.
do you have a tuner? or just running the tb ?
__________________
Sold-
mattydipps is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.