What did you do to your WK/XK today? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > What did you do to your WK/XK today?

Dana 30/ Dana 44 Chromoly shaft Kits- ECGSFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFlowmaster's Force II Axle-back exhaust system for the 201

Reply
Unread 02-12-2011, 02:37 PM   #1
Devilsmed98
Registered User
1995 YJ Wrangler 
 
Join Date: Nov 2009
Location: Ocean, New Jersey
Posts: 866
What did you do to your WK/XK today?

Took this from the YJ forum on here. It's interesting to see what everyone is doing each day in respect to mods, repairs, or general maintenance.

I'll start this one off with a funny story.

Going out on a date tonight and didn't want to make a bad impression by showing up in the RustBucket (YJ) so I decided to tackle my WK's starter problem. Ended up finding out that one of the bolts for the plastic splash guard was gone, and I broke another one taking it off. So now that is sitting in the junk pile in the basement. Checked the starter wires and they were all tight, wiggled them a little and it started right up.

Went to the gas station, got some gas, started up again. So I took it to the car wash.... (the kind where it is on a little rail almost). So I pay and walk outside. **** looked like hell. There were 5 Mexicans trying to push my Jeep while one inside was trying to start it. Meanwhile there was a lady screaming because her Jaguar Coupe was about 3 feet away from the back of my Jeep and coming out fast. Thank god one of those speedy guys jumped in the jaguar and hit the brakes just in time. I ended up opening the hood, pulling on the positive wire, and it started up. Got home and i cycled it 4 times and it was fine.

180116_10150417071105451_886010450_17504372_4812449_n.jpg  
__________________
~Black WK Club Member #9~
2011 WKII Overland
2007 WK Limited[/COLOR]
1995 YJ Rio Grande
Devilsmed98 is offline   Reply With Quote
Unread 02-12-2011, 03:28 PM   #2
clbailey
Registered User
2005 WK 
 
Join Date: Jan 2011
Location: Senoia, Georgia
Posts: 194
I put on some yellow fog light vinyl covers. And made a few of my own roads.

Are your side views backwards? wtf lol
clbailey is offline   Reply With Quote
Unread 02-12-2011, 03:29 PM   #3
bumzo1
Registered User
2005 WK 
 
Join Date: May 2010
Location: Texas
Posts: 1,085
its either the battery or the starter needs to be replaced, the WK starter commonly goes around 60-80k miles.

I myself gave the dub a nice detail and cleaned off all of the sand from when it iced last week.
__________________
'05 WK 3.7L | OME MD lift | 255/75/17 BFG M/Ts | 20" LED Light Bar
Khaki WK Club Member #1
bumzo1 is offline   Reply With Quote
Unread 02-12-2011, 03:57 PM   #4
Devilsmed98
Registered User
1995 YJ Wrangler 
 
Join Date: Nov 2009
Location: Ocean, New Jersey
Posts: 866
Quote:
Originally Posted by clbailey View Post
I put on some yellow fog light vinyl covers. And made a few of my own roads.

Are your side views backwards? wtf lol
Are those to improve the visibilty in fog? And I do believe they are backwards in that picture...interesting thanks for pointing that out.

Quote:
Originally Posted by bumzo1 View Post
its either the battery or the starter needs to be replaced, the WK starter commonly goes around 60-80k miles.

I myself gave the dub a nice detail and cleaned off all of the sand from when it iced last week.
I had this problem since 38k miles. 4 Hours after the thing rolled off the lot. Been good for a year or so and it just started acting up. I'll put in a new starter in the in spring. Only cost like $80.
__________________
~Black WK Club Member #9~
2011 WKII Overland
2007 WK Limited[/COLOR]
1995 YJ Rio Grande
Devilsmed98 is offline   Reply With Quote
Unread 02-12-2011, 04:51 PM   #5
bumzo1
Registered User
2005 WK 
 
Join Date: May 2010
Location: Texas
Posts: 1,085
have you replaced the battery since then? starters normally die pretty fast (within a month or so) from when they start acting up. It could also be the battery harness.
__________________
'05 WK 3.7L | OME MD lift | 255/75/17 BFG M/Ts | 20" LED Light Bar
Khaki WK Club Member #1
bumzo1 is offline   Reply With Quote
Unread 02-12-2011, 04:54 PM   #6
Devilsmed98
Registered User
1995 YJ Wrangler 
 
Join Date: Nov 2009
Location: Ocean, New Jersey
Posts: 866
Quote:
Originally Posted by bumzo1 View Post
have you replaced the battery since then? starters normally die pretty fast (within a month or so) from when they start acting up. It could also be the battery harness.
Ya OEM Battery went dead in October. I'll tinker with it on Monday when its going to be a beautiful 51* and sunny. Practically summer weather.
__________________
~Black WK Club Member #9~
2011 WKII Overland
2007 WK Limited[/COLOR]
1995 YJ Rio Grande
Devilsmed98 is offline   Reply With Quote
Unread 02-12-2011, 05:00 PM   #7
Budasac
Registered User
2005 WK 
 
Join Date: Nov 2010
Location: Woodbridge, NJ
Posts: 3,153
That's funny, I was thinking about starting the same thread today. Anyway, I polished and waxed the WK today. It actually wasn't snowing for once and was about 35 out so I figured I'd give her a mid winter wax.
just-waxed.jpg  
Budasac is offline   Reply With Quote
Unread 02-12-2011, 05:41 PM   #8
Devilsmed98
Registered User
1995 YJ Wrangler 
 
Join Date: Nov 2009
Location: Ocean, New Jersey
Posts: 866
Damn that looks so nice Buda. I really need to learn how to properly wash/wax my vehicles. Bringing it to the carwash sucks.

I kind of wish I didn't wash mine since now it revealed rock chips all over my hood and fenders =/


*600th post* WOHOOHOO I'm a cyberwheeling Warrior!
__________________
~Black WK Club Member #9~
2011 WKII Overland
2007 WK Limited[/COLOR]
1995 YJ Rio Grande
Devilsmed98 is offline   Reply With Quote
Unread 02-12-2011, 07:36 PM   #9
jager00
Registered User
2005 WK 
 
Join Date: Apr 2009
Location: salisbury, maryland
Posts: 3,840
getting some secret partsput on tomorrow! With lots of pics
__________________
2007 JK Sahara- trying to figure this one out


2005 WK 9" lift on 37's with all the goodies- regretfully sold :(
jager00 is offline   Reply With Quote
Unread 02-12-2011, 08:15 PM   #10
maxst2
Registered User
2006 WK 
 
Join Date: Feb 2010
Location: Oakland, IA
Posts: 546
Went to the local fish store to get some ro/di water for my saltwater tank... thought about getting some seafoam and doing the works to it since I have an oil change soon.
__________________
2006 65th Anni. Grand Cherokee 4x4 in black w/ 4.7L V8
maxst2 is offline   Reply With Quote
Unread 02-12-2011, 08:17 PM   #11
maxst2
Registered User
2006 WK 
 
Join Date: Feb 2010
Location: Oakland, IA
Posts: 546
Oo... bout time to change out the plugs as well.
__________________
2006 65th Anni. Grand Cherokee 4x4 in black w/ 4.7L V8
maxst2 is offline   Reply With Quote
Unread 02-12-2011, 10:05 PM   #12
CmmdrDan
Registered User
 
Join Date: Sep 2010
Posts: 3,175
Quote:
Originally Posted by jager00
getting some secret partsput on tomorrow! With lots of pics
I feel special cause I know..
CmmdrDan is offline   Reply With Quote
Unread 02-13-2011, 12:13 AM   #13
clbailey
Registered User
2005 WK 
 
Join Date: Jan 2011
Location: Senoia, Georgia
Posts: 194
Quote:
Originally Posted by Devilsmed98 View Post
Are those to improve the visibilty in fog? And I do believe they are backwards in that picture...interesting thanks for pointing that out.

Nah, just looks.
clbailey is offline   Reply With Quote
Unread 02-13-2011, 12:14 AM   #14
clbailey
Registered User
2005 WK 
 
Join Date: Jan 2011
Location: Senoia, Georgia
Posts: 194
Quote:
Originally Posted by Devilsmed98 View Post
Are those to improve the visibilty in fog? And I do believe they are backwards in that picture...interesting thanks for pointing that out.

Nah, just looks.
clbailey is offline   Reply With Quote
Unread 02-13-2011, 04:57 AM   #15
jwcardy
Registered User
1997 TJ Wrangler 
 
Join Date: Mar 2009
Location: Nebraska
Posts: 57
Well if you've seen my new to us wk thread you would know that I recently bought my 08. Well on the 4hr drive back home I noticed a little whine in the front end that I didn't notice on the test drive or during the driving my wife and I did while visiting the inlaws. Im a pretty mechanical person so my first thought is tranny or front diff. I have a buddy here in Omaha that is a tech for a dodge/jeep dealership here so I have him take it for a spin with me on his day off today. Ha I just wanted him to listen to the noise but we ended up taking it to the dealership and putting it on the lift and going over the whole jeep. Using a stethoscope we narrowed it down to the front diff. Prob the bearings. Which in a sense is good because its covered under the warranty that came with the jeep. Also while there he hooked me up with a new driverside door weather striping since mine had a tear in it and also a brand new key fob and cut key that he had "laying in his toolbox". I also ended up ordering the factory remote start once he showed me his price on it. Going to try and get the front diff replaced under warranty this week. After that.....the modding will begin.
-Wes
__________________
2008 WK...stock... XK/WK OWNERS GROUP #7
corn fed 2004 neon srt4
boosted 2004 s2000
jwcardy is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.