post #1 of Old 08-04-2013, 12:33 PM Thread Starter
scootter82
Registered User
2009 WK 
 
Join Date: Aug 2012
Location: Aurora
Posts: 424
Water pump for '09 5.7L HEMI

So yesterday I was leaving a convention when I noticed my A/C wasn't really kicking in. Then I noticed a sweet smell coming through the vents, immediately I think radiator leak. Gauges all seem normal. I drive about a block and when I reach the stop light, I notice a very small amount of steam coming up from the hood. I pull over. When parked, I can see an ok amount of radiator fluid dripping out and pouring to the ground. I start the car up to see if I can spot the leak. I can't see the origin, but I do see the radiator fluid boiling in the reservoir and it is still leaking from somewhere. All the hoses look ok, from what I can see. What makes me think this is the water pump is that when the tow truck started to pull it up on the trailer, when it hit the incline and the nose was pointed down, I saw a slow drip of radiator fluid coming from the engine block side of things, around where I think the water pump is.

Can anyone confirm or deny my suspicions? The shop won't be looking at it till tomorrow, Monday. Also, any idea of how much this repair will run me? Is there a "heavy duty" or performance water pump I can get that might be better than stock?

Thanks!


OME HD, JBA UCA, Rear Adj TB, Catch Can, K&N CAI, Gibson CB, MM TB, Flaspaq, Full LED swap
scootter82 is offline  
post #2 of Old 08-04-2013, 06:18 PM
10Xk
Registered User
2014 WK 
 
Join Date: Apr 2012
Posts: 1,092
5.7l Hemi is used in HD Rams. You can see if its the same pump as Ram or see if it is interchangeable.

Water pump is $156

http://www.mopar.com/part/04792838AB...2499168&b=jeep
10Xk is offline  
post #3 of Old 08-06-2013, 07:29 PM Thread Starter
scootter82
Registered User
2009 WK 
 
Join Date: Aug 2012
Location: Aurora
Posts: 424
So it ended up being $533 for a new water pump, thermostat, fluid, and a 30 mile tow and they got it done the next day. Not bad, all in all. Especially since I'm 900 miles away from home at the moment!

OME HD, JBA UCA, Rear Adj TB, Catch Can, K&N CAI, Gibson CB, MM TB, Flaspaq, Full LED swap
scootter82 is offline  
post #4 of Old 08-09-2013, 02:01 AM
kentman
Registered User
 
kentman's Avatar
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,437
That would certainly be about a $100 job at home, but the convenience factor on the road is worth the money. You do not want to overheat, ever.

An '09 with a water pump issue seems early to me. I have an '06 with 109K miles, and I am still on the original pump. How many miles were on your OEM pump?

I had an issue on the XK last year where the overflow tank went empty. I was 900 miles from home also. My issue was the 3-way splitter on the hotside for the heater hose sending hot coolant back to the third row seating HVAC controls. It sprung a leak and sprayed out. I spent about $30 at Napa on a new generic splitter and some HOAT coolant and fixed it with a pocket knife and a screw driver in the in-law's driveway. I had to drive 900 miles the next day. My patch is still solid a year later.

About 800 miles into that trip, I had a previous tire patch repair blow out. I got to put on the spare before getting home. You have got to love the full size spare. That was a Murphy's Law trip. All is well that ends well.

'06 XK Limited, 5.7L, QD II, Black, 150K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 115K
kentman is offline  
post #5 of Old 08-09-2013, 01:47 PM Thread Starter
scootter82
Registered User
2009 WK 
 
Join Date: Aug 2012
Location: Aurora
Posts: 424
It has 81k miles on it. Was in Dallas when it happened. I don't know if the heat down here had anuthing to do with it, but I've been running the ac full blast the whole time. I've hardly used it back home in Denver.

OME HD, JBA UCA, Rear Adj TB, Catch Can, K&N CAI, Gibson CB, MM TB, Flaspaq, Full LED swap
scootter82 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome