Unusual CRD problem - Page 2 - JeepForum.com

LinkBack Thread Tools
post #16 of 18 Old 06-17-2013, 06:43 AM
Registered User
2008 WK 
Join Date: Jul 2012
Location: Pine Grove
Posts: 228
FYI, I get the smell many times that it goes into dpf regen and i'm running just fine. If you have the smell all the time thats certainly an issue, but remember the DPF will go into regen cycle on a pattern.

2008 WK Red Rock Crystal Pearl CRD || Lifted and stuff.
gemiller is offline  
Sponsored Links
post #17 of 18 Old 06-17-2013, 08:13 PM
Registered User
2014 WK 
Join Date: May 2012
Posts: 505
If rough idle/loud idle - replace the crank position sensor. Had the same problem on mine - solved all issues.
inhidin is offline  
post #18 of 18 Old 09-04-2013, 09:49 AM
Registered User
2008 WK 
Join Date: Jun 2013
Location: milton
Posts: 37
Originally Posted by Jeeptheone View Post

I have been told by DC in Aust that this is a one of a kind issue that no one else in the world has experienced to date. The wiring harness has been changed to the PCM, PCM x 2, Injectors twice and the 02 sensor twice just to let you know the effort thye have gone to.

Thanks for the advice.


I also have a recurring cide the same as you. I have had the O2 sensor replaced. The P2A00 code comes back basically right away. You are not one in a million. Maybe two in a million.
miles85 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Unusual sound from radiator area - pics and video included superarmen ZJ Grand Cherokee Forum 4 12-02-2008 03:04 PM
Unusual ZJ questions (keywords: daily driver, manual, sleeper). NuTone ZJ Grand Cherokee Forum 9 08-21-2007 12:40 PM
Unusual occurance with my WJ JPK ZJ Grand Cherokee Forum 10 03-27-2007 09:00 AM
Unusual problem with my 02 WJ Marine_Mike ZJ Grand Cherokee Forum 2 10-24-2006 09:45 PM
unusual sounds..... thejeeper02 ZJ Grand Cherokee Forum 1 08-28-2006 07:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome