Umm..New IAC Not Fitting? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Umm..New IAC Not Fitting?

Rough Country Deals at JeepHut.comSave at JeepHut on Smittybilt Soft topsUp to $75 Cash Back on Your ARB Fridge Freezer Purchase

Reply
Unread 10-29-2013, 06:41 PM   #1
WJFrank88
Registered User
2004 WJ 
 
Join Date: Sep 2010
Location: Westminster, MD
Posts: 107
Umm..New IAC Not Fitting?

I can't explain this or figure it out so I was hoping somebody on here can..

I recently bought an 06 WK (4.7, QDII) with 75k miles. Today, I decided to see how bad the TB looked thinking the PO never really cleaned it. I cleaned the TB out good with Intake cleaner, didn't take it off to clean it (i'll do that another day, just wanted to see how bad it was)

I also wanted to see how bad the IAC looked, which is where my problems started. I remove the hex bolt, and TRY EVERYTHING to remove it, it seemed glued in there. I took a flat head and pried it outta there after a few attempts. I couldn't believe how hard it was to take off but I got it out so I cleaned it up.

However, no matter which way I tried to slide it back in, it would not budge. I lined the hole up with the one on the TB and tried pushing it in from every angle and it would not slide in! WTF?!! By this point, I'm frustrated as all hell and wind up breaking the top off of it trying to shimmy it in...Again, WTF

Luckily, Advanced had a new one in stock. I went to replace it thinking I wouldn't have the same problem, I was wrong. Again, it wouldn't go in.. So I took the bolt and screwed it in as much as possible, now its crooked. What am I doing wrong?

I should mention I had a WJ, and replaced the IAC on that twice without issue and am fairly handy with a wrench when it comes to jeeps, I just don't know what I'm missing here.

The jeep started, and idles fine with it like it is, I just don't think its good that the IAC sensor isn't going in all the way..

20131029_172148.jpg  
__________________
2006|4.7|QDII|OME HD|265/70/17Grabber AT2|D-ring receiver|Magnaflow|3' Firestik|Steel Armadillo
WJFrank88 is offline   Reply With Quote
Unread 10-30-2013, 07:56 AM   #2
WJFrank88
Registered User
2004 WJ 
 
Join Date: Sep 2010
Location: Westminster, MD
Posts: 107
Bump
__________________
2006|4.7|QDII|OME HD|265/70/17Grabber AT2|D-ring receiver|Magnaflow|3' Firestik|Steel Armadillo
WJFrank88 is offline   Reply With Quote
Unread 10-30-2013, 08:30 AM   #3
caulk04
Registered User
2008 WK 
 
Join Date: Jan 2013
Location: Greenville, Pennsylvania
Posts: 793
Looks like a tight o-ring that isn't going into the TB properly. I'm unfamiliar with the single bolt IAC, my old 4.7 was a two bolt setup like it would have been on your WJ (if a 4.7).

If it is an o-ring, try lubricating the ring and bore with some WD-40, oil or similar and wiggle/twist it to seat the o-ring.
__________________
Tint, Superchips, SRT intake tube, Gibson catback, catch can. One hardcore DD/kid hauler...yeah.
caulk04 is offline   Reply With Quote
Unread 11-01-2013, 09:38 AM   #4
DVB
Registered User
2006 WK 
 
Join Date: Aug 2013
Location: Chicago, Il
Posts: 174
I feel your pain. I pretty much had to pry mine off as well and had the same problems getting it back on too, I just kind of tapped it back in with a couple small pieces of firewood (that's all I had nearby). Since I had the whole TB off it was easier to work on it. Unfortunately, the minor cleaning didn't help so I am replacing it this weekend. Hope it goes smoother.
__________________
2006 4.7 Limited QD II, Stock
DVB is offline   Reply With Quote
Unread 11-01-2013, 10:21 AM   #5
DVB
Registered User
2006 WK 
 
Join Date: Aug 2013
Location: Chicago, Il
Posts: 174
caulk04, I was thinking of using some kind of lubricant too, I just wasn't sure what would be safe to use.
__________________
2006 4.7 Limited QD II, Stock
DVB is offline   Reply With Quote
Unread 11-01-2013, 11:40 AM   #6
caulk04
Registered User
2008 WK 
 
Join Date: Jan 2013
Location: Greenville, Pennsylvania
Posts: 793
Doesn't really matter what you use, you don't need much. Pull the dipstick and wipe a little oil on your finger then on the o-ring for that matter...don't even have to look for anything that way.
__________________
Tint, Superchips, SRT intake tube, Gibson catback, catch can. One hardcore DD/kid hauler...yeah.
caulk04 is offline   Reply With Quote
Unread 11-01-2013, 01:48 PM   #7
DVB
Registered User
2006 WK 
 
Join Date: Aug 2013
Location: Chicago, Il
Posts: 174
Sounds good, thanks.
__________________
2006 4.7 Limited QD II, Stock
DVB is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.