Uconnect/Satellite Problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Uconnect/Satellite Problems

Poison Spyder DeFenders™ - "Tubeless" Jeep FendeAll Bilstein shocks & struts - Lowest Prices Ever and Santa Kolak Announces: Kolak Exhaust 20% Off Sale!

Reply
Unread 03-11-2011, 03:03 PM   #1
Jbattle10
Registered User
2005 WK 
 
Join Date: Mar 2011
Location: Greenville, NC
Posts: 7
Uconnect/Satellite Problems

I purchased a 2005 Jeep GC about a year ago. It has the factory Uconnect on the mirror, GPS and rear entertainment system. The Uconnect doesn't work. Someone had said that I might have to take it to the dealer for them to do something with it. When the button is pressed, nothing happens. Is there a way I can turn it on somehow, or does it have to be done at the dealership? Also - I have the factory satellite radio, in my previous car, I could still turn on the satellite radio to get the ID number, etc. I turn it to SAT and it's just frozen on a station, any ideas on how to get that turned on. Sirrius needs the ID number and I don't know how to obtain it.

Jbattle10 is offline   Reply With Quote Quick reply to this message
Unread 03-12-2011, 01:34 PM   #2
Jbattle10
Registered User
2005 WK 
 
Join Date: Mar 2011
Location: Greenville, NC
Posts: 7
I have the Satellite working now - but still can't get the Uconnect working.
Jbattle10 is offline   Reply With Quote Quick reply to this message
Unread 03-12-2011, 02:41 PM   #3
90grandoneer
Registered User
2006 WK 
 
Join Date: Apr 2008
Location: City of Trees
Posts: 1,862
Do you have a bluetooth equipped cell phone? Is bluetooth activated on it? Have you paired it to the UConnect system? I believe there is a TSB on the early UConnect for some problems. Check and see if your vehicle is included. The UConnect module is located in the passenger side kick panel area. http://www.wkjeeps.com/wk_tsb.htm Good luck.
__________________
06 GCO, Dk Khaki, QDII, Flshing Hi 3rd Bk Lt, MDS "ON" Lt, Airtab Vortex Gens, Debadged, Fumoto Drain Valve, BT Catch Can, Chopped EGR Tube, SRT8 CAI, K&N Filter, Sonnax Trans Line Press Booster, SC Tuner W/Adv Trans Tune App, DS Tuner, Cust tubular hdrs w/3 in Magnaflow/Xlerator AP Exh Sys, Bilsteins, SRT Springs/Sways, Cust Eng Cvr, SRT8 frt/rear bumpers, FRI Sidewinder Cam/6.1 valvetrain, SLP 25% UD Pulley, BBK true 90mm T-Body, SOS Ign Coils w/.060 spark plug gaps, SRT Reps with 265/45&295/40X20's.
90grandoneer is offline   Reply With Quote Quick reply to this message
Unread 03-13-2011, 02:34 PM   #4
Jbattle10
Registered User
2005 WK 
 
Join Date: Mar 2011
Location: Greenville, NC
Posts: 7
Quote:
Originally Posted by 90grandoneer View Post
Do you have a bluetooth equipped cell phone? Is bluetooth activated on it? Have you paired it to the UConnect system? I believe there is a TSB on the early UConnect for some problems. Check and see if your vehicle is included. The UConnect module is located in the passenger side kick panel area. http://www.wkjeeps.com/wk_tsb.htm Good luck.
I do have a Bluetooth equipped cell phone, and it is turned on. I have been reading through forum after forum, most people who are having problems will press the Uconnect button and hear it say "not equipped" mine doesn't even say anything. I don't know what's wrong with it, and the dealer wants to charge $98 to even look at it! I think I located the module, but I don't know what I am looking for within the module to see if it's hooked up or what not.
Jbattle10 is offline   Reply With Quote Quick reply to this message
Unread 03-14-2011, 08:51 PM   #5
90grandoneer
Registered User
2006 WK 
 
Join Date: Apr 2008
Location: City of Trees
Posts: 1,862
If you have the bluetooth function on your phone activated, unless it is one of several new (don't know which ones though) smart phones, it should work. Some of the new phones have Hands Free Profiles that are not compatible with the older system. The book shows Bluetooth Hands Free Profile, version 0.96 or higher. The battery in the phone must also be almost fully charged.

I really think your problem is in the UConnect system though, since you're not getting any voice from the unit. Have you tried pushing the UConnect button and after a few seconds, saying, "Help"? That should take you to the help menu. Do you have the Nav. or radio only unit? Are you getting any Diagnostic Trouble Codes (DTC)? If so, what are they? Did you check to see if there are any TSB's that pertain to your year/model UConnect system? If you don't have any codes, the next things I would do are:

--I don't know if there is a separate fuse for the UConnect, but I would guess there is. Check the fuses in the Forward Control Module (FCM) under the hood.
--Try disconnecting the battery for about 15 minutes, which will reset all the adaptives and everything else.
--If that doesn't do it, try unplugging and replugging the UConnect Module. We're looking for a poor connection of some sort.
--You can also try pushing (together) the UConnect (phone picture) and the Voice Recognition (talking face) buttons simultaneously for about 10-15 seconds. This is suppose to reset the system, but I am not sure it works, as I've tried it, and it didn't appear to do anything.

If none of that works, unfortunately I think it may be time for a trip to the dealer.

I have an 05 LX with the radio UConnect and I have never had a day of trouble from it. On the other hand I have an 06 WK with the Nav. UConnect and it has always been goofy from time to time. It did work better after I updated the Calibration ID (CALID) flash file to the most current. If you have a Diablosport Tuner you can do it yourself, otherwise the dealer will hit you about $100 or more, and that's no guarantee that it will fix it. They would have to hook it up to their StarScan scan tool to
__________________
06 GCO, Dk Khaki, QDII, Flshing Hi 3rd Bk Lt, MDS "ON" Lt, Airtab Vortex Gens, Debadged, Fumoto Drain Valve, BT Catch Can, Chopped EGR Tube, SRT8 CAI, K&N Filter, Sonnax Trans Line Press Booster, SC Tuner W/Adv Trans Tune App, DS Tuner, Cust tubular hdrs w/3 in Magnaflow/Xlerator AP Exh Sys, Bilsteins, SRT Springs/Sways, Cust Eng Cvr, SRT8 frt/rear bumpers, FRI Sidewinder Cam/6.1 valvetrain, SLP 25% UD Pulley, BBK true 90mm T-Body, SOS Ign Coils w/.060 spark plug gaps, SRT Reps with 265/45&295/40X20's.
90grandoneer is offline   Reply With Quote Quick reply to this message
Unread 03-15-2011, 07:45 AM   #6
Jbattle10
Registered User
2005 WK 
 
Join Date: Mar 2011
Location: Greenville, NC
Posts: 7
I have the REC Navigation Radio. I tried pushing the two Uconnect buttons simultaneously with no response. I will have to try the unhooking and rebooting the module. Someone also said there has to be a chip in the system, any ideas what that means?
Jbattle10 is offline   Reply With Quote Quick reply to this message
Unread 03-15-2011, 01:28 PM   #7
mwalters2
Registered User
2005 WK 
 
Join Date: Jul 2009
Location: Monroe
Posts: 39
I have the same '05 equipped U-connect with Nav and rear seat entertainment. I noticed when I disconnect the battery for awhile, then the U-connect starts working again. Might be worth a shot!
__________________
2005 Jeep Grand Cherokee Larado 4.7L
mwalters2 is offline   Reply With Quote Quick reply to this message
Unread 03-15-2011, 04:00 PM   #8
90grandoneer
Registered User
2006 WK 
 
Join Date: Apr 2008
Location: City of Trees
Posts: 1,862
Jb, they're probably talking about some sort of microchip, which I am sure it does have. Have you checked for TSB's and fuses yet? Does the rest of the Nav/radio/CD changer, etc. work? Also, the UConnect has a separate volume control, although it's the same control, from the radio. Push the UConnect button and turn the volume control up? What happens? It should show on volume bar on the bottom of the screen. If the UConnect is working at all, when you push the UConnect button the Nav. screen should go blank and you should get some sort of indication that the Nav/radio unit has received a signal from the UConnect system. If none of that is happening, I'd go back to fuses or power source issues. I guess it could also be a control button in the mirror. Seems to me I've heard that before somewhere. Let's take it a step at a time and see what happens before you have to go to the rip off center, aka dealer. Does anyone else out there have any ideas??
__________________
06 GCO, Dk Khaki, QDII, Flshing Hi 3rd Bk Lt, MDS "ON" Lt, Airtab Vortex Gens, Debadged, Fumoto Drain Valve, BT Catch Can, Chopped EGR Tube, SRT8 CAI, K&N Filter, Sonnax Trans Line Press Booster, SC Tuner W/Adv Trans Tune App, DS Tuner, Cust tubular hdrs w/3 in Magnaflow/Xlerator AP Exh Sys, Bilsteins, SRT Springs/Sways, Cust Eng Cvr, SRT8 frt/rear bumpers, FRI Sidewinder Cam/6.1 valvetrain, SLP 25% UD Pulley, BBK true 90mm T-Body, SOS Ign Coils w/.060 spark plug gaps, SRT Reps with 265/45&295/40X20's.
90grandoneer is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.