UConnect and Radio stopped working -
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > UConnect and Radio stopped working

FS: Wranger BRIGHT License Plate LED! Just $3! Great value6th annual beat your wife to the credit cards sale!!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome Effect

Unread 12-29-2008, 01:02 PM   #1
Registered User
Join Date: Dec 2008
Location: Ny
Posts: 20
UConnect and Radio stopped working

Hey Guys,

I am having trouble with my uConnect device and my Radio. Yesterday I pressed the speak button on the uConnect device, after that the uConnect device would not turn on. MY radio would turn on but the I can not change the volume it's stuck at 0. I have tried the reset for uConnect holding down 2 button and the starting the car. It didn't help. I called Jeep they said go to the dealer and they will do a hard reset by taking out the fuse for the uConnect. Does anyone know where the Fuse box with the uConnect fuse is located. I have a Jepp GC 2007 Laredo.


ekam is offline   Reply With Quote Quick reply to this message
Unread 12-29-2008, 07:35 PM   #2
Registered User
2005 WK 
Join Date: Nov 2008
Location: DLI, Monterey, California
Posts: 231
I'm not sure about the WK, but fuse boxes are usually under the steering wheel/console area. Most of the time they are covered by a black plastic box, so grab a flashlight and take a look.
Floof is offline   Reply With Quote Quick reply to this message
Unread 12-30-2008, 09:43 AM   #3
Registered User
Join Date: Jul 2007
Location: England
Posts: 2,944
Fuses are all listed here reset info here
UK Chrysler Jeep Master Tec.
merlinTec is offline   Reply With Quote Quick reply to this message
Unread 01-04-2009, 09:33 PM   #4
Registered User
2013 WK 
Join Date: Mar 2007
Location: Florida
Posts: 493
It may not be the best thing to do but I have "RESET" mine twice now by disconnecting the battery. Crude but effective.. <shrug>.
05 Grand Cherokee Limited 5.7 Hemi 265/65/17 Revos, K&N
Previous Jeeps:
1998 ZJ Special Edition 2wd- Traded
1991 XJ 2.8 2wd Sold
HurriJeff is offline   Reply With Quote Quick reply to this message
Unread 07-01-2010, 09:04 PM   #5
Registered User
Join Date: Jul 2010
Location: Maryland
Posts: 1
The Jeep service bulletin says to remove the Ignition Off-Draw (IOD) fuse for 10 seconds, then replace it. (See merlinTec's post for the fuse info URL.) Turn the ignition on, but do not restart the vehicle. The UConnect system should be reset and work properly.

If this does not work, the bulletin goes on to say the firmware needs to be reloaded from the navigation CD. This appears to require special equipment, so it looks like a job for the dealer. The bulletin indicates there should be a 1/2 hour labor charge.

Good luck.
TheOriginalMdot is offline   Reply With Quote Quick reply to this message

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Suggested Threads

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. is not in any way associated with Jeep or the Chrysler Corp.