Uconnect nav gets really hot - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 02-15-2014, 12:46 PM Thread Starter
JF97
Registered User
2010 WK 
 
Join Date: Jan 2014
Posts: 140
Uconnect nav gets really hot

I've noticed that when I tough the nav, it is really hot, like touching a black car when it's sunny out. Is this normal?

JF97 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 02-15-2014, 03:02 PM
pawwright
Registered User
 
Join Date: Oct 2012
Location: fancy
Posts: 73
Yep - I say it's normal - if I use the nav function it always runs super hot - and the fan for the unit always runs for awhile after I shut the heep off....
pawwright is offline  
post #3 of 7 Old 02-15-2014, 03:59 PM
Chirpz
Registered User
2007 WK 
 
Join Date: Aug 2009
Location: Battle Ground
Posts: 1,351
Hmm... touch it where? Mine is an 07, may be different than yours. I have Uconnect and Nav and rear camera. Nothing ever get hot.

Chirpz
2007 WK 3.0L CRD, Quadradrive II, GDE EcoTune, DPF-Delete
4xGuard Front, Rear, Belly, & Side Rails, Factory Skids
EHM MOD, Garmin Mechanic EcoHD, K&N Filter (Deleted)
Chirpz is offline  
post #4 of 7 Old 02-16-2014, 06:01 AM
pawwright
Registered User
 
Join Date: Oct 2012
Location: fancy
Posts: 73
Quote:
Originally Posted by Chirpz View Post
Hmm... touch it where? Mine is an 07, may be different than yours. I have Uconnect and Nav and rear camera. Nothing ever get hot.
Sorry - in my follow-up I should have mentioned I have a 2008 RER radio........
pawwright is offline  
post #5 of 7 Old 02-16-2014, 08:28 PM
jeeptwins
Registered User
2008 WK 
 
Join Date: Nov 2007
Location: Hanover, Ontario
Posts: 34
Hi JF97
We noticed our nav radio on our 08 WK ,with automatic climate control, getting really hot after switching from a/c in the summer to heating in the winter while leaving the control knobs in the Auto setting. We switched to any of the manual heat settings and things cooled down dramatically. Give it a try.
Jeeptwins
jeeptwins is offline  
post #6 of 7 Old 02-17-2014, 06:32 AM Thread Starter
JF97
Registered User
2010 WK 
 
Join Date: Jan 2014
Posts: 140
Quote:
Originally Posted by jeeptwins
Hi JF97 We noticed our nav radio on our 08 WK ,with automatic climate control, getting really hot after switching from a/c in the summer to heating in the winter while leaving the control knobs in the Auto setting. We switched to any of the manual heat settings and things cooled down dramatically. Give it a try. Jeeptwins
Ive been using auto heat, so that's probably it. Thanks for the tip, I'll try it.
JF97 is offline  
post #7 of 7 Old 02-17-2014, 08:49 AM
jeeptwins
Registered User
2008 WK 
 
Join Date: Nov 2007
Location: Hanover, Ontario
Posts: 34
Hi JF97
Let us know if that also works for you. We are hoping it wasn't just a coincidence that the hot nav radio cooled down when we changed to the manual setting.
Jeeptwins
jeeptwins is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome