Uconnect nav gets really hot - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Uconnect nav gets really hot

ROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO NEW JK WRANGLER GRAB BARS NOW at ROCKRIDGE4WD

Reply
Unread 02-15-2014, 12:46 PM   #1
JF97
Registered User
2010 WK 
 
Join Date: Jan 2014
Location: , Michigan
Posts: 119
Uconnect nav gets really hot

I've noticed that when I tough the nav, it is really hot, like touching a black car when it's sunny out. Is this normal?

JF97 is offline   Reply With Quote
Unread 02-15-2014, 03:02 PM   #2
pawwright
Registered User
 
Join Date: Oct 2012
Location: fancy, tn
Posts: 34
Yep - I say it's normal - if I use the nav function it always runs super hot - and the fan for the unit always runs for awhile after I shut the heep off....
pawwright is offline   Reply With Quote
Unread 02-15-2014, 03:59 PM   #3
Chirpz
Senior Member
 
Chirpz's Avatar
2007 WK 
 
Join Date: Aug 2009
Location: Battle Ground, Washington
Posts: 737
Hmm... touch it where? Mine is an 07, may be different than yours. I have Uconnect and Nav and rear camera. Nothing ever get hot.
__________________
[B]Chirpz[/B]
2007 WK 3.0L CRD, Quadradrive II, GDE EcoTune, DPF-Delete
4xGuard Front, Rear, Belly, & Side Rails, Factory Skids
EHM MOD, Garmin Mechanic EcoHD, K&N Filter (Deleted)
Chirpz is offline   Reply With Quote
Unread 02-16-2014, 06:01 AM   #4
pawwright
Registered User
 
Join Date: Oct 2012
Location: fancy, tn
Posts: 34
Quote:
Originally Posted by Chirpz View Post
Hmm... touch it where? Mine is an 07, may be different than yours. I have Uconnect and Nav and rear camera. Nothing ever get hot.
Sorry - in my follow-up I should have mentioned I have a 2008 RER radio........
pawwright is offline   Reply With Quote
Unread 02-16-2014, 08:28 PM   #5
jeeptwins
Registered User
2008 WK 
 
Join Date: Nov 2007
Location: Hanover, Ontario
Posts: 21
Hi JF97
We noticed our nav radio on our 08 WK ,with automatic climate control, getting really hot after switching from a/c in the summer to heating in the winter while leaving the control knobs in the Auto setting. We switched to any of the manual heat settings and things cooled down dramatically. Give it a try.
Jeeptwins
jeeptwins is offline   Reply With Quote
Unread 02-17-2014, 06:32 AM   #6
JF97
Registered User
2010 WK 
 
Join Date: Jan 2014
Location: , Michigan
Posts: 119
Quote:
Originally Posted by jeeptwins
Hi JF97 We noticed our nav radio on our 08 WK ,with automatic climate control, getting really hot after switching from a/c in the summer to heating in the winter while leaving the control knobs in the Auto setting. We switched to any of the manual heat settings and things cooled down dramatically. Give it a try. Jeeptwins
Ive been using auto heat, so that's probably it. Thanks for the tip, I'll try it.
JF97 is offline   Reply With Quote
Unread 02-17-2014, 08:49 AM   #7
jeeptwins
Registered User
2008 WK 
 
Join Date: Nov 2007
Location: Hanover, Ontario
Posts: 21
Hi JF97
Let us know if that also works for you. We are hoping it wasn't just a coincidence that the hot nav radio cooled down when we changed to the manual setting.
Jeeptwins
jeeptwins is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.