Twistedlizard72's Build and other Adventures - Page 4 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #46 of 109 Old 06-19-2013, 05:49 AM
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore
Posts: 4,688
Quote:
Originally Posted by twistedlizard72 View Post
If I remember right, it was vehicles made after 2003/2004? If I get some spare time, I will give them a shout and get the scoop.

The Trans-go kits come in two varieties, the light version which can all be accessed through the oil pan. That version is the cheaper one and upgrades the accumulator plate along with a few solenoid springs and goodies. The bigger kit is usually around the $100 mark and comes with improved spring clips. This kit you have to pull the transmission to get everything on.

I should have it back Friday and will report.
which one id you go with?


2007.5 WK Laredo 4.7
OEM+
paroxysym is offline  
Sponsored Links
Advertisement
 
post #47 of 109 Old 06-19-2013, 02:23 PM Thread Starter
twistedlizard72
Registered User
2007 WK 
 
Join Date: Apr 2011
Location: Piņon Hills
Posts: 309
I did the big kit since the transmission is out and in pieces.

Kevin K.

WANTED: AFE CAI for '07 4.7L WK
twistedlizard72 is offline  
post #48 of 109 Old 06-19-2013, 03:28 PM
Jeepforthewin
Registered User
2010 JK Wrangler 
 
Join Date: Jan 2013
Location: Jacksonville
Posts: 2,134
You'll have to let us know how the difference is once your transmission is back in!

2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline  
post #49 of 109 Old 06-23-2013, 09:38 PM Thread Starter
twistedlizard72
Registered User
2007 WK 
 
Join Date: Apr 2011
Location: Piņon Hills
Posts: 309
Here's the scoop on the trans rebuild and Trans Go shift kit...I LOVE IT!!

All new parts went into the transmission including a shift solenoid body. The kit really made a good difference. It don't really think it should be classified as a shift kit, more like a "fix what Mopar didn't" kit. It holds onto 1st gear a little longer at WOT. No waiting for the gear to engage when shifting from park. Up shifts are smooth and seamless as well as down shifts. You really have to pay attention to feel the shifts because it is so smooth now. Best way to describe it is, Solid. Running better than the day it came off the production line.

At this point, I highly recommend this kit, especially if you have the transmission out of the vehicle. If not, put in the shift kit accessible through the pan and save the rest for when the trans has to be rebuilt.

One thing to note, the transmission filter only had 9,000 miles on it and it had already split. Not sure if that had anything to do with the day I broke it, or if that was part of why it broke, but the filter failed....and rather early at that. So keep an eye on that fellow WK Jeepers.

Kevin K.

WANTED: AFE CAI for '07 4.7L WK
twistedlizard72 is offline  
post #50 of 109 Old 06-25-2013, 06:23 AM
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore
Posts: 4,688
so the solenoid pack needed replaced as well or you decided to replace those regardless?

2007.5 WK Laredo 4.7
OEM+
paroxysym is offline  
post #51 of 109 Old 06-25-2013, 09:50 AM Thread Starter
twistedlizard72
Registered User
2007 WK 
 
Join Date: Apr 2011
Location: Piņon Hills
Posts: 309
I had it replaced regardless. I kept the old one to have an emergency spare around.

Kevin K.

WANTED: AFE CAI for '07 4.7L WK
twistedlizard72 is offline  
post #52 of 109 Old 10-16-2013, 02:58 PM
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore
Posts: 4,688
any updates?

2007.5 WK Laredo 4.7
OEM+
paroxysym is offline  
post #53 of 109 Old 12-10-2013, 12:55 PM Thread Starter
twistedlizard72
Registered User
2007 WK 
 
Join Date: Apr 2011
Location: Piņon Hills
Posts: 309
Got home today from a 5 month deployment and fired up the Jeep. Running good, took a minute to run out the flat spots in the tires. Trans is impeccable. I was however given the gift (by the Jeep) of 4 new DTC's.

1. P1128, which I thought I had solved when I replaced all 4 O2 sensors 7 months ago.
2. U0001- Can C Bus Circuit (oh god, here we go…..)
3. C1407-TRANSFER CASE BRAKE CONTROL CIRCUIT LOW
4. C1405- TRANSFER CASE RANGE POSITION SENSOR CIRCUIT HIGH

So needless to say, there is going to be some work going down. Just hope it doesn't strand me being I got quite a few miles to log over the holidays. I do plan to get my Aspen Creek recovery shackles on here in the next few days.

Kevin K.

WANTED: AFE CAI for '07 4.7L WK
twistedlizard72 is offline  
post #54 of 109 Old 12-10-2013, 01:27 PM
Jeepforthewin
Registered User
2010 JK Wrangler 
 
Join Date: Jan 2013
Location: Jacksonville
Posts: 2,134
Welcome back!! Glad you are safe and sound now. Hooefully the codes are thrown by something simple

2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline  
post #55 of 109 Old 12-10-2013, 01:41 PM
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore
Posts: 4,688
welcome back, the DTCs are your jeeps way of saying it missed you lol.

2007.5 WK Laredo 4.7
OEM+
paroxysym is offline  
post #56 of 109 Old 12-10-2013, 08:00 PM Thread Starter
twistedlizard72
Registered User
2007 WK 
 
Join Date: Apr 2011
Location: Piņon Hills
Posts: 309
Thanks, it's great to be home.

Not sure what was up with the DTC's, I went and got the driveline measured and right after that they codes cleared. Just keep an eye on it, I really don't want that T-case computer re-flash.

Kevin K.

WANTED: AFE CAI for '07 4.7L WK
twistedlizard72 is offline  
post #57 of 109 Old 12-10-2013, 08:08 PM
ttusqrl
Registered User
2005 WK 
 
Join Date: Oct 2007
Location: Dallas
Posts: 492
If you have been gone for that long, I wonder if the variety of codes is due to a failing battery.

Sent from my iPhone using JeepForum

2005 WK 5.7 ORT | Mod SL (OME struts & 990s) | JBA UCAs & Discos | Saguaro Front Bumper | Warn Zeon 10s | 285/70/17 BFG TA KO | AIRAID CAI | Gibson 3" Exhaust | DiabloSport Intune | JL Stealthbox
ttusqrl is offline  
post #58 of 109 Old 12-11-2013, 12:05 AM Thread Starter
twistedlizard72
Registered User
2007 WK 
 
Join Date: Apr 2011
Location: Piņon Hills
Posts: 309
That crossed my mind too. It is an ancient battery.

Kevin K.

WANTED: AFE CAI for '07 4.7L WK
twistedlizard72 is offline  
post #59 of 109 Old 12-11-2013, 06:34 AM
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore
Posts: 4,688
so with the 285s, you just did the procal and the transgo kit? no superchips?

hows performance/mpgs without a tuner?

2007.5 WK Laredo 4.7
OEM+
paroxysym is offline  
post #60 of 109 Old 12-11-2013, 07:12 AM Thread Starter
twistedlizard72
Registered User
2007 WK 
 
Join Date: Apr 2011
Location: Piņon Hills
Posts: 309
I do have a super chips but haven't use it for calibration, and I don't have the trans tuner app. I run the performance 87 tune majority of the time. Performance is good, considering it's the 4.7 and my mixed driving has been yielding mid 14's (EVIC) mpg since I got home. Best I have seen on the highway is 19. Haven't tried at stock settings yet.

Kevin K.

WANTED: AFE CAI for '07 4.7L WK
twistedlizard72 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome