Transmission help!!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Transmission help!!!

2014 Spartan Locker Special - While Supplies Last! Dana 3OPTIC ARMOR WINDOWS all sale now !!!!!!!!Rockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 04-09-2014, 04:10 PM   #1
94jeepman
Jager93
 
94jeepman's Avatar
2005 WK 
 
Join Date: Apr 2011
Location: rapid city, south dakota
Posts: 633
Transmission help!!!

throwing a bunch of codes and cant get the jeep to move unless its floored. stays in 3rd gear.
P0700, p0868, p0740, p0732, p1790, p0944, p0736, p0876

__________________
KHAKI MEMBER #59


The WK mods: SC flashpaq 3870, flow master super 40, 3.5" X Factor leveling kit, 33" M/T baja claws, 17" pro comp wheels, one 12 inch subwoofer, rugged ridge tailight gaurds, rola rack with 18" extension
94jeepman is offline   Reply With Quote
Unread 04-09-2014, 05:00 PM   #2
yzjwk
Registered User
2005 WK 
 
Join Date: Apr 2011
Location: Lac du Bonnet, manitoba, Can
Posts: 1,070
Quote:
Originally Posted by 94jeepman View Post
throwing a bunch of codes and cant get the jeep to move unless its floored. stays in 3rd gear.
P0700, p0868, p0740, p0732, p1790, p0944, p0736, p0876
It's in limp mode . Erase the codes either with a scanner , or battery cable.
See if they come back . Could be a badly Split filter .
__________________
Proud owner : 05 WK Ltd 5.7 HEMI
90 YJ Islander 4.2 Cam'd & Decked
94 ZJ Ltd 5.2
00 WJ 4.0
yzjwk is offline   Reply With Quote
Unread 04-09-2014, 05:45 PM   #3
94jeepman
Jager93
 
94jeepman's Avatar
2005 WK 
 
Join Date: Apr 2011
Location: rapid city, south dakota
Posts: 633
I erased the codes still doing it. Now my reverse is drive my neutral is drive and drive still stays in 3rd gear
__________________
KHAKI MEMBER #59


The WK mods: SC flashpaq 3870, flow master super 40, 3.5" X Factor leveling kit, 33" M/T baja claws, 17" pro comp wheels, one 12 inch subwoofer, rugged ridge tailight gaurds, rola rack with 18" extension
94jeepman is offline   Reply With Quote
Unread 04-09-2014, 06:24 PM   #4
modernblueWK
Registered User
 
Join Date: Jan 2010
Location: Gunnison, CO
Posts: 1,677
Double check the mechanical shift linkage.
__________________
2008 wk 4.7 v8 Laredo X QTII - 245/70-17 at2 - Magnflow 13742
Blue WK club #4
2013 HEMI Durango Awd Crew. All stock
modernblueWK is offline   Reply With Quote
Unread 04-09-2014, 07:46 PM   #5
yzjwk
Registered User
2005 WK 
 
Join Date: Apr 2011
Location: Lac du Bonnet, manitoba, Can
Posts: 1,070
P0740–TCC OUT OF RANGE
P0868-LINE PRESSURE LOW
P0732-GEAR RATIO ERROR IN 2ND
P1790-FAULT IMMEDIATELY AFTER SHIFT
P0944-LOSS OF HYDRAULIC PUMP PRIME
P0736-GEAR RATIO ERROR IN REVERSE
P0876-UD PRESSURE SWITCH RATIONALITY

It looks like something might have gone in the transmission to loose prime & pressure , unless you have little to no fluid .I guess the shift mechanism or PCM/TCM module could cause the issue , but if the connections are good/clean , I would be dropping the pan myself and checking the filters .
__________________
Proud owner : 05 WK Ltd 5.7 HEMI
90 YJ Islander 4.2 Cam'd & Decked
94 ZJ Ltd 5.2
00 WJ 4.0
yzjwk is offline   Reply With Quote
Unread 04-09-2014, 10:12 PM   #6
94jeepman
Jager93
 
94jeepman's Avatar
2005 WK 
 
Join Date: Apr 2011
Location: rapid city, south dakota
Posts: 633
Filters just went in around 8000 miles ago. So that was going to be my last option to check. But you never know
__________________
KHAKI MEMBER #59


The WK mods: SC flashpaq 3870, flow master super 40, 3.5" X Factor leveling kit, 33" M/T baja claws, 17" pro comp wheels, one 12 inch subwoofer, rugged ridge tailight gaurds, rola rack with 18" extension
94jeepman is offline   Reply With Quote
Unread 04-10-2014, 05:47 AM   #7
caulk04
Registered User
2008 WK 
 
Join Date: Jan 2013
Location: Greenville, Pennsylvania
Posts: 609
Could be a split filter or a blown accumulator plate. Maybe something else, but the pan must come off to check for either of those things.

Limp mode should allow R 2 and 3, user selectable with the shifter. If the accumulator plate is blown though, that puts a whole 'nother wrench into that.
__________________
Tint, Superchips, SRT intake tube, Gibson catback, catch can. One hardcore DD/kid hauler...yeah.
caulk04 is offline   Reply With Quote
Unread 04-10-2014, 06:26 AM   #8
94jeepman
Jager93
 
94jeepman's Avatar
2005 WK 
 
Join Date: Apr 2011
Location: rapid city, south dakota
Posts: 633
Quote:
Originally Posted by caulk04 View Post
Could be a split filter or a blown accumulator plate. Maybe something else, but the pan must come off to check for either of those things.

Limp mode should allow R 2 and 3, user selectable with the shifter. If the accumulator plate is blown though, that puts a whole 'nother wrench into that.
I'll have to dig into it when I have time. I need it fixed ASAP but have a bunch of other stuff going on now so I don't know what to do at the moment. Would a split filter make it throw 8 codes?
__________________
KHAKI MEMBER #59


The WK mods: SC flashpaq 3870, flow master super 40, 3.5" X Factor leveling kit, 33" M/T baja claws, 17" pro comp wheels, one 12 inch subwoofer, rugged ridge tailight gaurds, rola rack with 18" extension
94jeepman is offline   Reply With Quote
Unread 04-10-2014, 06:44 AM   #9
kris06
Registered User
2006 WK 
 
Join Date: Mar 2013
Posts: 34
Split filter and if there was no pressure your clutches went bad to due to no pressure
kris06 is offline   Reply With Quote
Unread 04-10-2014, 10:43 PM   #10
94jeepman
Jager93
 
94jeepman's Avatar
2005 WK 
 
Join Date: Apr 2011
Location: rapid city, south dakota
Posts: 633
Could it be a split filter if I'm going forward in reverse and neutral tho?
__________________
KHAKI MEMBER #59


The WK mods: SC flashpaq 3870, flow master super 40, 3.5" X Factor leveling kit, 33" M/T baja claws, 17" pro comp wheels, one 12 inch subwoofer, rugged ridge tailight gaurds, rola rack with 18" extension
94jeepman is offline   Reply With Quote
Unread 04-12-2014, 06:09 PM   #11
kris06
Registered User
2006 WK 
 
Join Date: Mar 2013
Posts: 34
Is it in a limp mode?
kris06 is offline   Reply With Quote
Unread 04-12-2014, 09:57 PM   #12
94jeepman
Jager93
 
94jeepman's Avatar
2005 WK 
 
Join Date: Apr 2011
Location: rapid city, south dakota
Posts: 633
Quote:
Originally Posted by kris06 View Post
Is it in a limp mode?
How do you check that?
__________________
KHAKI MEMBER #59


The WK mods: SC flashpaq 3870, flow master super 40, 3.5" X Factor leveling kit, 33" M/T baja claws, 17" pro comp wheels, one 12 inch subwoofer, rugged ridge tailight gaurds, rola rack with 18" extension
94jeepman is offline   Reply With Quote
Unread 04-13-2014, 07:32 AM   #13
kris06
Registered User
2006 WK 
 
Join Date: Mar 2013
Posts: 34
Does it get stuck on third gear ?
kris06 is offline   Reply With Quote
Unread 04-13-2014, 08:08 AM   #14
94jeepman
Jager93
 
94jeepman's Avatar
2005 WK 
 
Join Date: Apr 2011
Location: rapid city, south dakota
Posts: 633
Quote:
Originally Posted by kris06 View Post
Does it get stuck on third gear ?
Yes
__________________
KHAKI MEMBER #59


The WK mods: SC flashpaq 3870, flow master super 40, 3.5" X Factor leveling kit, 33" M/T baja claws, 17" pro comp wheels, one 12 inch subwoofer, rugged ridge tailight gaurds, rola rack with 18" extension
94jeepman is offline   Reply With Quote
Unread 04-13-2014, 03:05 PM   #15
kris06
Registered User
2006 WK 
 
Join Date: Mar 2013
Posts: 34
Then its in a limp mode you will need to rebuild
kris06 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.