post #1 of Old 07-11-2010, 12:18 AM Thread Starter
jeffsb69
Registered User
 
Join Date: Jul 2010
Location: st.louis
Posts: 2
tranny goes into limp mode

have problem with 2005 grand cherokee,car shifted hard into 3 to 4th gear a couple times..then went into limp mode alowwing to travel in 1st gear only.engine light then comes on. codes are p0700 and p1731...i cant find any code description for a 1731.. is this a input /output sensor problem? car has shifted perfectly till this happened. Thanks..

jeffsb69 is offline  
post #2 of Old 07-11-2010, 06:53 AM
wrenchbendr
Registered User
2005 WK 
 
Join Date: Feb 2009
Location: walkerton in
Posts: 120
p1731= incorrect gear engaged
wrenchbendr is offline  
post #3 of Old 07-11-2010, 07:54 AM
robpp
Registered User
 
Join Date: Oct 2007
Location: Colorado
Posts: 1,267
is it a 3.7? lots of issues with the electonic shift module (whats under the shift handle) for the NAG1. and its like 600 for the part to replace it. some take it apart and try to clean the contacts.....some have success. the hemi and 4.7 dont seem to have nearly as many issues with this.

also look thru the TSBs at wkjeeps.com

but the manual says likely cause is: SO have you checked the fluid properly ????? is there a dipstick present?

LOW FLUID LEVEL
ABS DTCS PRESENT
TRANSMISSION SOLENOID, SPEED SENSOR AND/OR OTHER ELECTRICAL RELATED DTCS PRESENT
INTERMITTENT STICKING VALVE IN THE VALVE BODY
INTERNAL TRANSMISSION PROBLEM
TRANSMISSION CONTROL MODULE

Rob 007 Laredo 4.7 FFV 27X; DeBadg'd; Zaino'd; SRT8 Grill, Pedals, Strut; ClearBra; WeatherTech; LED Reverse; HIR Hi/Lo; SS Fog; Stealth Turns; 15% Tint; Stubbie; Rear Spoiler; Magnaflow; V1; 22Elite Console/Visors; Body Kit; Color Match Everything; TintedTails; K&N 63; Front Skid; QuickOilDrainValve; BatteryTender; SuperChips 91; Bilstein; Billet Window Switches; Greasable Addco Sways; RamMedic Hood; Fastman TB; BWoody Links; Kicker Upgrade w/Single Sub; AVIC F90BT Hacked; NeffyWrap ABCD; Putco LEDs; Viper 20s w/255/50; R1 Slot/Dimple w/Hawk Pro Ceramic; Whistler Mod w/FlashTech Halos
robpp is offline  
post #4 of Old 07-11-2010, 09:08 AM Thread Starter
jeffsb69
Registered User
 
Join Date: Jul 2010
Location: st.louis
Posts: 2
Yes it is a 3.7 There is a dipstick and fluid level is fine and as well as not looking foamy or dirty.Going to try the input sensors today since they seem to be a relative cheap.and accessible to change. Is it difficult to take apart shift handle?or should i leave this to a pro? thanks for the help
jeffsb69 is offline  
post #5 of Old 07-11-2010, 08:18 PM
WKBoston
Registered User
2006 WK 
 
Join Date: Apr 2010
Location: Massachusetts
Posts: 102
My 3.7 is doing the same thing. Bringing it in to be serviced at the dealership in two weeks, still under warranty. I am sure that since i touched the steering too many times the warranty is voided or something stupid.
WKBoston is offline  
post #6 of Old 07-11-2010, 09:26 PM
robpp
Registered User
 
Join Date: Oct 2007
Location: Colorado
Posts: 1,267
Quote:
Originally Posted by jeffsb69 View Post
Yes it is a 3.7 There is a dipstick and fluid level is fine and as well as not looking foamy or dirty.Going to try the input sensors today since they seem to be a relative cheap.and accessible to change. Is it difficult to take apart shift handle?or should i leave this to a pro? thanks for the help
theres a thread here if not send me a PM its on another forum and ill get you a link. its like big electrical contacts. you get contact cleaner. take them apart. clean contacts. put back together.

the reson people go thru the trouble is the the ESM for the Nag 1 can be up to like 600 to replace.

Rob 007 Laredo 4.7 FFV 27X; DeBadg'd; Zaino'd; SRT8 Grill, Pedals, Strut; ClearBra; WeatherTech; LED Reverse; HIR Hi/Lo; SS Fog; Stealth Turns; 15% Tint; Stubbie; Rear Spoiler; Magnaflow; V1; 22Elite Console/Visors; Body Kit; Color Match Everything; TintedTails; K&N 63; Front Skid; QuickOilDrainValve; BatteryTender; SuperChips 91; Bilstein; Billet Window Switches; Greasable Addco Sways; RamMedic Hood; Fastman TB; BWoody Links; Kicker Upgrade w/Single Sub; AVIC F90BT Hacked; NeffyWrap ABCD; Putco LEDs; Viper 20s w/255/50; R1 Slot/Dimple w/Hawk Pro Ceramic; Whistler Mod w/FlashTech Halos
robpp is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
00'WJ 45RFE tranny in limp mode JohnnyZJ ZJ Grand Cherokee Forum 5 10-21-2008 08:56 PM
94 zj limp mode cheapmf ZJ Grand Cherokee Forum 2 09-19-2008 03:06 PM
42re limp mode again jbigalow ZJ Grand Cherokee Forum 7 08-06-2007 10:14 AM
Limp mode MotoX5874 ZJ Grand Cherokee Forum 1 06-28-2007 12:31 PM
limp mode jbigalow ZJ Grand Cherokee Forum 3 01-15-2007 05:39 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome