post #1 of Old 01-29-2011, 06:40 AM Thread Starter
BurmaJack
Registered User
2008 WK 
 
Join Date: Dec 2010
Posts: 489
Traction Control, ESP, BAS Warning Lights?

I was driving home from work on the freeway at about 80mph/130kph when after about 20 minutes the traction control symbol, ESP, and BAS lights came on. When I arrived home, I switched to 4 Lo - no change, I tried shutting it off, then turned the key to "on" and while all of the other lights went out during the test, the above lights stayed on.

Does anybody have any idea what's going on? BTW it has been above freezing for the past few days, and overnight (I work night shift) the temperature dropped well below freezing.

Thanks


'08.5 WK Laredo CRD North Edition; QTII;
Modern Blue Pearl; GDE HOT Tune

Blue WK Club Member #2
BurmaJack is offline  
post #2 of Old 01-29-2011, 06:51 AM
TRZ
Registered User
2008 WK 
 
Join Date: May 2007
Location: Lakewood, CO
Posts: 536
Mine did this when I had a bad speed sensor. I used my Superchips tuner to read the error messages which told me which sensor was bad. If car parts stores in Canada provide OBDII reading services, you might try that route. The sensor was about $35 in the 'States and relatively easy to replace.
TRZ is offline  
post #3 of Old 01-29-2011, 06:52 AM
AJeepZJ
Registered User
2006 WK 
 
Join Date: Aug 2010
Location: Ft Bragg
Posts: 3,575
Bad wheel sensor, possibly.

All Gear, No Skill.
AJeepZJ is offline  
post #4 of Old 01-29-2011, 07:13 AM Thread Starter
BurmaJack
Registered User
2008 WK 
 
Join Date: Dec 2010
Posts: 489
Thanks guys, I will have it looked at. Sounds like a minor issue, now I can sleep, its been a long work night

'08.5 WK Laredo CRD North Edition; QTII;
Modern Blue Pearl; GDE HOT Tune

Blue WK Club Member #2
BurmaJack is offline  
post #5 of Old 01-30-2011, 07:33 AM Thread Starter
BurmaJack
Registered User
2008 WK 
 
Join Date: Dec 2010
Posts: 489
Well surprise surprise! I fired her up sat afternoon to head to work, and after about 10 minutes, while making a left turn, the lights disappeared! The JEEP ghosts were just paying a visit apparently

'08.5 WK Laredo CRD North Edition; QTII;
Modern Blue Pearl; GDE HOT Tune

Blue WK Club Member #2
BurmaJack is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
esp bas and traction control lights stanton3 WK Grand Cherokee & XK Commander Forum 1 12-10-2010 01:03 AM
ABS/Traction Control Warning Light Snoopy WK Grand Cherokee & XK Commander Forum 30 08-15-2010 02:56 AM
ESP ABS Traction Control Lights BonesWK WK Grand Cherokee & XK Commander Forum 5 04-06-2010 02:52 PM
Warning lights on, gauges at zero, windows, lights don't work... viperdriver ZJ Grand Cherokee Forum 0 09-09-2008 04:57 PM
ESP & Traction control jeepster2000 ZJ Grand Cherokee Forum 2 01-11-2008 10:15 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome