TCM P0750...codes and more codes and the one speed tranny - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > TCM P0750...codes and more codes and the one speed tranny

Warrior Products @ Oconee Off-Road! 706-534-9955Advance Adapters SYE KitsUCF Halloween Sale - 15% Off Until Midnight on Friday!

Reply
Unread 11-01-2008, 07:02 PM   #1
Mattt0305
Registered User
2005 WK 
 
Join Date: Mar 2006
Posts: 25
TCM P0750...codes and more codes and the one speed tranny

Well I posted a week ago and got some great replies but most wanted to know the in depth codes over the generic P0700. Ive just parked the thing and finally got it to a dealer to pull the real codes. It's locked in third which i assume is limp mode, so here it goes. P0750 P0841 P0870 P0935. I can look them up and most seem to deal with pressure but the one is solenoid A malfunction. Anyone ever change one of these solenoid packs? Is it as easy as it looks, pull the pan and remove the filter and valve body and its bolted to the VB. Is this actually the problem. Oh well, any advice is welcomed, Cheers all.

Mattt0305 is offline   Reply With Quote Quick reply to this message
Unread 11-01-2008, 07:19 PM   #2
robpp
Registered User
 
Join Date: Oct 2007
Location: Colorado
Posts: 1,239
You say you can look them up? Do you have the Service Manual? If not, I have the 005WK and can share the details. Let me know and I'll post up the manual pages for each code.

I am only reading and providing my opinion:
Since all of them are hydraulic fluid related, have you had the fluid level checked. Some models there is NO dipstick. And there is a process to check it based on the temperature of the fluid. I would get a power flush on the transmission. And maybe a pan filter too. My guess is either not enough fluid or contaminated fluid.

You dont list engine/transmission, that could help others with similar provide feedback too.

Good Luck,
Rob
__________________
Rob 007 Laredo 4.7 FFV 27X; DeBadg'd; Zaino'd; SRT8 Grill, Pedals, Strut; ClearBra; WeatherTech; LED Reverse; HIR Hi/Lo; SS Fog; Stealth Turns; 15% Tint; Stubbie; Rear Spoiler; Magnaflow; V1; 22Elite Console/Visors; Body Kit; Color Match Everything; TintedTails; K&N 63; Front Skid; QuickOilDrainValve; BatteryTender; SuperChips 91; Bilstein; Billet Window Switches; Greasable Addco Sways; RamMedic Hood; Fastman TB; BWoody Links; Kicker Upgrade w/Single Sub; AVIC F90BT Hacked; NeffyWrap ABCD; Putco LEDs; Viper 20s w/255/50; R1 Slot/Dimple w/Hawk Pro Ceramic; Whistler Mod w/FlashTech Halos
robpp is offline   Reply With Quote Quick reply to this message
Unread 11-01-2008, 07:37 PM   #3
Mattt0305
Registered User
2005 WK 
 
Join Date: Mar 2006
Posts: 25
Ah yes, sorry, its a 2005 GC(of course) 4x4, 4.7l with a 545rfe, the one with the dipstick. Fluid is fine, first thing I checked. I should give the whole history too. This happened once or twice a year ago and took it to a dealer and they said it was the pressure line sensor, they took it out cleaned it and it was fine till a week ago. But this is somewhat different. All i had to do before was turn the car off and start it back up and it was fine. Now.... It's just third gear all the time. I have a new sensor but I work for the railroad and havent had time to crawl under and replace it. The worry is that darn solenoid A malfunction one. Ahhh. I still love her though. Thanks Rob I'll take any help or advice.
Mattt0305 is offline   Reply With Quote Quick reply to this message
Unread 11-01-2008, 09:50 PM   #4
robpp
Registered User
 
Join Date: Oct 2007
Location: Colorado
Posts: 1,239
Yeah that sheds a bit more light.

I agree, change the sensor and see what happens.

Good Luck
__________________
Rob 007 Laredo 4.7 FFV 27X; DeBadg'd; Zaino'd; SRT8 Grill, Pedals, Strut; ClearBra; WeatherTech; LED Reverse; HIR Hi/Lo; SS Fog; Stealth Turns; 15% Tint; Stubbie; Rear Spoiler; Magnaflow; V1; 22Elite Console/Visors; Body Kit; Color Match Everything; TintedTails; K&N 63; Front Skid; QuickOilDrainValve; BatteryTender; SuperChips 91; Bilstein; Billet Window Switches; Greasable Addco Sways; RamMedic Hood; Fastman TB; BWoody Links; Kicker Upgrade w/Single Sub; AVIC F90BT Hacked; NeffyWrap ABCD; Putco LEDs; Viper 20s w/255/50; R1 Slot/Dimple w/Hawk Pro Ceramic; Whistler Mod w/FlashTech Halos
robpp is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.