Suspension Help! - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 11-03-2013, 04:39 PM Thread Starter
njudkins21
Registered User
 
Join Date: Oct 2012
Location: sterling heights
Posts: 16
Suspension Help!

Hey guys I just took my 05 Grand Cherokee in to get all new shocks and struts. I believe they used monroe reflex? Anyway, I've had it back in 4 times in the last week because I have a rattle coming out of the front driver side since they replaced them. They tore it back apart, replaced the ball joints, and strut mount and its still there. My question is this... When I have the front end in the air and I take my fist and strike the spring, should it have ANY play in it at all? It sounds loose, and the other side is not. Im not a suspension guy so any info would be appreciated!

njudkins21 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 11-03-2013, 04:44 PM
Kolak
Vendor
 
Kolak's Avatar
 
Join Date: Jun 2004
Location: Phoenix, AZ
Posts: 6,194
Did they replace the upper and lower spring isolators? They are often the culprit.

Kolak Performance and Offroad
Member: Specialty Equipment Market Association
Telephone: 480 998-3661
kolak@aol.com or kolak@kolakperformance.com
Kolak is online now  
post #3 of 6 Old 11-03-2013, 04:56 PM Thread Starter
njudkins21
Registered User
 
Join Date: Oct 2012
Location: sterling heights
Posts: 16
The top one is new the bottom one is not. I just went out there trying to isolate the noise and grabbed hold of the strut itself and can wiggle it a little bit... any ideas?
njudkins21 is offline  
post #4 of 6 Old 11-03-2013, 05:11 PM
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake
Posts: 857
My mechanic had to replace the new strut he installed. It was bad out of the box.. I believe it is the same manufacturer and part as yours...

Tom
tchristopher1@twc.com
2006 G.C.65th Anniv. Edition
2007 Liberty Sport 3.7
tom19511 is offline  
post #5 of 6 Old 11-03-2013, 05:13 PM
ttusqrl
Registered User
2005 WK 
 
Join Date: Oct 2007
Location: Dallas
Posts: 492
I have new isolaters in the box if you need them.

Sent from my iPhone using JeepForum

2005 WK 5.7 ORT | Mod SL (OME struts & 990s) | JBA UCAs & Discos | Saguaro Front Bumper | Warn Zeon 10s | 285/70/17 BFG TA KO | AIRAID CAI | Gibson 3" Exhaust | DiabloSport Intune | JL Stealthbox
ttusqrl is offline  
post #6 of 6 Old 11-03-2013, 05:29 PM Thread Starter
njudkins21
Registered User
 
Join Date: Oct 2012
Location: sterling heights
Posts: 16
Actually I forgot to mention that, they already replaced it with a new strut because the first one they put in was bad. Possibly another bad one?
njudkins21 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome