stuttering/clunking at speed under load. Help new baby coming Jeep is acting up! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > stuttering/clunking at speed under load. Help new baby coming Jeep is acting up!

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Clayton Off Road JK Short Arm Suspension Kits~Artec JK 1 TON SWAP~

Reply
Unread 08-09-2013, 02:27 PM   #1
Ruckus02
Registered User
 
Join Date: May 2010
Location: Canada
Posts: 46
stuttering/clunking at speed under load. Help new baby coming Jeep is acting up!

2006 WK 3.7 AWD. The jeep is acting really crazy at highway seed (~2000rpm). At first it was just under load, like going up hills. Then after a week its happening on level ground. It is like a series of mini-stalls in rapid succession. When I let off the gas its fine. The engine will not do it on its own with the jeep in P or N, or in the driveway at any rpm in D with brake on. No codes. Transmission was flushed at dealer 6 months ago. 150,000km 0r 90,000 miles. Just cleaned the TB and installed a new TPS. Had dealer check tranny, fluid is good. They got no codes either. Any help here would be appreciated. My wife is about to give birth to #2 and putting them both in a lifted TJ Rubicon is very difficult for her. Thank you!

Ruckus02 is offline   Reply With Quote
Unread 08-09-2013, 02:48 PM   #2
yzjwk
Registered User
2005 WK 
 
Join Date: Apr 2011
Location: Lac du Bonnet, manitoba, Can
Posts: 1,101
Quote:
Originally Posted by Ruckus02 View Post
2006 WK 3.7 AWD. The jeep is acting really crazy at highway seed (~2000rpm). At first it was just under load, like going up hills. Then after a week its happening on level ground. It is like a series of mini-stalls in rapid succession. When I let off the gas its fine. The engine will not do it on its own with the jeep in P or N, or in the driveway at any rpm in D with brake on. No codes. Transmission was flushed at dealer 6 months ago. 150,000km 0r 90,000 miles. Just cleaned the TB and installed a new TPS. Had dealer check tranny, fluid is good. They got no codes either. Any help here would be appreciated. My wife is about to give birth to #2 and putting them both in a lifted TJ Rubicon is very difficult for her. Thank you!
If there are no codes , the only stab in the dark i will take is that it's not the engine that's causing it . Sounds to me like the lock up torque converter (or possibly the final drive clutch ) is letting go and locking up again. . Also FWIW Chrysler does not recomend transmission flushing of any kind .
__________________
Proud owner : 05 WK Ltd 5.7 HEMI
90 YJ Islander 4.2 Cam'd & Decked
94 ZJ Ltd 5.2
00 WJ 4.0
yzjwk is offline   Reply With Quote
Unread 08-09-2013, 03:23 PM   #3
Ruckus02
Registered User
 
Join Date: May 2010
Location: Canada
Posts: 46
Thank you. They changed the fluid and filter. Perhaps I was incorrect when I said flush.
Ruckus02 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.