Stalling after cleaning injectors - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Stalling after cleaning injectors

PANDEMIC-USA 50" Double row LED LIGHT BAR!! These thiIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed LineGR8TOPS HD TJ Replacement Hinges

Reply
Unread 11-25-2014, 08:31 PM   #1
alberto68888
Registered User
2008 WK 
 
Join Date: Aug 2014
Location: Venezuela, Caracas
Posts: 34
Stalling after cleaning injectors

Few months ago i did a ultrasonic fuel injectors cleaning and days after that my wk (2008 4.7L) start to stall in traffic having no dtc codes and no CEL. It stall everytime now even while driving, took it to a lots of mechanics and still stalling, really got me crazy. Any ideas?

alberto68888 is offline   Reply With Quote Quick reply to this message
Unread 11-25-2014, 08:37 PM   #2
technologic80
Registered User
2005 WK 
 
Join Date: Nov 2014
Location: Metro Detroit, Michigan
Posts: 80
I thought I read that a bad EGR valve can cause stalling.
technologic80 is offline   Reply With Quote Quick reply to this message
Unread 12-15-2014, 03:31 PM   #3
alberto68888
Registered User
2008 WK 
 
Join Date: Aug 2014
Location: Venezuela, Caracas
Posts: 34
I havent changed the EGR, but replaced the crankshaft, camshaft sensor, pcv valve and spark plugs. Also tested the fuel pressure and its 60 psi. Its stall about 5 times in a day and no codes. All start after the injector cleaning, a bad injector should throw a code? Also when stall all the electronic system works, the engine just shut off and start again shifting neutral.
alberto68888 is offline   Reply With Quote Quick reply to this message
Unread 01-23-2015, 02:39 PM   #4
alberto68888
Registered User
2008 WK 
 
Join Date: Aug 2014
Location: Venezuela, Caracas
Posts: 34
So did another injector clean and stall gone about 3 days and back again. When stall it will crank 2-3 times and start again. Could be the fuel pump failing?
alberto68888 is offline   Reply With Quote Quick reply to this message
Unread 01-23-2015, 04:45 PM   #5
Hendrix9
Registered User
2007 WK 
 
Join Date: Feb 2012
Location: Watertown, Connecticut
Posts: 362
Question- what made you think to do the initial injector cleaning? Was it acting weird? Just curious.
__________________
2007 CRD QDII- ROR springs on 265/70/17s
2010 Jetta Sportwagen TDI 6MT - Stock for now...
Hendrix9 is offline   Reply With Quote Quick reply to this message
Unread 01-24-2015, 07:02 AM   #6
alberto68888
Registered User
2008 WK 
 
Join Date: Aug 2014
Location: Venezuela, Caracas
Posts: 34
Well ive heard that many people complaints about the gas sold here, they say that its too dirty and the fuel filter and injectors gets clogs. I didnt find any fuel filter replacement and i think that if there is a bad injector, at least i will get a dtc. So im wondering if could be the fuel pump causing the stall.
alberto68888 is offline   Reply With Quote Quick reply to this message
Unread 01-24-2015, 07:56 AM   #7
RCS1300
Registered User
2005 WK 
 
Join Date: May 2014
Location: Stamford, Connecticut
Posts: 446
Check your fuel pressure at the fuel rail. It should be about 55 psi or higher. If the fuel pressure is lower, you may have a clogged fuel filter or weak fuel pump. Unfortunately, I believe the fuel filter is within the fuel pump assembly so you change them out as a unit.
RCS1300 is offline   Reply With Quote Quick reply to this message
Unread 01-24-2015, 08:16 AM   #8
alberto68888
Registered User
2008 WK 
 
Join Date: Aug 2014
Location: Venezuela, Caracas
Posts: 34
Quote:
Originally Posted by RCS1300 View Post
Check your fuel pressure at the fuel rail. It should be about 55 psi or higher. If the fuel pressure is lower, you may have a clogged fuel filter or weak fuel pump. Unfortunately, I believe the fuel filter is within the fuel pump assembly so you change them out as a unit.
I did check fuel pressure and got 60psi but the WK is now with 56k so i dont know if its time to change the fuel pump.
alberto68888 is offline   Reply With Quote Quick reply to this message
Unread 01-24-2015, 09:19 AM   #9
RCS1300
Registered User
2005 WK 
 
Join Date: May 2014
Location: Stamford, Connecticut
Posts: 446
Quote:
Originally Posted by alberto68888 View Post
I did check fuel pressure and got 60psi but the WK is now with 56k so i dont know if its time to change the fuel pump.
If you have 60 psi the fuel pump and fuel filter are fine. Do not change them. Something else is causing the problem.

Have the spark plugs been in the Jeep more than 30,000 miles?
RCS1300 is offline   Reply With Quote Quick reply to this message
Unread 01-24-2015, 10:19 AM   #10
alberto68888
Registered User
2008 WK 
 
Join Date: Aug 2014
Location: Venezuela, Caracas
Posts: 34
Quote:
Originally Posted by RCS1300 View Post
If you have 60 psi the fuel pump and fuel filter are fine. Do not change them. Something else is causing the problem.

Have the spark plugs been in the Jeep more than 30,000 miles?
Only 10k miles. But when it stall the radio, a/c, headlights still on so i dont think about an electrical issue. Trans fluid is on top, crank/cam sensor replaced, pcv valve replaced too.
alberto68888 is offline   Reply With Quote Quick reply to this message
Unread 01-24-2015, 10:33 AM   #11
RCS1300
Registered User
2005 WK 
 
Join Date: May 2014
Location: Stamford, Connecticut
Posts: 446
Spark plugs are fine at 10,000 miles. No need to change them.

One other item to test is the Idle Air Control valve. The purpose of this valve is to let air into the engine when the air intake is closed during idle. If it is dirty or not working it could cause the engine to stall.

I would first clean it as it could be dirty with carbon buildup. Do not replace it because it is expensive at $80.

But first, check your air filter and make sure it is clean. This could be the issue.
RCS1300 is offline   Reply With Quote Quick reply to this message
Unread 01-24-2015, 10:42 AM   #12
alberto68888
Registered User
2008 WK 
 
Join Date: Aug 2014
Location: Venezuela, Caracas
Posts: 34
Do the 4.7 have IAC Valve? Well the air filter its ok too, replaced every oil change. TB cleaned 2 months ago. The thing is it isnt stall only at idle, it stalled once at 50mph, but not always at idle
alberto68888 is offline   Reply With Quote Quick reply to this message
Unread 01-24-2015, 12:12 PM   #13
Greever
Registered User
2008 WK 
 
Join Date: Oct 2014
Location: yonkers, New York
Posts: 211
Do you have the wired throttle body? or the electronic one? I also have a 2008 4.7 and mine is electronic and Ive been told not to clean it with regular TB cleaner as it can damage the electronic's in it. Also I dont think the electronic TB has an IAC valve.
Greever is offline   Reply With Quote Quick reply to this message
Unread 01-24-2015, 12:17 PM   #14
alberto68888
Registered User
2008 WK 
 
Join Date: Aug 2014
Location: Venezuela, Caracas
Posts: 34
Quote:
Originally Posted by Greever View Post
Do you have the wired throttle body? or the electronic one? I also have a 2008 4.7 and mine is electronic and Ive been told not to clean it with regular TB cleaner as it can damage the electronic's in it. Also I dont think the electronic TB has an IAC valve.
I have the electronic one and only cleaned up twice. I want to be sure that its something bad before doing anything, fuel pump isnt cheap about 200$. But the guy who tested fuel pressure said that should replace the pump.
alberto68888 is offline   Reply With Quote Quick reply to this message
Unread 01-24-2015, 12:28 PM   #15
Greever
Registered User
2008 WK 
 
Join Date: Oct 2014
Location: yonkers, New York
Posts: 211
i dont see why he would want to change the pump if the current one is operating at spec.
Greever is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.