Squeal at start-up GC2005 v6 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Squeal at start-up GC2005 v6

Rough Country Lift Kits and Parts!1999-2004 Jeep Grand Cherokee Limited Headlight Pair1997 - 2001 Jeep Cherokee Header Panel

Reply
Unread 03-22-2014, 10:04 AM   #1
Mimmo
Registered User
2005 WK 
 
Join Date: Jul 2010
Location: New York
Posts: 8
Squeal at start-up GC2005 v6

This winter i started getting an intermittent squealing sound at start up. It can last several seconds or max several minutes. Eventually it goes away. I thought it was just due to the extreme cold we had in northeast buts its persisted. I changed the serpentine belt and both tensioner pulleys just to be safe. Noise is still there. Iíve cycled the compressor on/off no difference. Water pump is not leaking and its hard to tell where the sound is coming from. It sounds just like a squealing belt but thereís no belt adjustment on the 2005 models, unless Iím missing something. Anyone run into this?

Mimmo is offline   Reply With Quote
Unread 03-22-2014, 11:09 AM   #2
JeepN4KC
Keep on Jeepin on........
 
JeepN4KC's Avatar
 
Join Date: Jul 2011
Location: Blue Springs, MO
Posts: 5,091
I would suspect the water pump or alternator based on what you describe and what's been changed.

Both of those have bearings that can go out and when they do they can make a squealing noise.
__________________
~Mike~

My Build Thread WK
My Other Build Thread XJ
'01 XJ with some stuff
Sept 2013 Cherokee of the Month
'07 WK with some other stuff
~RED WK CLUB #7~
'11 KK with mostly stock stuff
'06WK our first Jeep with stock stuff - totalled and gone
JeepN4KC is offline   Reply With Quote
Unread 03-22-2014, 11:11 AM   #3
jeepin_in_a_wk
Registered User
2007 WK 
 
Join Date: Feb 2014
Location: colorado springs, colorado
Posts: 14
put some soap on the belt and see if that solves it. thats the first thing i do when that happens, if it keeps up then look into your pulleys
jeepin_in_a_wk is offline   Reply With Quote
Unread 03-22-2014, 11:48 AM   #4
Mimmo
Registered User
2005 WK 
 
Join Date: Jul 2010
Location: New York
Posts: 8
Thanks for the feedback. I'll check these and report back.
Mimmo is offline   Reply With Quote
Unread 03-22-2014, 05:01 PM   #5
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake, OH
Posts: 251
If your tensioner is frozen, the the belt may squeal. Or the tensioner pulleys may be dry..
__________________
Tom19511
tchristopher1@wowway.com
2006 Grand Cherokee Laredo 3.7
2007 Liberty Sport 3.7
tom19511 is online now   Reply With Quote
Unread 03-22-2014, 10:52 PM   #6
yzjwk
Registered User
2005 WK 
 
Join Date: Apr 2011
Location: Lac du Bonnet, manitoba, Can
Posts: 1,063
Quote:
Originally Posted by Mimmo View Post
This winter i started getting an intermittent squealing sound at start up. It can last several seconds or max several minutes. Eventually it goes away. I thought it was just due to the extreme cold we had in northeast buts its persisted. I changed the serpentine belt and both tensioner pulleys just to be safe. Noise is still there. Iíve cycled the compressor on/off no difference. Water pump is not leaking and its hard to tell where the sound is coming from. It sounds just like a squealing belt but thereís no belt adjustment on the 2005 models, unless Iím missing something. Anyone run into this?
My money would be on the power steering pump . Have you checked the fluid ? They have a tendancy to leak in the cold .
__________________
Proud owner : 05 WK Ltd 5.7 HEMI
90 YJ Islander 4.2 Cam'd & Decked
94 ZJ Ltd 5.2
00 WJ 4.0
yzjwk is offline   Reply With Quote
Unread 03-23-2014, 09:23 AM   #7
JKM
Registered User
2005 WK 
 
Join Date: Dec 2008
Location: Toronto, Ontario
Posts: 394
I had the same issue with my 2005 3.7L V6. Squeal when starting only when extremely cold and would go away in 2-3mins. Recently replaced serpentine belt and tension puller. Was thinking maybe tensioner, but haven't gotten around to replacing it since it doesn't squeak anymore since it warmed up a little
JKM is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.