The squeaking is killing me - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > The squeaking is killing me

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineGrizzly Lockers available at Rockridge4wd.comThe ULTIMATE "Selectable" Locker System! Brough

Reply
Unread 10-18-2013, 09:30 AM   #1
fafafofi
Member
 
fafafofi's Avatar
2006 WK 
 
Join Date: Jun 2008
Location: Glenwood Springs, CO
Posts: 213
The squeaking is killing me

Installed the lift and drove for a few hundred miles. Now there is a squeaking coming from the strut/spring assembly. Everything is torqued but when you shake it, it squeaks on both sides. It all seems to be seated properly. Help I'm going insane

fafafofi is offline   Reply With Quote Quick reply to this message
Unread 10-18-2013, 09:32 AM   #2
Jeepforthewin
Lucky Charms!
 
Jeepforthewin's Avatar
2005 WK 
 
Join Date: Jan 2013
Location: Jacksonville, Fl
Posts: 2,075
Quote:
Originally Posted by fafafofi
Installed the lift and drove for a few hundred miles. Now there is a squeaking coming from the strut/spring assembly. Everything is torqued but when you shake it, it squeaks on both sides. It all seems to be seated properly. Help I'm going insane
Which lift?
__________________
2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline   Reply With Quote Quick reply to this message
Unread 10-18-2013, 09:51 AM   #3
fafafofi
Member
 
fafafofi's Avatar
2006 WK 
 
Join Date: Jun 2008
Location: Glenwood Springs, CO
Posts: 213
OME with bilsteins
fafafofi is offline   Reply With Quote Quick reply to this message
Unread 10-18-2013, 09:57 AM   #4
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore, Md.
Posts: 3,936
somethings not torqued or seated properly... flex it out to seat everything and then see how it is. lol
__________________
2007.5 WK Laredo 4.7
OEM+
paroxysym is offline   Reply With Quote Quick reply to this message
Unread 10-18-2013, 01:16 PM   #5
Unsp0kn
Registered User
2008 JK Wrangler 
 
Join Date: Aug 2013
Location: McCall, ID
Posts: 33
Check the swaybar link ends. They were loose when I bought our Commander and it sounded horrible. Torqued them down, no more noise.
__________________
2008 Wrangler Unlimited X -3.8L V6 - 6spd - Spyder Rock Bumpers - K&N CAI - 285/70 BFG KM2s - BlackRock D Series 17" - Rigid Industries A-pillar Duallys
2007 Commander Overland - 5.7L HEMI - QDII - 4" SuperLift - 285/70 BFG KM2s - Pro Comp Series 5001 17" - PIAA Fogs
Unsp0kn is offline   Reply With Quote Quick reply to this message
Unread 02-01-2014, 09:39 AM   #6
fafafofi
Member
 
fafafofi's Avatar
2006 WK 
 
Join Date: Jun 2008
Location: Glenwood Springs, CO
Posts: 213
Still squeaking on both sides! I've unloaded some silicone spray around the springs and such but still not gone. Anyone else have an issue with this setup or have suggestions? Every bump adds a little more insanity to my drive
fafafofi is offline   Reply With Quote Quick reply to this message
Unread 02-01-2014, 11:01 AM   #7
overland-wk
Registered User
2006 WK 
 
Join Date: Apr 2013
Location: Joliet, il
Posts: 213
When you installed the lift did you happen to remove the upper control arms? If so check to see if the upper control arm bolts are tight this can also cause squeaking it happend to me.
__________________
06 ROR lifted wk (mine)
07 RC lifted xk (wife's)
Youtube channel
Bumsmodified98xj
overland-wk is offline   Reply With Quote Quick reply to this message
Unread 02-01-2014, 11:10 AM   #8
fafafofi
Member
 
fafafofi's Avatar
2006 WK 
 
Join Date: Jun 2008
Location: Glenwood Springs, CO
Posts: 213
Cool thanks. Probably the only bolts I forgot to recheck.
fafafofi is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.