Service four wheel system - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Service four wheel system

Rough Country Lift Kits and Parts!Clayton Off Road WJ Long Arm Kits!Baseline 4x4 Lifetime Warranty 4340 Chromoly Axle Shaft Ki

Reply
Unread 01-05-2007, 06:24 AM   #1
reynolds
Registered User
 
Join Date: Dec 2005
Posts: 9
Service four wheel system

MY son just called me , He is on the whay to work when a light came on service four wheel system Today In philly iy is now 58 and sunny so there is no snow
so
what is this light telling me and what is the problem

reynolds is offline   Reply With Quote
Unread 01-05-2007, 06:41 AM   #2
PeteC
Registered User
2000 TJ Wrangler 
 
Join Date: Jan 2004
Location: Oak Park, Michigan
Posts: 851
This may sound like too simple of an answer, but here goes.

There has been some kind of fault in the Four Wheel Dirve system. You need to take it to a dealer so they can run diagnostics and find out exactly what the fault is.

Best I can do for you.
__________________
'00 TJ With toys, lift and tires.
'10 Dodge Ram 1500 Quad 4x4. Daily driver and tow rig
'05 Dodge Neon. Wifes daily driver and gas sipper.
There is no Bandaid for Stupidity
Sorry if my support of legal wheeling offends you
PeteC is offline   Reply With Quote
Unread 01-05-2007, 08:01 AM   #3
KingPrat
Registered User
2001 WJ 
 
Join Date: Jan 2006
Location: Saugerties, NY
Posts: 1,305
http://www.wkjeeps.com/tsb/tsb_wk_2101406a.pdf

Have your son bring that to the dealer when he goes. That gives the flash software and procedure. It's better to have it with you than to trust the dealer to "find" the certain TSB.
__________________
New: Steel Blue 2001 Laredo 4.7, QD, Exhaust

Nokian Vatiiva tires: 235/65-17

Previous:1997 ZJ TSi 4.0. Some stuff added


Western New England College '08
Golden Bear Lacrosse #13
Week 11 USILA Rank: #15
2008: 16-5
NCAA Elite 8
TCCC Champions



Please read and share!!
KingPrat is offline   Reply With Quote
Unread 01-05-2007, 02:16 PM   #4
OnlyInARealJeep
Registered User
 
OnlyInARealJeep's Avatar
 
Join Date: May 2006
Location: Abingdon, Virginia
Posts: 239
I had this same problem with my WK.
It came on once and then I started my WK again and it went away.
Its just a glitch like everyone else is saying.
You don't need to go to the dealer about it unless you want to get the glitch fixed so it won't happen again.
__________________
Current: 2006 Midnight Blue Jeep Grand Cherokee WK Limited 4.7L V8

Modifications: Magnaflow Exhaust System, K&N 63 Series Intake System, JET Chip Stage Two, Addco Anti-Sway Bars, 4xGuard Front Guard II, 4xGuard Side Steps With Rock Rails, 4xGuard Rear Guard HC, Mopar Front Suspension Skid Plate, Door Entry Guards, Mopar Tail Light Guards, SRT-8 Sports Pedals, Commander Shifter Knob, Two 10" JL Audio W6v2 Subwoofers, JL Audio 500/1 Amp, And Thule Sport Utility Bars With Six Skis or Four Snowboards Clamps And Fairing.

Up Next: Front Window Tint and 4xGuard Belly Guard HC
OnlyInARealJeep is offline   Reply With Quote
Unread 01-05-2007, 02:17 PM   #5
BlackRubi04
Member
2004 TJ Wrangler 
 
Join Date: Oct 2005
Location: Chicago Burbs
Posts: 259
Quote:
Originally Posted by reynolds
MY son just called me , He is on the whay to work when a light came on service four wheel system Today In philly iy is now 58 and sunny so there is no snow
so
what is this light telling me and what is the problem

Mine does it all the time. Last time I was at the dealership I mentioned it and the guy told me it was a 'common problem.' They didn't have time to take a look at it but informed me not to worry about it. That was 2k miles ago, no problems yet.

kd
__________________
'04 TJ Rubicon
BlackRubi04 is offline   Reply With Quote
Unread 01-05-2007, 02:30 PM   #6
OnlyInARealJeep
Registered User
 
OnlyInARealJeep's Avatar
 
Join Date: May 2006
Location: Abingdon, Virginia
Posts: 239
Quote:
Originally Posted by BlackRubi04
Mine does it all the time. Last time I was at the dealership I mentioned it and the guy told me it was a 'common problem.' They didn't have time to take a look at it but informed me not to worry about it. That was 2k miles ago, no problems yet.

kd
Yeah I've been driving on mine for about 4k miles now and still no problems.
__________________
Current: 2006 Midnight Blue Jeep Grand Cherokee WK Limited 4.7L V8

Modifications: Magnaflow Exhaust System, K&N 63 Series Intake System, JET Chip Stage Two, Addco Anti-Sway Bars, 4xGuard Front Guard II, 4xGuard Side Steps With Rock Rails, 4xGuard Rear Guard HC, Mopar Front Suspension Skid Plate, Door Entry Guards, Mopar Tail Light Guards, SRT-8 Sports Pedals, Commander Shifter Knob, Two 10" JL Audio W6v2 Subwoofers, JL Audio 500/1 Amp, And Thule Sport Utility Bars With Six Skis or Four Snowboards Clamps And Fairing.

Up Next: Front Window Tint and 4xGuard Belly Guard HC
OnlyInARealJeep is offline   Reply With Quote
Unread 01-05-2007, 03:31 PM   #7
drewman141
Gas Guzzler
 
drewman141's Avatar
1994 ZJ 
 
Join Date: Apr 2005
Location: Somers, NY
Posts: 975
30K and I get the message maybe once every few thousand miles but no issues. It's definately some kind of glitch.
__________________
[SIZE="1"]2008 WK Overland HEMI - Modern Blue Pearlcoat
Fully loaded with slush mats of course.

MUST GO! 1994 Limited ZJ 5.2L V8 - Light Driftwood Satin Glow
It's a 94 5.2L Limited - trxus 33's on 15x7 steelies, 4.56s w/ front OX and rear trutrac, NP242 swap, novak shift kit, Kevin's ultimate 4.5" lift + ACOS, ARB front bumper w/warn M8000, rear tomkin machine bumper w/ tire carrier, kevin's hardore railz, kevin's ultimate tc skid, kevin's trackbar conversion, rusty's gas skid, flexalite efan, Kolak's performance ignition and brake upgrades. ViAir OBA, custom storage/sub box and I'm sure there's a bunch of other things I'm missing. Everything is a little over 3 years old with less than 10K miles. Looking to get around $4k.



drewman141 is offline   Reply With Quote
Unread 01-09-2007, 05:33 PM   #8
OnlyInARealJeep
Registered User
 
OnlyInARealJeep's Avatar
 
Join Date: May 2006
Location: Abingdon, Virginia
Posts: 239
Quote:
Originally Posted by drewman141
30K and I get the message maybe once every few thousand miles but no issues. It's definately some kind of glitch.
Yeah same here it comes up at exactly 2,000 miles everytime.
__________________
Current: 2006 Midnight Blue Jeep Grand Cherokee WK Limited 4.7L V8

Modifications: Magnaflow Exhaust System, K&N 63 Series Intake System, JET Chip Stage Two, Addco Anti-Sway Bars, 4xGuard Front Guard II, 4xGuard Side Steps With Rock Rails, 4xGuard Rear Guard HC, Mopar Front Suspension Skid Plate, Door Entry Guards, Mopar Tail Light Guards, SRT-8 Sports Pedals, Commander Shifter Knob, Two 10" JL Audio W6v2 Subwoofers, JL Audio 500/1 Amp, And Thule Sport Utility Bars With Six Skis or Four Snowboards Clamps And Fairing.

Up Next: Front Window Tint and 4xGuard Belly Guard HC
OnlyInARealJeep is offline   Reply With Quote
Unread 01-10-2007, 05:52 AM   #9
howelljeep
Registered User
1979 CJ5 
 
Join Date: Jun 2006
Location: Howell, MI
Posts: 189
It comes up every 2000 miles even after the dealer installed new software?
__________________
1982 CJ8
1986 CJ7
1979 CJ5 258 I6 3 speed
1999 Dodge Durango
howelljeep is offline   Reply With Quote
Unread 01-10-2007, 06:49 AM   #10
PeteC
Registered User
2000 TJ Wrangler 
 
Join Date: Jan 2004
Location: Oak Park, Michigan
Posts: 851
A "glitch" is still a "fault" and should be remedied.

My issue is that if I am used to seeing a warning light and I ignore it, then when something does go wrong and I still ignore it I might be asking for trouble. Get a warning light and ignore it for say 2000 miles and the dealer and DCX may have a case not to warrenty the problem since you did not take "due care".

Anyway, I want my vehicle to operate correctly in all facets. Until I take it off road and beat on it beyond recognition........oh wait, that's my TJ.
__________________
'00 TJ With toys, lift and tires.
'10 Dodge Ram 1500 Quad 4x4. Daily driver and tow rig
'05 Dodge Neon. Wifes daily driver and gas sipper.
There is no Bandaid for Stupidity
Sorry if my support of legal wheeling offends you
PeteC is offline   Reply With Quote
Unread 01-31-2007, 03:46 PM   #11
crazyed71
Registered User
 
Join Date: Feb 2006
Posts: 2
Took a trip to the austrian alps, the drive home was 800 miles on the autostrada(italian freeway=No speed limit as long as you dodge the speed cameras..) Anyway my glitch was comming on every 20 min... I stoped at a service station, RESET the service interval for oil and what not.... never had a glitch again....
crazyed71 is offline   Reply With Quote
Unread 01-31-2007, 04:29 PM   #12
OnlyInARealJeep
Registered User
 
OnlyInARealJeep's Avatar
 
Join Date: May 2006
Location: Abingdon, Virginia
Posts: 239
Bottom line, it's not a big deal if its saying Servive 4WD System. It is just a glitch in the computer and turns off after you start your WK again.
__________________
Current: 2006 Midnight Blue Jeep Grand Cherokee WK Limited 4.7L V8

Modifications: Magnaflow Exhaust System, K&N 63 Series Intake System, JET Chip Stage Two, Addco Anti-Sway Bars, 4xGuard Front Guard II, 4xGuard Side Steps With Rock Rails, 4xGuard Rear Guard HC, Mopar Front Suspension Skid Plate, Door Entry Guards, Mopar Tail Light Guards, SRT-8 Sports Pedals, Commander Shifter Knob, Two 10" JL Audio W6v2 Subwoofers, JL Audio 500/1 Amp, And Thule Sport Utility Bars With Six Skis or Four Snowboards Clamps And Fairing.

Up Next: Front Window Tint and 4xGuard Belly Guard HC
OnlyInARealJeep is offline   Reply With Quote
Unread 02-02-2007, 07:54 AM   #13
Francos_Cmdr
Registered User
 
Join Date: Jan 2007
Location: Springfield Va
Posts: 9
Chime in

Guess I'll chime in... I've had my Commander for better than a year now, and what's curious is the very first one I took for a test drive had this error message come up while I was returning to the dealer... He said it was due to not being properly serviced, bonehead didn't know squat.. Anyway I've had the message come up from time to time and can't link it to a specific mileage. As others have said, resetting service miles seems to clear it out.

I would really like to get a reading from Jeep and know it is a software bug or sensitivity issue that causes the error to come on, and a fix is on the way.

I'm curious if the bogus error message is limited to 2006 models, or are the 2007's still seeing it?

KKKKFL
Francos_Cmdr is offline   Reply With Quote
Unread 02-02-2007, 09:46 AM   #14
wysiwyg
Registered User
 
Join Date: Dec 2006
Location: MN
Posts: 12
My 2006 Commander does this also, they replaced a sensor in the rear differential that could get a small amount of metal shaving on it and triggers the warning light.
wysiwyg is offline   Reply With Quote
Unread 02-02-2007, 09:40 PM   #15
JerseyGeorge
Registered User
 
Join Date: Jul 2006
Location: New Jersey
Posts: 80
Quote:
Originally Posted by PeteC
A "glitch" is still a "fault" and should be remedied.

My issue is that if I am used to seeing a warning light and I ignore it, then when something does go wrong and I still ignore it I might be asking for trouble. Get a warning light and ignore it for say 2000 miles and the dealer and DCX may have a case not to warrenty the problem since you did not take "due care".

Anyway, I want my vehicle to operate correctly in all facets. Until I take it off road and beat on it beyond recognition........oh wait, that's my TJ.
I would agree with your point, BUT this is a well documented problem and DCX would be very stupid to ignore your warranty!
JerseyGeorge is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.