Service Electric Brake System - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Service Electric Brake System

USA Standard Chromoly Front Axle Shaft Kits with Dana 30 4Warrior Products @ Oconee Off-Road! 706-534-9955Advance Adapters SYE Kits

Reply
Unread 09-09-2013, 08:19 AM   #1
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 410
Service Electric Brake System

Was making a left turn to drop my wife off and heard a grinding noise as I was pulling out on the highway. I had the recall done and service 4wd system problems fixed. Just the other day it popped back up. Now the grinding noise and service electric brake system message and abs light and traction control light are on. Anyone else have these problems?

jjarvis0007 is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 09:53 AM   #2
Jeepforthewin
Lucky Charms!
 
Jeepforthewin's Avatar
2005 WK 
 
Join Date: Jan 2013
Location: Jacksonville, Fl
Posts: 2,075
Sounds like a Speed wheel sensor. When one of mine went out it would throw the ABS and Traction control light aswel as "Service 4WD system" and "Service Electric Brake System". Next time it throws the lights and codes do the key dance. I replaced my left rear speed sensor awhile ago and am having same problem again so I did key dance and it pulled U1418 which is for the rear right hand side sensor.
__________________
2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 10:07 AM   #3
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 410
Quote:
Originally Posted by Jeepforthewin View Post
Sounds like a Speed wheel sensor. When one of mine went out it would throw the ABS and Traction control light aswel as "Service 4WD system" and "Service Electric Brake System". Next time it throws the lights and codes do the key dance. I replaced my left rear speed sensor awhile ago and am having same problem again so I did key dance and it pulled U1418 which is for the rear right hand side sensor.
No DTC codes shown
jjarvis0007 is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 10:27 AM   #4
R32R1
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: South County, RI
Posts: 209
Yea that's a speed sensor. Replace them all just to be sure
R32R1 is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 10:50 AM   #5
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 410
Why would I hear a grinding noise when turning left? I got the recall done for FDCM and they had messed up at first and the Service 4wd System message popped back up the other day. Then today it made a grinding noise and the ABS light and traction control just popped up?

Where can I find these speed sensors?
jjarvis0007 is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 11:11 AM   #6
Jeepforthewin
Lucky Charms!
 
Jeepforthewin's Avatar
2005 WK 
 
Join Date: Jan 2013
Location: Jacksonville, Fl
Posts: 2,075
They are located in the wheel hub. And mine grinded too when it would short out due to the ABS and Trac light coming on.
__________________
2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 11:34 AM   #7
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 410
Just the two front wheels on a 2005 JGC Limited 4.7?

Looks like O'Reillys has two of them but they say their for the rear tires? I only see what could be a sensor on both front wheel?
jjarvis0007 is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 11:54 AM   #8
Jeepforthewin
Lucky Charms!
 
Jeepforthewin's Avatar
2005 WK 
 
Join Date: Jan 2013
Location: Jacksonville, Fl
Posts: 2,075
Im not sure on the 4.7 but on my 5.7 we have wires that lead into the rear hub assemblies which these wires are for the Speed wheel sensor.
__________________
2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 12:04 PM   #9
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 410
Quote:
Originally Posted by Jeepforthewin View Post
Im not sure on the 4.7 but on my 5.7 we have wires that lead into the rear hub assemblies which these wires are for the Speed wheel sensor.
Disconnected the battery for a few minutes. Just left to run some errands and now there is no message. Thanks for all yalls help.
jjarvis0007 is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 12:52 PM   #10
Jeepforthewin
Lucky Charms!
 
Jeepforthewin's Avatar
2005 WK 
 
Join Date: Jan 2013
Location: Jacksonville, Fl
Posts: 2,075
Quote:
Originally Posted by jjarvis0007

Disconnected the battery for a few minutes. Just left to run some errands and now there is no message. Thanks for all yalls help.
Be careful with that. If it is a Speed wheel sensor it will come back. I almost got tboned cause my Jeep locked up halfway through a legal U-turn and I couldn't move then it finally released but I was almost hit cause of it. Just a heads up
__________________
2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 01:10 PM   #11
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 410
Quote:
Originally Posted by Jeepforthewin View Post

Be careful with that. If it is a Speed wheel sensor it will come back. I almost got tboned cause my Jeep locked up halfway through a legal U-turn and I couldn't move then it finally released but I was almost hit cause of it. Just a heads up
It just came back. It didnt lock up but the lights came back on.
jjarvis0007 is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 02:18 PM   #12
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 410
Nevermind. Was turning into a 4 way intersection and it locked up as I was trying to go uphill. O'Reillys shows to have all 4 actually. 2 rears and 2 fronts. With the fronts being more expensive. I can't see anything on the rear though? I can see them on the front.
jjarvis0007 is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 02:29 PM   #13
Jeepforthewin
Lucky Charms!
 
Jeepforthewin's Avatar
2005 WK 
 
Join Date: Jan 2013
Location: Jacksonville, Fl
Posts: 2,075
Still no codes being thrown after the key dance? If the key dance isn't showing a DTC report at all auto zone can scan it for you.
__________________
2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 02:44 PM   #14
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 410
No codes at all. Pulls up with dashes then says DTC Done. ABS light is on and ESP disabled light is on. Kind of scary. Didnt make it early this morning to the dealership for fixing the service 4wd system message. Went in earlier and he said to come back in the morning.
Hoping they can take care of the 4wd problem AGAIN and try to tell me which sensor it could be.
Is there a relay or fuse I can pull to stop it from throwing on the brakes while driving?
jjarvis0007 is offline   Reply With Quote Quick reply to this message
Unread 09-09-2013, 04:13 PM   #15
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 410
Just went to pick my wife up from work and now the darn thing is stumbling and dropping rpms to about 250-300.
jjarvis0007 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.