JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   WK Grand Cherokee & XK Commander Forum (http://www.jeepforum.com/forum/f67/)
-   -   Service Electric Brake System (http://www.jeepforum.com/forum/f67/service-electric-brake-system-1573335/)

jjarvis0007 09-09-2013 09:19 AM

Service Electric Brake System
 
Was making a left turn to drop my wife off and heard a grinding noise as I was pulling out on the highway. I had the recall done and service 4wd system problems fixed. Just the other day it popped back up. Now the grinding noise and service electric brake system message and abs light and traction control light are on. Anyone else have these problems?

Jeepforthewin 09-09-2013 10:53 AM

Sounds like a Speed wheel sensor. When one of mine went out it would throw the ABS and Traction control light aswel as "Service 4WD system" and "Service Electric Brake System". Next time it throws the lights and codes do the key dance. I replaced my left rear speed sensor awhile ago and am having same problem again so I did key dance and it pulled U1418 which is for the rear right hand side sensor.

jjarvis0007 09-09-2013 11:07 AM

Quote:

Originally Posted by Jeepforthewin (Post 15888634)
Sounds like a Speed wheel sensor. When one of mine went out it would throw the ABS and Traction control light aswel as "Service 4WD system" and "Service Electric Brake System". Next time it throws the lights and codes do the key dance. I replaced my left rear speed sensor awhile ago and am having same problem again so I did key dance and it pulled U1418 which is for the rear right hand side sensor.

No DTC codes shown

R32R1 09-09-2013 11:27 AM

Yea that's a speed sensor. Replace them all just to be sure

jjarvis0007 09-09-2013 11:50 AM

Why would I hear a grinding noise when turning left? I got the recall done for FDCM and they had messed up at first and the Service 4wd System message popped back up the other day. Then today it made a grinding noise and the ABS light and traction control just popped up?

Where can I find these speed sensors?

Jeepforthewin 09-09-2013 12:11 PM

They are located in the wheel hub. And mine grinded too when it would short out due to the ABS and Trac light coming on.

jjarvis0007 09-09-2013 12:34 PM

Just the two front wheels on a 2005 JGC Limited 4.7?

Looks like O'Reillys has two of them but they say their for the rear tires? I only see what could be a sensor on both front wheel?

Jeepforthewin 09-09-2013 12:54 PM

Im not sure on the 4.7 but on my 5.7 we have wires that lead into the rear hub assemblies which these wires are for the Speed wheel sensor.

jjarvis0007 09-09-2013 01:04 PM

Quote:

Originally Posted by Jeepforthewin (Post 15889098)
Im not sure on the 4.7 but on my 5.7 we have wires that lead into the rear hub assemblies which these wires are for the Speed wheel sensor.

Disconnected the battery for a few minutes. Just left to run some errands and now there is no message. Thanks for all yalls help.

Jeepforthewin 09-09-2013 01:52 PM

Quote:

Originally Posted by jjarvis0007

Disconnected the battery for a few minutes. Just left to run some errands and now there is no message. Thanks for all yalls help.

Be careful with that. If it is a Speed wheel sensor it will come back. I almost got tboned cause my Jeep locked up halfway through a legal U-turn and I couldn't move then it finally released but I was almost hit cause of it. Just a heads up :thumbsup:

jjarvis0007 09-09-2013 02:10 PM

Quote:

Originally Posted by Jeepforthewin (Post 15889297)

Be careful with that. If it is a Speed wheel sensor it will come back. I almost got tboned cause my Jeep locked up halfway through a legal U-turn and I couldn't move then it finally released but I was almost hit cause of it. Just a heads up :thumbsup:

It just came back. It didnt lock up but the lights came back on.

jjarvis0007 09-09-2013 03:18 PM

Nevermind. Was turning into a 4 way intersection and it locked up as I was trying to go uphill. O'Reillys shows to have all 4 actually. 2 rears and 2 fronts. With the fronts being more expensive. I can't see anything on the rear though? I can see them on the front.

Jeepforthewin 09-09-2013 03:29 PM

Still no codes being thrown after the key dance? If the key dance isn't showing a DTC report at all auto zone can scan it for you.

jjarvis0007 09-09-2013 03:44 PM

No codes at all. Pulls up with dashes then says DTC Done. ABS light is on and ESP disabled light is on. Kind of scary. Didnt make it early this morning to the dealership for fixing the service 4wd system message. Went in earlier and he said to come back in the morning.
Hoping they can take care of the 4wd problem AGAIN and try to tell me which sensor it could be.
Is there a relay or fuse I can pull to stop it from throwing on the brakes while driving?

jjarvis0007 09-09-2013 05:13 PM

Just went to pick my wife up from work and now the darn thing is stumbling and dropping rpms to about 250-300.


The time now is 08:33 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.