Service 4wd system light - Page 4 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Service 4wd system light

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 01-05-2012, 12:16 PM   #46
boykinjw
Registered User
1997 TJ Wrangler 
 
Join Date: May 2010
Location: VA
Posts: 194
I still have the bag at home, I can check it for a part number in a couple hours after work if no one else has replied.

__________________
2005 WK Hemi QDII
1997 TJ 4.0, RC 4", 33x10.5 KM2
boykinjw is offline   Reply With Quote
Unread 01-05-2012, 12:26 PM   #47
LelandGray
Registered User
2005 WK 
 
Join Date: Aug 2010
Location: Tulsa, OK
Posts: 89
I just got off the phone with the dealership and got part #'s and prices..
Front diff solenoid - 52114003AF -$54
Harness - 52114327AC - $13.99
Rear diff solenoid - 52114003AF -$54
Harness - 52114328AC - $13.99
I can order the solenoid’s off the Internet for about $20 cheaper each, so I’ll probably go that route.
__________________
Silver WK Club Member #11
LelandGray is offline   Reply With Quote
Unread 01-05-2012, 12:32 PM   #48
boykinjw
Registered User
1997 TJ Wrangler 
 
Join Date: May 2010
Location: VA
Posts: 194
I got mine from a member on here named kolak. PM him and he can get you pricing
__________________
2005 WK Hemi QDII
1997 TJ 4.0, RC 4", 33x10.5 KM2
boykinjw is offline   Reply With Quote
Unread 01-21-2013, 06:40 PM   #49
kmarta
Registered User
 
Join Date: Jan 2013
Location: Irvine, CA
Posts: 1
Quote:
Originally Posted by ryanlberg View Post
So i have been dealing with this issue for 3 years now (the service 4x4 system and service electric brake system ) and no one can fix it had it in last week for a flash that worked for 3 days. i did allot of research and reading of threads on a few sites over the last 3days and compiled a list of what people have have fixed to solve the problem. so maybe this will help when trying to get this fixed. not sure if anyone wants this info but this is what i found.
1. LIMITED SLIP SENSOR IN AXLE
2. STEERING ANGLE SENSOR
3. SOLENOID IN DIFF
4. SHORTED OUT CONTROL WIRE GOING INTO THE REAR DIFF THE COMPONENT INSIDE THE DIFF WAS REPLACED INCLUDING WIRING
5. SENSOR ON TRANSFER CASE
6. ABS MODULE REPLACED
7. (FDCM) FINAL DRIVE CONTROL MODULE
8. TRANSFER CASE MOTOR
9. BRAKE LIGHT SWITCH
10. The service 4 wheel drive light came on intermittently for about a year. Jeep changed transmission sensors, axle sensors, re flashed the computers several times without any permanent fix. Finally I asked Jeep to trace the wiring harness and to check the resistance because the problem acted like a wire was grounding out. The dealership set some time aside to do this and they found a wire grounding out under the transmission housing, repaired it and it was the fix needed.

There is no service bulletin on this as far as I know. Some of the check engine light problems are from defective sensors. But if the normal diagnostics don't find the trouble, ask the dealership to check the wiring harness for a ground/short. A couple of Jeep mechanics have told me they have seen it several times.
Add to #9: Fuse for brake lights (15A located under the hood)

I have an '06 WK and the Service 4wd System light came on along with the traction control (squiggly lines behind a car on the right side) and the ESC/BAS light about a week ago while towing a 8k lb trailer and kept coming back even after I unhooked the trailer. I found this Thread to be really helpful but there were so many possibilities that I thought that I had really messed things up. Since I didn't notice anything bad I just kept driving it. The light kept coming on within 2 miles after I started the car and always when I was stopped at a light, weirdly it was always the same light. I was getting an alignment yesterday and the guys at Firestone told me I have a serious problem because the service 4wd light was on and there were no codes but also that my brake lights weren't working and I needed a new brake light switch (they said it would cost me $75 installed) which seemed odd because I never had to replace that so I just said thank you and left. Got home, popped the hood and low and behold the fuse for the brake lights was out. Not that surprised it blew because I spliced my trailer wiring into the rear brake lights, and leave it to Jeep not to provide a spare 15A fuse so I pulled the one for my radio until I could pick up a new one today and the warning lights are gone.

Also saw in an earlier post on this Thread about the Jeep Clunk sound from the front end. Originally thought it was the sway bar bushings so I changed those but the clunk was still there and I was in for an alignment because I just changed both inner and outer tie rods. Turns out I bent the drivers side inner tie rod and the outer ball joint on the passenger side was loose.

Anyway, I know this Thread is old but I just thought I'd add my experience to it in case anyone like me (a gearhead with no warranty and a limited budget) is still looking at it for answers. Now I can get back to enjoying my precious wk, clunk and warning light free...
kmarta is offline   Reply With Quote
Unread 01-22-2013, 10:57 AM   #50
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,809
Subscribed
__________________
2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline   Reply With Quote
Unread 02-12-2013, 01:06 PM   #51
cobrakillerta
Registered User
2006 WK 
 
Join Date: Sep 2009
Location: Long Island, NY
Posts: 104
Does anyone know what the correct torque sequence is for the front diff cover?
cobrakillerta is offline   Reply With Quote
Unread 02-13-2013, 06:37 PM   #52
mykdee311
Registered User
2005 WK 
 
Join Date: Sep 2011
Location: Salt Lake City, Utah
Posts: 158
Quote:
Originally Posted by cobrakillerta View Post
Does anyone know what the correct torque sequence is for the front diff cover?


pretty much any sequence until 44 ft.lb.
__________________
05 WK Limited, QDII, Hemi, Superchip, OME HD Lift, JBA UCA & disconnects, 4xGuard (Belly, Sliders, Rear Sliders, Diff), 255/75R17 on Moab's w/ 1.5" Spacer, Thule M.O.A.B. Basket
03 3500 Cummins, 79 Mustang 2.5T Stroker, 63 F250 428 4x4
mykdee311 is offline   Reply With Quote
Unread 03-30-2013, 05:20 PM   #53
phottomatt
Registered User
2010 JK Wrangler 
 
Join Date: Nov 2010
Location: Havertown, PA
Posts: 333
Good stuff sub'ed, I'm getting the "service 4WD system" intermittently, just ordered front solenoid and harness.
__________________
2010 Flame Red Sahara, Rough Country stubby bumper/winch, Body Armor rock sliders, stiff spring mod and RC 2.5" series II spacer lift (~3.5" total lift), 33X12.5 Duratracs on 15" MB72s.
2007 Grand Cherokee Limited, Red Rock, 5.7L HEMI
phottomatt is offline   Reply With Quote
Unread 03-31-2013, 10:27 AM   #54
dsjr2006
Registered User
2006 WK 
 
Join Date: May 2012
Location: Norton Shores, Michigan
Posts: 441
Quote:
Originally Posted by phottomatt
Good stuff sub'ed, I'm getting the "service 4WD system" intermittently, just ordered front solenoid and harness.
Do you know that it is the front that's out?
__________________
'06 Limited Hemi QDII - Icon Coilovers - OME Lift w/Bilsteins - 32" 265/65R18 Goodyear Duratracs on JK Sahara 18s - Smittybilt XRC10 Comp X20 Winch

05-08 WK Service Manual PDF: [url]http://bit.ly/VxI9z0[/url]
dsjr2006 is offline   Reply With Quote
Unread 03-31-2013, 10:39 AM   #55
phottomatt
Registered User
2010 JK Wrangler 
 
Join Date: Nov 2010
Location: Havertown, PA
Posts: 333
Quote:
Originally Posted by dsjr2006 View Post

Do you know that it is the front that's out?
No just a guess LOL but the solenoid is the same part no. so if replacing the front doesn't fix it I'll swap it to the rear, and the wiring harness was only $10 so it can't hurt to change that.
__________________
2010 Flame Red Sahara, Rough Country stubby bumper/winch, Body Armor rock sliders, stiff spring mod and RC 2.5" series II spacer lift (~3.5" total lift), 33X12.5 Duratracs on 15" MB72s.
2007 Grand Cherokee Limited, Red Rock, 5.7L HEMI
phottomatt is offline   Reply With Quote
Unread 04-01-2013, 03:24 PM   #56
kentman
Registered User
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,429
Front solenoid seems to be the issue normally.
__________________
'06 XK Limited, 5.7L, QD II, Black, 122K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 101K
kentman is offline   Reply With Quote
Unread 04-02-2013, 09:54 AM   #57
dsjr2006
Registered User
2006 WK 
 
Join Date: May 2012
Location: Norton Shores, Michigan
Posts: 441
Mine was rear.
__________________
'06 Limited Hemi QDII - Icon Coilovers - OME Lift w/Bilsteins - 32" 265/65R18 Goodyear Duratracs on JK Sahara 18s - Smittybilt XRC10 Comp X20 Winch

05-08 WK Service Manual PDF: [url]http://bit.ly/VxI9z0[/url]
dsjr2006 is offline   Reply With Quote
Unread 04-02-2013, 12:51 PM   #58
phottomatt
Registered User
2010 JK Wrangler 
 
Join Date: Nov 2010
Location: Havertown, PA
Posts: 333
Quote:
Originally Posted by dsjr2006 View Post
Mine was rear.
Did you do the harness also?

Anyone have a picture or description of where the front solenoid is, i can't find anything good on it. Thanks.
__________________
2010 Flame Red Sahara, Rough Country stubby bumper/winch, Body Armor rock sliders, stiff spring mod and RC 2.5" series II spacer lift (~3.5" total lift), 33X12.5 Duratracs on 15" MB72s.
2007 Grand Cherokee Limited, Red Rock, 5.7L HEMI
phottomatt is offline   Reply With Quote
Unread 04-04-2013, 12:31 PM   #59
dsjr2006
Registered User
2006 WK 
 
Join Date: May 2012
Location: Norton Shores, Michigan
Posts: 441
Quote:
Originally Posted by phottomatt

Did you do the harness also?

Anyone have a picture or description of where the front solenoid is, i can't find anything good on it. Thanks.
Starts at pg 3-141 of the service manual. See link in my sig.
__________________
'06 Limited Hemi QDII - Icon Coilovers - OME Lift w/Bilsteins - 32" 265/65R18 Goodyear Duratracs on JK Sahara 18s - Smittybilt XRC10 Comp X20 Winch

05-08 WK Service Manual PDF: [url]http://bit.ly/VxI9z0[/url]
dsjr2006 is offline   Reply With Quote
Unread 04-04-2013, 01:36 PM   #60
phottomatt
Registered User
2010 JK Wrangler 
 
Join Date: Nov 2010
Location: Havertown, PA
Posts: 333
Quote:
Originally Posted by dsjr2006 View Post

Starts at pg 3-141 of the service manual. See link in my sig.
Awesome thank you.
__________________
2010 Flame Red Sahara, Rough Country stubby bumper/winch, Body Armor rock sliders, stiff spring mod and RC 2.5" series II spacer lift (~3.5" total lift), 33X12.5 Duratracs on 15" MB72s.
2007 Grand Cherokee Limited, Red Rock, 5.7L HEMI
phottomatt is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.