JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   WK Grand Cherokee & XK Commander Forum (http://www.jeepforum.com/forum/f67/)
-   -   service 4WD system ........... (http://www.jeepforum.com/forum/f67/service-4wd-system-322460/)

karvr 10-01-2006 04:17 PM

service 4WD system ...........
 
hello, just bought an 06 grand cherokee with quadra trac 2, 4.7 V8, my wife and I were travelling with cruise on doing 110 km an hour when the chime went off and in the display was this message " service 4WD system " then it went out hasn't come back on since.Everything seems normal , near my house I went on some back roads and checked the low 4x4 mode, went in and out of low to high several times as per manuals instructions, works fine.....any ideas...thx in advance.

karvr 10-01-2006 05:13 PM

fix found
 
see link...i guess i'll bring it in to service soon....

http://www.wkjeeps.com/tsb/tsb_wk_2101406.pdf

k1llerkyle 10-09-2006 04:20 PM

There is a service bulletin on it. its a false reading. I got the same thing, they just have to flash the computer.

:rolleyes:

Podedwards 10-14-2006 01:45 PM

Service Four Wheel Drive System
 
It means that a sensor is bad (acting erratically) and needs to be replaced. Happened onmine-replaced no problem.

GCT00427 10-15-2006 03:22 AM

It may never come back on. It happened to me last year after I got my Rocky Mountain (Sept 26) on one cold morning as I was going to church. When I got out, it had already reset itself and has never reappeared.

If it doesn't come back on, don'e worry about it. If it does, you can always take it to the dealer.

Regards,

Chuck

karvr 10-15-2006 05:07 PM

final drive control module flashed
 
Hello thx for the replies, I had the final drive control module flashed with updated software......as per the technical bulletin I found. What annoy's me about this whole situation is that as a consumer I had to go into the dealer and ask them to do the work...they only do the reflash (or any technical bulletin)if the costumer ask's for it, they won't do it even if they know of it and your in there for say an oil change, I realize it is warranty work and they can't upsell warranty work. Thats fine with me I bookmarked the site for tsb's and will be sure to visit them when and if I see one pertaining to my vehicle.


Technical Service Bulletins
http://www.wkjeeps.com/wk_tsb.htm

cliff 10-16-2006 09:51 PM

2005 Cherokee Laredo
 
This past Friday, I bought a used 05 WK with the 3.7 and 4wd. with 20,000 miles. Got it off of eBay.


I am hearing a very slight growling sound coming from the front end when driving it. I have a 4wd 03 dodge pickup that does not have any noise at all from the front. However it is not full time like the 5Qdra Trac 1 system

This WK was a rental car, and apparently seems to be in good shape. It is still under factory warranty. I called the nearest jeep dealer today and spoke with the service dept. He said they would check it out.


Any of you folks ever noticed this kind of noise coming from the front end.

I am pleased with the jeep. I am getting about 22 mpg. I use it as a work car and drive it about 100 miles a day. Don't plan to do any serious off road driving with it at our ranch.


The time now is 10:28 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.