Service 4wd indicator + bad odor - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Service 4wd indicator + bad odor

Borla Exhaust presents "Climber" at EJSTactical Recovery Equipment Soft Shackles!!!Ring & Pinion's, Lockers, 4340 Axles, Install Kits, Ba

Reply
Unread 08-15-2014, 06:06 PM   #1
fred99x
Registered User
2008 WK 
 
Join Date: Sep 2006
Location: Edmonton, Alberta, Canada
Posts: 185
Service 4wd indicator + bad odor

My wife was complaining about a bad odor inside the cabin of the jeep (08 CRD Limited). She also mentioned that by the way the service 4WD indicator was coming up as well. Sure enough I drove the jeep to the store one day with no smell or issues but leaving the parking lot all of a sudden I had the odor in the cabin of the jeep and shortly after the service 4WD indicator lit up. The smell was mostly gone by the time I reached home. Tonight I decided to do an oil change on the jeep. When I was completed I had the jeep running while I put some things away in the garage. Suddenly I could smell the odor from the Jeep. I quickly popped the hood to see if I could figure out where the smell was coming from. I checked the vent from the front differential and sure enough that's where the smell was coming from. I also noticed that there was actually smoke coming from the outlet of the vent. Seeing as the jeep had not moved for sometime the smoke couldn't have been from overheating due to bearings gears or whatever. The smoke lasted for a short time and then stopped on its own. I'm thinking that it must be something electrical inside the differential. If it was a short of some kind you would think it would blow a fuse somewhere. I seem to remember reading in other posts about a solenoid inside the differentials. Is there anything else inside the differential that could possibly cause this?

fred99x is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.