recirculate - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > recirculate

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 10-03-2014, 03:11 PM   #1
nvrdone1
Registered User
2007 WK 
 
Join Date: Sep 2014
Location: duvall, wa
Posts: 25
recirculate

Just bought an 07 GC overland. Question on the recirculating air button.
When I push the button, the light flashes and then goes off. Don't know if its on recirculate or out side air. Any ideas?
Also, is there a search function on this site?
Thanks.

nvrdone1 is offline   Reply With Quote Quick reply to this message
Unread 10-03-2014, 03:37 PM   #2
Chirpz
Senior Member
 
Chirpz's Avatar
2007 WK 
 
Join Date: Aug 2009
Location: Battle Ground, Washington
Posts: 838
Quote:
Originally Posted by nvrdone1 View Post
Just bought an 07 GC overland. Question on the recirculating air button.
When I push the button, the light flashes and then goes off. Don't know if its on recirculate or out side air. Any ideas?
Also, is there a search function on this site?
Thanks.
Do you have a user manual. If so, read it. According to mine, the switch has a mind of its own...meaning, if you just leave it alone nothing happens. If you push it, it may work and it may not work depending on whether or not the computer thinks you need it. It is very annoying. No combination of button pushes will over-ride the computer's decision....believe me we have tried. We have to drive by this stinky dairy several times a week and when we push the button, it never works when we NEED it. After we pass the dairy, it decides to work after we keep fiddling.

That's the way it is with an 07 WK and I suspect yours is the same. If you discover some secret, let me know and we can put away our gas masks.
__________________
Chirpz
2007 WK 3.0L CRD, Quadradrive II, GDE EcoTune, DPF-Delete
4xGuard Front, Rear, Belly, & Side Rails, Factory Skids
EHM MOD, Garmin Mechanic EcoHD, K&N Filter (Deleted)
Chirpz is offline   Reply With Quote Quick reply to this message
Unread 10-03-2014, 03:38 PM   #3
Chirpz
Senior Member
 
Chirpz's Avatar
2007 WK 
 
Join Date: Aug 2009
Location: Battle Ground, Washington
Posts: 838
Oh...I forgot to mention...when it is really working, the red light stays ON. If it flashes and goes off, the computer thinks you deserve that fine smell or whatever.
__________________
Chirpz
2007 WK 3.0L CRD, Quadradrive II, GDE EcoTune, DPF-Delete
4xGuard Front, Rear, Belly, & Side Rails, Factory Skids
EHM MOD, Garmin Mechanic EcoHD, K&N Filter (Deleted)
Chirpz is offline   Reply With Quote Quick reply to this message
Unread 10-03-2014, 04:07 PM   #4
nvrdone1
Registered User
2007 WK 
 
Join Date: Sep 2014
Location: duvall, wa
Posts: 25
Ok thanks for the info. The selling dealer needs to get me an owners manual, so until then, Im in a "stinky" situation. Maybe the owners manual will also tell me why the auto up on my drivers window doesn't work. Only time will tell.
Thanks much
nvrdone1 is offline   Reply With Quote Quick reply to this message
Unread 10-03-2014, 05:15 PM   #5
colinzj
Registered User
2006 WK 
 
Join Date: Mar 2005
Location: Chandler, AZ
Posts: 1,511
Sounds like you're in automatic mode, in which case, as Chirpz said, it'll do what it wants. If the system has decided it needs to use the defroster (which it might be this time of year), it won't let you enable recirc since it's trying to keep the windshield clear. Under normal conditions in auto the LED will stay on and you'll have recirc for a couple minutes until it turns itself back off.

If you're in manual, on is on and off is off unless there's a problem with some part of the system.

While you're waiting on the dealer, you can download a copy of the owner's manual.
__________________
2006 WK Laredo 4x4 4.7L
1993 ZJ Laredo 4x4 4.0L Dead, sold, and rolling again
colinzj is online now   Reply With Quote Quick reply to this message
Unread 10-03-2014, 05:33 PM   #6
Keeslinger31
Registered User
2005 WK 
 
Join Date: Dec 2012
Location: , Missouri
Posts: 340
At least its not clicking really loud when you press the button thats what mine did so I replaced the actuator no more click but now it has a mind of its own, scanner seems to think the control panel is bad so I gave up
__________________
05 Hemi modified ome hd, bilsteins 255/70 grabber at2
Black WK # 126
Keeslinger31 is offline   Reply With Quote Quick reply to this message
Unread 10-04-2014, 11:59 PM   #7
Chirpz
Senior Member
 
Chirpz's Avatar
2007 WK 
 
Join Date: Aug 2009
Location: Battle Ground, Washington
Posts: 838
Quote:
Originally Posted by nvrdone1 View Post
Ok thanks for the info. The selling dealer needs to get me an owners manual, so until then, Im in a "stinky" situation. Maybe the owners manual will also tell me why the auto up on my drivers window doesn't work. Only time will tell.
Thanks much
Oh.... it is very common for the recirculation actuator gear to break off. If that has happened already, it is not too hard to fix. When your gear is broken, the light may light when you press the button but its really not doing anything. I recently replaced mine.

Also.... it is pretty common for the auto window not to work properly. My driver side seems to work fine most of the time but the passenger side always requires a little coaxing. If you google this problem you will find that it is pretty common.

Funny thing..... after we had a bad accident in which our passenger door was smashed so bad that it would no longer close and latch, the window started working fine. I was surprised that it didn't break. Then after the door was replaced, the window when back to its spotty manner of working. The repair shop made extra effort trying to fix it then pointed out the commonality of the problem. I told them it was an existing malady and not to fiddle with it any more.
__________________
Chirpz
2007 WK 3.0L CRD, Quadradrive II, GDE EcoTune, DPF-Delete
4xGuard Front, Rear, Belly, & Side Rails, Factory Skids
EHM MOD, Garmin Mechanic EcoHD, K&N Filter (Deleted)
Chirpz is offline   Reply With Quote Quick reply to this message
Unread 10-05-2014, 09:31 AM   #8
nvrdone1
Registered User
2007 WK 
 
Join Date: Sep 2014
Location: duvall, wa
Posts: 25
Took a long drive yesterday and had time to mess with the recirc setting. Found out that when the position switch is set at either of the 2 settings for defogging the windshield the recirc doesn't work. When it's in the vent or floor mode the recirc stays on. Seems weird but I guess that's normal for this car. On my wife's Acura TL and my Pathfinder recerc works no matter what setting the vent / defrost/ heater is on.
Now on to the windows. Maybe I can just turn of the auto up.
nvrdone1 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.