recall 2005 to 2010 Grand Cherokees, 2006 to 2010 Commanders - Page 8 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > recall 2005 to 2010 Grand Cherokees, 2006 to 2010 Commanders

Savvy/Currie Aluminum Control ArmsROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO December Specials at Jeephut.com

Reply
Unread 08-21-2013, 09:04 AM   #106
R32R1
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: South County, RI
Posts: 209
Quote:
Originally Posted by jjarvis0007 View Post
I just talked to a shop foremen from a local Jeep dealer and he said it was a knucklehead not following the protocol on how to flash the system. He ended up being the foremen of the shop where I took my Jeep too.
Question is, if the flash was done, can they still start from the 1st step and do it over again? Or are they limited to just clearing DTCs at that point...

R32R1 is offline   Reply With Quote Quick reply to this message
Unread 08-21-2013, 03:17 PM   #107
longboy
Registered User
2006 WK 
 
Join Date: Nov 2006
Location: Longmont, Colorado
Posts: 915
Just picked up my WK from the dealer. Flash was done and no DTCs or "Service 4wd System" messages. I tested Low range before and after the service just to be sure, all is good.
__________________
2006 WK
longboy is offline   Reply With Quote Quick reply to this message
Unread 08-22-2013, 01:49 PM   #108
RockinR
Registered User
2006 XK Commander 
 
Join Date: Jul 2013
Location: Del Rio, Texas
Posts: 41
Quote:
Originally Posted by blue3 View Post
I am glad I checked this thread before I headed in for the recall!

Is there a need to periodically run in 4Lo, other than to verify function before you might need to use it? Also, don't understand why you roll backwards.
There is no need to periodically run 4Lo, in fact it could be harmful if done on a dry surface for an extended period. I just do it for my own satisfaction, to make parts move, and I only roll a few yards. Why backwards, is just because I do this as I am leaving the driveway.
RockinR is offline   Reply With Quote Quick reply to this message
Unread 08-22-2013, 02:29 PM   #109
R32R1
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: South County, RI
Posts: 209
Quote:
Originally Posted by RockinR View Post
There is no need to periodically run 4Lo, in fact it could be harmful if done on a dry surface for an extended period. I just do it for my own satisfaction, to make parts move, and I only roll a few yards. Why backwards, is just because I do this as I am leaving the driveway.
Yes, for smoother engagement you should be rolling about 1/2mph. This should also only be done on dirt or slippery conditions. You will load up the drivetrain if you engage 4lo and drive around on dry pavement. End result would be a louder clunk when going back to 4hi- no bueno.
R32R1 is offline   Reply With Quote Quick reply to this message
Unread 08-23-2013, 04:32 PM   #110
Walt
Registered User
2008 WK 
 
Join Date: Oct 2009
Location: Midland, MI
Posts: 1,535
Had the N23 recall FDCM flash performed this morning. Another item checked off the list.

I checked 4Lo operation before and they checked its operation afterwards. [Dealer also did the free 23-point safety inspection while it was in.]
__________________
HEMI CLUB MEMBER #45; SILVER WK CLUB MEMBER #13
'08 WK GC Limited. 5.7L HEMI. Quadra-Trac II. Bright Silver Metallic. Class IV hitch.
Michelin LTX M/S tires. Fumoto oil drain valve. Billet Technology oil catch can.
Walt is offline   Reply With Quote Quick reply to this message
Unread 08-23-2013, 07:01 PM   #111
R32R1
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: South County, RI
Posts: 209
Okay so I went back today, brought the recall checklist, and now have 4lo. Apparently, they didn't follow it to a 'T'
R32R1 is offline   Reply With Quote Quick reply to this message
Unread 08-24-2013, 10:30 PM   #112
ChrisWK
Registered User
2005 WK 
 
Join Date: Mar 2011
Location: Atlanta, Ga.
Posts: 131
Man if the dealership does not know how to flash it right and screw something up and want charge you for the stupid **** I think I will not do this recall I use my ebrake all the time.
__________________
Limited HEMI Dark Khaki Pearl SRT8 Full Body Kit, Roof Rails,SRT8 Engine Strut Bar, Lund Rear Spoiler, MYGIG INSTALLED with LOCKPICK, Kenwood Sub,AFE Intake, Taylor Spark Plug Wires,G2 Silver Painted Brake Calipers, Billet Tech Catch Can, Addco Sway Bars Front and Rear, Eibach Lowering Springs,Xenon Volt HID Lows 6k,Chrome SRT Reps
ChrisWK is offline   Reply With Quote Quick reply to this message
Unread 08-24-2013, 10:40 PM   #113
Bounty Hunter
Registered User
 
Join Date: Feb 2003
Location: Southern Illinois
Posts: 12
Had mine done. It took a few extra minutes for them to clear the 'Service 4wd System' trouble code but it cleared fine. No problems since, 4lo works as it should.

You should get it done. If you have any doubts, print the PDF and take it in. Point out the section about the possibility of a trouble code and how to clear it. Easy peasy.
__________________
'95 YJ 2.5L
Bounty Hunter is offline   Reply With Quote Quick reply to this message
Unread 08-25-2013, 08:03 AM   #114
R32R1
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: South County, RI
Posts: 209
Quote:
Originally Posted by ChrisWK View Post
Man if the dealership does not know how to flash it right and screw something up and want charge you for the stupid **** I think I will not do this recall I use my ebrake all the time.
Yea any doubt, show them 4lo works and make them notate that in the service order. If it wasnt for this forum,it might have been an oversight
R32R1 is offline   Reply With Quote Quick reply to this message
Unread 08-25-2013, 09:47 AM   #115
Walt
Registered User
2008 WK 
 
Join Date: Oct 2009
Location: Midland, MI
Posts: 1,535
Quote:
Originally Posted by R32R1 View Post
Yea any doubt, show them 4lo works and make them notate that in the service order....
That's exactly what I did. Had them test it afterward also.
__________________
HEMI CLUB MEMBER #45; SILVER WK CLUB MEMBER #13
'08 WK GC Limited. 5.7L HEMI. Quadra-Trac II. Bright Silver Metallic. Class IV hitch.
Michelin LTX M/S tires. Fumoto oil drain valve. Billet Technology oil catch can.
Walt is offline   Reply With Quote Quick reply to this message
Unread 08-25-2013, 10:47 AM   #116
ecollins7
Registered User
2006 WK 
 
Join Date: Sep 2011
Location: baltimore, Maryland
Posts: 438
I had the code and yesterday they told me they screwed up and didn't follow the recall properly. It now works as it should.
ecollins7 is offline   Reply With Quote Quick reply to this message
Unread 08-25-2013, 05:33 PM   #117
GregK340
Registered User
2007 WK 
 
Join Date: Oct 2011
Location: Liverpool, NY
Posts: 87
Quote:
Originally Posted by ecollins7 View Post
I had the code and yesterday they told me they screwed up and didn't follow the recall properly. It now works as it should.
At least they were honest about it.
GregK340 is offline   Reply With Quote Quick reply to this message
Unread 08-25-2013, 05:55 PM   #118
ecollins7
Registered User
2006 WK 
 
Join Date: Sep 2011
Location: baltimore, Maryland
Posts: 438
Yeah, I wasn't a big fan of this dealership in the first place and didn't feel like driving 45 minutes to the next one. Their honesty helped their rep with me.
ecollins7 is offline   Reply With Quote Quick reply to this message
Unread 08-25-2013, 07:50 PM   #119
RockinR
Registered User
2006 XK Commander 
 
Join Date: Jul 2013
Location: Del Rio, Texas
Posts: 41
After having mine done twice now, I checked out the 4Lo system yesterday. I got the "Service 4WD System" message again with no T-case movement. It was working last week. I guess it will be another trip to the dealer this week. I wish I had never done the recall.
RockinR is offline   Reply With Quote Quick reply to this message
Unread 08-26-2013, 08:53 AM   #120
R32R1
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: South County, RI
Posts: 209
Quote:
Originally Posted by RockinR View Post
After having mine done twice now, I checked out the 4Lo system yesterday. I got the "Service 4WD System" message again with no T-case movement. It was working last week. I guess it will be another trip to the dealer this week. I wish I had never done the recall.
Download the PDF with the step-by-step instructions on it. If they don't follow them exactly, it will not work. Most guys plug the tool in and hit update, as usual...its not the same.
R32R1 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.