recall 2005 to 2010 Grand Cherokees, 2006 to 2010 Commanders - Page 5 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > recall 2005 to 2010 Grand Cherokees, 2006 to 2010 Commanders

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe ULTIMATE "Selectable" Locker System! BroughFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 08-15-2013, 09:44 PM   #61
98jgc
Registered User
2005 WK 
 
Join Date: May 2006
Location: Oneonta, NY
Posts: 424
Got my follow up notice today about doing the re flash on my 4.7 QTII. Is there anything to worry about them screwing up something ? More importantly, will this add like 15 horsepower ??

98jgc is offline   Reply With Quote
Unread 08-16-2013, 04:54 PM   #62
Walt
Registered User
2008 WK 
 
Join Date: Oct 2009
Location: Midland, MI
Posts: 1,519
Finally got the second notice. I was going to schedule an appointment for today, however......after reading several posts about post-flash issues, I decided to hold off and talk to the Service Manager first.

Seems as though some WK's have had issues like failure to engage 4-Lo and 4wd MIL's once the Final Drive Control Module software is updated. I do not want another set of problems to solve right now.
__________________
HEMI CLUB MEMBER #45; SILVER WK CLUB MEMBER #13
'08 WK GC Limited. 5.7L HEMI. Quadra-Trac II. Bright Silver Metallic. Class IV hitch.
Michelin LTX M/S tires. Fumoto oil drain valve. Billet Technology oil catch can.
Walt is offline   Reply With Quote
Unread 08-16-2013, 05:04 PM   #63
Walt
Registered User
2008 WK 
 
Join Date: Oct 2009
Location: Midland, MI
Posts: 1,519
Finally got the second notice. I was going to schedule an appointment for today, however......after reading several posts about post-flash issues, I decided to hold off and talk to the Service Manager first.

Seems as though some WK's have had issues like failure to engage 4-Lo and 4wd MIL's once the Final Drive Control Module software is updated. I do not want another set of problems to solve right now.
__________________
HEMI CLUB MEMBER #45; SILVER WK CLUB MEMBER #13
'08 WK GC Limited. 5.7L HEMI. Quadra-Trac II. Bright Silver Metallic. Class IV hitch.
Michelin LTX M/S tires. Fumoto oil drain valve. Billet Technology oil catch can.
Walt is offline   Reply With Quote
Unread 08-16-2013, 11:03 PM   #64
bmac13579
Registered User
2007 WK 
 
Join Date: Sep 2012
Location: Swedesboro, NJ
Posts: 29
Okay. So I'm not the only one who has now encountered issues due to the recall 'fix'?

Apparently now I cannot shift into 4lo and I get the 'Service 4 Wheel Drive System' message.
Maybe one of my sensors just coincidently decided to stop working, but maybe I'm crazy.

Is this the common issue? Or are there others?
__________________
2007 WK - Silver WK Club Member #71, 4.7L V8, 5 spd Auto, Autobot Decal (grfxedge.com), Aspen Creek Front Tow Shackles, Factory Tow Hitch
Check out more pictures and info here: www.mywk.tumblr.com
bmac13579 is offline   Reply With Quote
Unread 08-17-2013, 05:33 AM   #65
JeepN4KC
Keep on Jeepin on........
 
JeepN4KC's Avatar
 
Join Date: Jul 2011
Location: Blue Springs, MO
Posts: 5,103
Quote:
Originally Posted by Walt View Post
Finally got the second notice. I was going to schedule an appointment for today, however......after reading several posts about post-flash issues, I decided to hold off and talk to the Service Manager first.

Seems as though some WK's have had issues like failure to engage 4-Lo and 4wd MIL's once the Final Drive Control Module software is updated. I do not want another set of problems to solve right now.
Just got my "we know how to fix it now" recall notice yesterday.

I dunno if I'll take mine in because I've had zero issues with my transfer case - and it recently got a pretty good workout.

"If it ain't broke don't fix it" is at the front of my mind.
__________________
~Mike~

My Build Thread WK
My Other Build Thread XJ
'01 XJ with some stuff
Sept 2013 Cherokee of the Month
'07 WK with some other stuff
~RED WK CLUB #7~
'11 KK with mostly stock stuff
'06WK our first Jeep with stock stuff - totalled and gone
JeepN4KC is offline   Reply With Quote
Unread 08-18-2013, 06:18 PM   #66
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 399
Got my 2nd notice in the mail yesterday. Not sure what I'm going to do with it as of now? My 4wd Lo works just fine. I guess I can tell the service manager about other people having these problems after the flash. If I decide to take it in this week I'll definitely check it once I get there and once its done. I always use the parking brake when parking
jjarvis0007 is offline   Reply With Quote
Unread 08-18-2013, 07:11 PM   #67
modernblueWK
Registered User
 
Join Date: Jan 2010
Location: Gunnison, CO
Posts: 1,665
2nd notice here too. I spent 2 days in 4low recently. I have no major incentive to update it until i know thry wont screw it up.
__________________
2008 wk 4.7 v8 Laredo X QTII - 245/70-17 at2 - Magnflow 13742
Blue WK club #4
2013 HEMI Durango Awd Crew. All stock
modernblueWK is offline   Reply With Quote
Unread 08-18-2013, 07:41 PM   #68
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR, AR
Posts: 399
Spending two days in 4Lo seems like fun
jjarvis0007 is offline   Reply With Quote
Unread 08-18-2013, 09:51 PM   #69
modernblueWK
Registered User
 
Join Date: Jan 2010
Location: Gunnison, CO
Posts: 1,665
On purpose. Did a few trails around here.
__________________
2008 wk 4.7 v8 Laredo X QTII - 245/70-17 at2 - Magnflow 13742
Blue WK club #4
2013 HEMI Durango Awd Crew. All stock
modernblueWK is offline   Reply With Quote
Unread 08-19-2013, 05:34 AM   #70
R32R1
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: South County, RI
Posts: 209
So far it looks like resetting the code is the only thing that might work? Anybody else have a fix for this?
R32R1 is offline   Reply With Quote
Unread 08-19-2013, 05:48 AM   #71
LJS8510
Web Wheeler
 
LJS8510's Avatar
2008 WK 
 
Join Date: Oct 2007
Location: Chicago Il, IL
Posts: 1,312
I got my notice, I'll have them do it but also will make them aware of the potential 4-lo problem.
Although I'm not sure it has be confirmed that it has been a problem?
__________________

08 CRD @ 163,000
OME HD Lift about 3"
4xGuard Rails
Stillens
AEV Wheels 5.75 BS
JBA UCA's
GSA 255/75/17 32.1" (no bolt cut/no pinch weld)
spare 265/70/17 stock location
Lockpic, 100,000 club
LJS8510 is offline   Reply With Quote
Unread 08-19-2013, 06:11 AM   #72
R32R1
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: South County, RI
Posts: 209
Quote:
Originally Posted by LJS8510 View Post
I got my notice, I'll have them do it but also will make them aware of the potential 4-lo problem.
Although I'm not sure it has be confirmed that it has been a problem?
I'm going to say it's a problem. I bet Chrysler will send out another notice fixing this one...
R32R1 is offline   Reply With Quote
Unread 08-19-2013, 06:18 AM   #73
R32R1
Registered User
2006 WK 
 
Join Date: Oct 2011
Location: South County, RI
Posts: 209
I'm on the phone with the recall center. Apparently this is the 'first' report of the 'Service 4WD System'.

IF YOU ARE EXPERIENCING 'SERVICE 4WD SYSTEM':

Please call this number- 1-800-853-1403

Report the problem with the last 8 of your VIN. Chrysler advised it's not a problem until more people report it. I wish we can do a roll-back to the previous software release
R32R1 is offline   Reply With Quote
Unread 08-19-2013, 07:01 AM   #74
LJS8510
Web Wheeler
 
LJS8510's Avatar
2008 WK 
 
Join Date: Oct 2007
Location: Chicago Il, IL
Posts: 1,312
R32R1
You could not go into 4-low after the recall fix?
__________________

08 CRD @ 163,000
OME HD Lift about 3"
4xGuard Rails
Stillens
AEV Wheels 5.75 BS
JBA UCA's
GSA 255/75/17 32.1" (no bolt cut/no pinch weld)
spare 265/70/17 stock location
Lockpic, 100,000 club
LJS8510 is offline   Reply With Quote
Unread 08-19-2013, 08:32 AM   #75
LouC
Registered User
2007 WK 
 
Join Date: Feb 2008
Location: NY
Posts: 1,171
I just had mine done (used the wk to launch my boat and thought what if it did in fact shift to neutral) shifted to low 4x and it works just like before.
__________________
2007 WK Limited Hemi QDII
1998 ZJ Laredo 4.0 Selectrac
LouC is online now   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.