recall 2005 to 2010 Grand Cherokees, 2006 to 2010 Commanders - Page 11 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #151 of 301 Old 09-10-2013, 06:59 AM
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR
Posts: 410
Quote:
Originally Posted by R32R1 View Post
Not to play devils advocate, but mine gets close to dying sometimes too; it's not the flash. They do that and multiple people on here (way before the flash came out) have experienced this. The flash only focuses on that one module and nothing else. Anyone who is saying they saw differences, etc, is just prone to the placebo effect.
I'm not gonna lie it has dropped rpms before but never died. Never had the other messages either.

jjarvis0007 is offline  
Sponsored Links
Advertisement
 
post #152 of 301 Old 09-10-2013, 10:25 AM
Dusty280
Registered User
2008 WK 
 
Join Date: Nov 2007
Location: Green Bay, WI
Posts: 78
speed sensor assembly

Well the dealer says it is not the flash this caused my loss of power but rather is the speed sensor assembly. this part is on back order. cost to fix replace is about $800. I am finally getting use out of the insurance I bought with the vehicle. I have to pay the $100 deductible. I am waiting for a call back on how long they think it will take to get the part in.
Dusty280 is offline  
post #153 of 301 Old 09-10-2013, 10:33 AM
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR
Posts: 410
Quote:
Originally Posted by Dusty280 View Post
Well the dealer says it is not the flash this caused my loss of power but rather is the speed sensor assembly. this part is on back order. cost to fix replace is about $800. I am finally getting use out of the insurance I bought with the vehicle. I have to pay the $100 deductible. I am waiting for a call back on how long they think it will take to get the part in.
Were you getting any warning messages or DTC's?
jjarvis0007 is offline  
post #154 of 301 Old 09-10-2013, 11:05 AM
Dusty280
Registered User
2008 WK 
 
Join Date: Nov 2007
Location: Green Bay, WI
Posts: 78
P0700 is what came up. I had loss of power (like the transmission was slipping or it was starting out in overdrive, except it reved properly). Happened twice shortly after the dealer did the recall fix. If you look up the P0700 code it says it is the Transaxle control module. Then you need a tool to read what the transaxle code is. Apparently mine said speed sensor assembly.
Dusty280 is offline  
post #155 of 301 Old 09-11-2013, 08:03 AM
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR
Posts: 410
Sitting back at the dealership waiting on them to do the recall for the 3rd time.
jjarvis0007 is offline  
post #156 of 301 Old 09-11-2013, 08:54 AM
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR
Posts: 410
I have a case # now to work with Chrysler on getting the transfer case actuator replaced. They cleared the codes 4 times according to the recall. The case is stating that the N23 Recall causes the actuator to mess up. The actuator is $490 and they are backordered 30 from Chrysler as of now with more expected to be on hold. I'll take a pic of this paper if you think it'll help anyone with their decision of not doing it. I wouldn't advise it. Use the parking brake until Chrysler comes out with another solution.
jjarvis0007 is offline  
post #157 of 301 Old 09-11-2013, 09:01 AM
bytehoven
Registered User
2014 KL Cherokee 
 
Join Date: Oct 2009
Location: The 1st State
Posts: 176
OK...

2009 JGC Limited with QTII and QD II. I had the flash done once and ended up with the service 4WD system error. I took the vehicle in for the 2nd time on Tuesday and they determined it was the actuator and were able to order a new part. The part came in today and will be installed tomorrow.

The service manager was unaware of any 3 repair/flash rule regarding replacing the actuator and apparently the part is not on back order. Perhaps the part is back ordered depending on region of the US.

I will post a follow up tomorrow after the replacement of the actuator. All costs covered under powertrain warranty.
bytehoven is offline  
post #158 of 301 Old 09-11-2013, 09:46 AM
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR
Posts: 410
So you're paying $490 for the actuator and labor?



I was told by the shop foreman to deal with Chrysler on this issue and not to buy it.
jjarvis0007 is offline  
post #159 of 301 Old 09-12-2013, 01:12 PM
bytehoven
Registered User
2014 KL Cherokee 
 
Join Date: Oct 2009
Location: The 1st State
Posts: 176
Update...

My '09 WK went in for the recall repair today...
1- 08525301 Motor/Actuator - Transfer caser shifter motor
1- 5143786AA Actuator Fuel Control
1- Install S/O Transfer Case Reflash Final Drive

Time to repair was just over an hour. No charge for the repair. The repair was covered under the life time drivetrain warranty.

The repair appears to have fixed the "service 4WD system" error message when shifting in 4LO.

I will report back any failures to the 4WD system going forward.

...
bytehoven is offline  
post #160 of 301 Old 09-12-2013, 01:19 PM
modernblueWK
Web Wheeler
 
Join Date: Jan 2010
Location: Gunnison, CO
Posts: 2,620
Did you pay for any parts? The recall is a flash only.

SOLD 2008 WK 4.7 V8 Build/Adventure Thread
2013 Hemi Durango Crew
2007 Silverado Crewcab LT3
modernblueWK is offline  
post #161 of 301 Old 09-12-2013, 01:24 PM
bytehoven
Registered User
2014 KL Cherokee 
 
Join Date: Oct 2009
Location: The 1st State
Posts: 176
Quote:
Originally Posted by modernblueWK View Post
Did you pay for any parts? The recall is a flash only.
No charge for the repair. The repair was covered under the life time drivetrain warranty.
bytehoven is offline  
post #162 of 301 Old 09-16-2013, 08:58 AM
earyck790
Registered User
 
Join Date: May 2009
Location: Ohio
Posts: 16
had it done to mine and wish i didnt!

Since noone replyed to my thread about this I'll rant here;

4LO SEEMS fine no problem there yet???!!! Knocks on wood!

but my a/c took a **** on me (no cold up frnt)!
recirc door gear broke (I don't think this is a coincidence but I dont have 80 bucks to waste to prove it's not.)

and I had my check engine light came on but I think that might be due to my tranny and dif fluids needin changed?

Anyone else??
earyck790 is offline  
post #163 of 301 Old 09-16-2013, 09:18 AM
RockinR
Registered User
2006 XK Commander 
 
Join Date: Jul 2013
Location: Del Rio
Posts: 40
Quote:
Originally Posted by R32R1 View Post
Not to play devils advocate, but mine gets close to dying sometimes too; it's not the flash. They do that and multiple people on here (way before the flash came out) have experienced this. The flash only focuses on that one module and nothing else. Anyone who is saying they saw differences, etc, is just prone to the placebo effect.
After 3 flash proceedures, my dealer diagnosed a bad transfer case actuator (motor). They replaced it this morning, took a little over 1 hour, under full warrenty. All works fine, finally.
RockinR is offline  
post #164 of 301 Old 09-16-2013, 09:22 AM
RockinR
Registered User
2006 XK Commander 
 
Join Date: Jul 2013
Location: Del Rio
Posts: 40
Quote:
Originally Posted by jjarvis0007 View Post
So you're paying $490 for the actuator and labor?



I was told by the shop foreman to deal with Chrysler on this issue and not to buy it.
If you have less than 100,000 miles, it should be covered under the power train warrenty. My Commander has a little over 90,000 and they gave me a new actuator this morning under warrenty. Contact Jeep customer service. I am not actually sure that it isn't covered under the recall.
RockinR is offline  
post #165 of 301 Old 09-20-2013, 10:41 AM
jjarvis0007
Registered User
2005 WK 
 
Join Date: Apr 2013
Location: NLR
Posts: 410
Quote:
Originally Posted by RockinR View Post

If you have less than 100,000 miles, it should be covered under the power train warrenty. My Commander has a little over 90,000 and they gave me a new actuator this morning under warrenty. Contact Jeep customer service. I am not actually sure that it isn't covered under the recall.
Even if I'm the 2nd or 3rd owner?
jjarvis0007 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome