random question about something I've never felt before - JeepForum.com

LinkBack Thread Tools
post #1 of 2 Old 08-27-2013, 02:41 PM Thread Starter
Registered User
2011 JK Wrangler 
Join Date: Aug 2013
Location: Palmetto
Posts: 61
random question about something I've never felt before

Ok so I drive an 05 wk. Tires are in need of replacing soon but now this past week something strange has been going on when braking. When approaching a stoplight or stop sign or anything and I apply the brakes, its doing a funny kind of brake, release, brake, release, brake, release feeling. I still seem to be stopping fine its not like I'm locking tires up its only when I'm gradually breaking that it does this. Any thoughts on what this could be?

jeremymayflower is offline  
Sponsored Links
post #2 of 2 Old 08-27-2013, 03:02 PM
Registered User
2004 WJ 
Join Date: Dec 2011
Location: Oakmont
Posts: 350
Warped rotors? I had the same problem on my WJ and replacing the rotors fixed it
lafacej is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome